aboutsummaryrefslogtreecommitdiff
path: root/sysutils/conky
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2010-03-07 13:03:42 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2010-03-07 13:03:42 +0000
commit49e869c313701afa31e607f38ed34146db4e2360 (patch)
treedc9d0d99b92bcdaa01a4f76f620b19f0899c72e5 /sysutils/conky
parent21942fb8ceace282898715e79418c3367db50946 (diff)
downloadports-49e869c313701afa31e607f38ed34146db4e2360.tar.gz
ports-49e869c313701afa31e607f38ed34146db4e2360.zip
Notes
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile30
-rw-r--r--sysutils/conky/files/patch-configure9
2 files changed, 34 insertions, 5 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index dbf2a7e0d8c4..9af714806134 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -7,12 +7,12 @@
PORTNAME= conky
PORTVERSION= 1.7.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils
MASTER_SITES= SF
-MAINTAINER?= ntarmos@cs.uoi.gr
-COMMENT?= An advanced, highly configurable system monitor for X
+MAINTAINER= ntarmos@cs.uoi.gr
+COMMENT= An advanced, highly configurable system monitor for X
CONFLICTS?= conky-awesome-[0-9]*
SLAVEDIRS= sysutils/conky-awesome
@@ -26,7 +26,6 @@ USE_ICONV= yes
USE_GMAKE= yes
CONFIGURE_ARGS+= --disable-portmon \
--disable-hddtemp \
- --disable-apcupsd \
--disable-iostats
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -37,10 +36,13 @@ PORTEXAMPLES= conkyrc.sample
PORTDOCS= README AUTHORS ChangeLog TODO NEWS \
docs.html variables.html config_settings.html
-OPTIONS+= AUDACIOUS "Enable Audacious support" Off \
+OPTIONS+= APCUPSD "Enable APCUPSD support" Off \
+ AUDACIOUS "Enable Audacious support" Off \
BMPX "Enable BMPX support" Off \
MPD "Enable MPD support" Off \
RSS "Enable RSS support" Off \
+ METAR "Enable METAR Weather support" Off \
+ XOAP "Enable XOAP Weather support" Off \
XMMS2 "Enable XMMS2 support" Off
.if !empty(USE_XORG)
@@ -65,6 +67,13 @@ CONFIGURE_ARGS+= --disable-x11 --disable-own-window
.undef WITH_XFT
.endif
+.if defined(WITH_APCUPSD)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/apcupsd:${PORTSDIR}/sysutils/apcupsd
+CONFIGURE_ARGS+= --enable-apcupsd
+.else
+CONFIGURE_ARGS+= --disable-apcupsd
+.endif
+
.if defined(WITH_AUDACIOUS)
LIB_DEPENDS+= audclient.2:${PORTSDIR}/multimedia/audacious
CONFIGURE_ARGS+= --enable-audacious
@@ -124,6 +133,17 @@ CONFIGURE_ARGS+= --enable-rss
USE_GNOME+= glib20
.endif
+.if defined(WITH_METAR)
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --enable-weather-metar
+.endif
+
+.if defined(WITH_XOAP)
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+CONFIGURE_ARGS+= --enable-weather-xoap
+.endif
+
.if defined(WITH_XMMS2)
LIB_DEPENDS+= xmmsclient.5:${PORTSDIR}/audio/xmms2
CONFIGURE_ARGS+= --enable-xmms2
diff --git a/sysutils/conky/files/patch-configure b/sysutils/conky/files/patch-configure
index 74cd4d428180..cebc6f7c9049 100644
--- a/sysutils/conky/files/patch-configure
+++ b/sysutils/conky/files/patch-configure
@@ -1,5 +1,14 @@
--- configure.orig
+++ configure
+@@ -12805,7 +12805,7 @@
+
+
+ if test x$want_apcupsd = xyes; then
+- if test x"$uname" != xLinux; then
++ if test x"$uname" != xLinux -a x"$uname" != xFreeBSD; then
+ { $as_echo "$as_me:$LINENO: apcupsd not supported on $uname... disabling" >&5
+ $as_echo "$as_me: apcupsd not supported on $uname... disabling" >&6;}
+ want_apcupsd=no
@@ -15930,7 +15930,7 @@
fi