aboutsummaryrefslogtreecommitdiff
path: root/sysutils/conky
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-13 23:47:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-13 23:47:55 +0000
commit001ece54483d0daf408a34a324a3738d080ffdeb (patch)
treeb685583009af7ad9b8d636b25dd142e9ad8fe7ab /sysutils/conky
parentb9a9b5145b7f5e9a96a688f2d74507866d96c1fd (diff)
Notes
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile66
-rw-r--r--sysutils/conky/distinfo6
-rw-r--r--sysutils/conky/files/patch-src-conf_cookie.c14
-rw-r--r--sysutils/conky/files/patch-src-freebsd.h10
-rw-r--r--sysutils/conky/pkg-plist4
5 files changed, 39 insertions, 61 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 689f3e7d84e2..ec732f1fc146 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= conky
-PORTVERSION= 1.7.0
-PORTREVISION= 1
+PORTVERSION= 1.7.1.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -24,16 +23,27 @@ USE_XORG?= x11 xext xdamage
USE_GNOME?= pkgconfig
USE_ICONV= yes
CONFIGURE_ARGS+= --disable-portmon \
- --disable-config-output \
--disable-hddtemp
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
MAN1= conky.1
-
+PLIST_FILES= bin/conky
+PORTEXAMPLES= conkyrc.sample
PORTDOCS= README AUTHORS ChangeLog TODO NEWS \
docs.html variables.html config_settings.html
+OPTIONS+= AUDACIOUS "Enable Audacious support" Off \
+ BMPX "Enable BMPX support" Off \
+ DOUBLE_BUFFER "Enable double buffering" On \
+ IMLIB2 "Enable Imlib2 support" Off \
+ LUA "Enable Lua support" Off \
+ MPD "Enable MPD support" Off \
+ XFT "Enable Xft support" Off \
+ XMMS2 "Enable XMMS2 support" Off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_AUDACIOUS)
LIB_DEPENDS+= audclient.2:${PORTSDIR}/multimedia/audacious
CONFIGURE_ARGS+= --enable-audacious
@@ -50,6 +60,20 @@ CONFIGURE_ARGS+= --enable-bmpx
CONFIGURE_ARGS+= --disable-bmpx
.endif
+.if defined(WITH_LUA)
+USE_LUA= 5.1+
+CONFIGURE_ARGS+= --enable-lua
+.else
+CONFIGURE_ARGS+= --disable-lua
+.endif
+
+.if defined(WITH_IMLIB2)
+LIB_DEPENDS+= Imlib2.5:${PORTSDIR}/graphics/imlib2
+CONFIGURE_ARGS+= --enable-imlib2
+.else
+CONFIGURE_ARGS+= --disable-imlib2
+.endif
+
.if defined(WITH_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFIGURE_ARGS+= --enable-xft
@@ -57,15 +81,7 @@ CONFIGURE_ARGS+= --enable-xft
CONFIGURE_ARGS+= --disable-xft
.endif
-#.if !defined(WITHOUT_OWN_WINDOW)
-#CONFIGURE_ARGS+= --enable-own-window
-#.else
-#CONFIGURE_ARGS+= --disable-own-window
-#.endif
-
-.if defined(WITH_MPD)
-CONFIGURE_ARGS+= --enable-mpd
-.else
+.if defined(WITHOUT_MPD)
CONFIGURE_ARGS+= --disable-mpd
.endif
@@ -80,29 +96,19 @@ CONFIGURE_ARGS+= --disable-xmms2
CONFIGURE_ARGS+= --disable-double-buffer
.endif
-.if defined(WITHOUT_SETI)
-CONFIGURE_ARGS+= --disable-seti
-.endif
-
-pre-everything::
- @${ECHO_MSG} "You may specify the following on the command line:"
- @${ECHO_MSG} " "
- @${ECHO_MSG} "WITH_AUDACIOUS=yes to enable Audacious support"
- @${ECHO_MSG} "WITH_BMPX=yes to enable BMPx support"
- @${ECHO_MSG} "WITH_XFT=yes to enable XFT support"
- @${ECHO_MSG} "WITHOUT_OWN_WINDOW=yes to disable own window support"
- @${ECHO_MSG} "WITH_MPD=yes to enable MPD support"
- @${ECHO_MSG} "WITH_XMMS2=yes to enable XMMS2 support"
- @${ECHO_MSG} "WITHOUT_DOUBLE_BUFFER=yes to disable double buffer support"
- @${ECHO_MSG} " "
+post-patch:
+ @${REINPLACE_CMD} -e 's,lua5\.1,lua-5.1,g' \
+ ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/conky ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/conky.1 ${PREFIX}/man/man1
post-install:
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/data/conky.conf ${EXAMPLESDIR}/conkyrc.sample
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -114,4 +120,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/conky/distinfo b/sysutils/conky/distinfo
index 94470aad3915..b73fe4d42ed8 100644
--- a/sysutils/conky/distinfo
+++ b/sysutils/conky/distinfo
@@ -1,3 +1,3 @@
-MD5 (conky-1.7.0.tar.bz2) = 10360c37d76ab25f4d585bcdfd07f075
-SHA256 (conky-1.7.0.tar.bz2) = 088594166c33a03fc5aacb63ecb15a6b83ffb80dc3aa40e1f10b897ca1733355
-SIZE (conky-1.7.0.tar.bz2) = 478369
+MD5 (conky-1.7.1.1.tar.bz2) = 153a661e78a466c95b1b332e7cd599cb
+SHA256 (conky-1.7.1.1.tar.bz2) = aa7277c01dc5da407f12b27ae4d6b6ab72f24667d60818e9be28e7bdf26cd3ca
+SIZE (conky-1.7.1.1.tar.bz2) = 512566
diff --git a/sysutils/conky/files/patch-src-conf_cookie.c b/sysutils/conky/files/patch-src-conf_cookie.c
deleted file mode 100644
index 542caf288847..000000000000
--- a/sysutils/conky/files/patch-src-conf_cookie.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/conf_cookie.c.orig 2009-05-03 12:39:27.000000000 +0300
-+++ src/conf_cookie.c 2009-05-03 12:39:48.000000000 +0300
-@@ -23,11 +23,3 @@
- }
- return i;
- }
--
--cookie_io_functions_t conf_cookie = {
-- .read = &conf_read,
-- .write = NULL,
-- .seek = NULL,
-- .close = NULL,
--};
--
diff --git a/sysutils/conky/files/patch-src-freebsd.h b/sysutils/conky/files/patch-src-freebsd.h
deleted file mode 100644
index 57a9651983cb..000000000000
--- a/sysutils/conky/files/patch-src-freebsd.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/freebsd.h.orig 2009-05-03 20:22:29.000000000 +0300
-+++ src/freebsd.h 2009-05-03 20:22:11.000000000 +0300
-@@ -2,6 +2,7 @@
- #define FREEBSD_H_
-
- #include "common.h"
-+#include <sys/param.h>
- #include <sys/mount.h>
- #include <sys/ucred.h>
- #include <fcntl.h>
diff --git a/sysutils/conky/pkg-plist b/sysutils/conky/pkg-plist
deleted file mode 100644
index b9484c49cce2..000000000000
--- a/sysutils/conky/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@comment $FreeBSD$
-bin/conky
-%%EXAMPLESDIR%%/conkyrc.sample
-@dirrm %%EXAMPLESDIR%%