aboutsummaryrefslogtreecommitdiff
path: root/sysutils/consul-alerts
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-06-05 12:59:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-06-05 12:59:09 +0000
commit5819b981b111985653b2137081f503c3da97e7cf (patch)
tree03d5e57a6d7f0b1c7c3e91fe5ed634e1a6297538 /sysutils/consul-alerts
parentc7c9d908bc98d5f91aeef608c3767fc06831f22b (diff)
Notes
Diffstat (limited to 'sysutils/consul-alerts')
-rw-r--r--sysutils/consul-alerts/Makefile37
-rw-r--r--sysutils/consul-alerts/distinfo14
-rw-r--r--sysutils/consul-alerts/files/patch-consul-alerts.go11
3 files changed, 23 insertions, 39 deletions
diff --git a/sysutils/consul-alerts/Makefile b/sysutils/consul-alerts/Makefile
index fee4c6b2f414..35695899fc33 100644
--- a/sysutils/consul-alerts/Makefile
+++ b/sysutils/consul-alerts/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= consul-alerts
-PORTVERSION= 0.4.0
+PORTVERSION= 0.5.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= jhixson@gmail.com
@@ -13,37 +12,29 @@ LICENSE= GPLv2+
BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
-USES= compiler
+USES= compiler go
USE_GITHUB= yes
-GH_ACCOUNT= AcalephStorage aws:aws_sdk_go
-GH_PROJECT= aws-sdk-go:aws_sdk_go
-GH_TAGNAME= v1.5.12:aws_sdk_go
-GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+GH_ACCOUNT= AcalephStorage
+GH_SUBDIR= src/github.com/AcalephStorage/consul-alerts
+GH_TUPLE= aws:aws-sdk-go:v1.8.30:aws_sdk_go/src/github.com/aws/aws-sdk-go \
+ imdario:mergo:0.2.2:mergo/src/github.com/imdario/mergo \
+ mitchellh:hashstructure:9204ce5:hashstructure/src/github.com/mitchellh/hashstructure
-PLIST_FILES= ${PREFIX}/bin/consul-alerts
+PLIST_FILES= ${PREFIX}/bin/${PORTNAME}
-USE_RC_SUBR= consul-alerts
+USE_RC_SUBR= ${PORTNAME}
STRIP= #none
-post-patch:
- @${MKDIR} ${WRKDIR}/src/github.com/AcalephStorage
- @${MV} ${WRKSRC} \
- ${WRKDIR}/src/github.com/AcalephStorage/consul-alerts
- @${MKDIR} ${WRKDIR}/src/github.com/aws
- @${MV} ${WRKSRC_aws_sdk_go} \
- ${WRKDIR}/src/github.com/aws/aws-sdk-go
-
do-build:
- @cd ${WRKDIR}/src/github.com/AcalephStorage/consul-alerts; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKDIR} go build -v -x \
- -ldflags "-X main.GitDescribe=v${PORTVERSION}" -o bin/consul-alerts
+ cd ${GO_WRKSRC} && \
+ ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
+ -ldflags "-X main.GitDescribe=${DISTVERSIONFULL}" -o bin/${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} \
- ${WRKDIR}/src/github.com/AcalephStorage/consul-alerts/bin/consul-alerts \
- ${STAGEDIR}${PREFIX}/bin/consul-alerts
+ ${INSTALL_PROGRAM} ${GO_WRKSRC}/bin/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.pre.mk>
diff --git a/sysutils/consul-alerts/distinfo b/sysutils/consul-alerts/distinfo
index 5303c9e10029..57c9442b2e94 100644
--- a/sysutils/consul-alerts/distinfo
+++ b/sysutils/consul-alerts/distinfo
@@ -1,5 +1,9 @@
-TIMESTAMP = 1480575830
-SHA256 (AcalephStorage-consul-alerts-v0.4.0_GH0.tar.gz) = 6d77e61e29bc4bda77465a01cd78c50690edc703f8e97b34c954bdb4bd4ff15c
-SIZE (AcalephStorage-consul-alerts-v0.4.0_GH0.tar.gz) = 221117
-SHA256 (aws-aws-sdk-go-v1.5.12_GH0.tar.gz) = 0287ef280424d38227ed6aaa3cc50b2ceebaea8f73a57a8f2cd9dc24b6434280
-SIZE (aws-aws-sdk-go-v1.5.12_GH0.tar.gz) = 5078095
+TIMESTAMP = 1495844279
+SHA256 (AcalephStorage-consul-alerts-v0.5.0_GH0.tar.gz) = 2f6b8e1c0c58a1b84ff0b24655f86da1325f4124eaa24fd45bc1b4cc324ef360
+SIZE (AcalephStorage-consul-alerts-v0.5.0_GH0.tar.gz) = 242042
+SHA256 (aws-aws-sdk-go-v1.8.30_GH0.tar.gz) = 8467f39202e19299738eae2c0ec1e5475798b2bd02110d64efe824abe912210e
+SIZE (aws-aws-sdk-go-v1.8.30_GH0.tar.gz) = 6784740
+SHA256 (imdario-mergo-0.2.2_GH0.tar.gz) = 06ff82ceeea1a2d5e5064867a8e3c581ad9c1fc8e243afc673b7b8c94f28d4cf
+SIZE (imdario-mergo-0.2.2_GH0.tar.gz) = 9415
+SHA256 (mitchellh-hashstructure-9204ce5_GH0.tar.gz) = c3e9599761f944c6bcc7c6e7d92df40e32f247c471a02b02a079817d4ccf2afc
+SIZE (mitchellh-hashstructure-9204ce5_GH0.tar.gz) = 6460
diff --git a/sysutils/consul-alerts/files/patch-consul-alerts.go b/sysutils/consul-alerts/files/patch-consul-alerts.go
deleted file mode 100644
index d600f086d9c8..000000000000
--- a/sysutils/consul-alerts/files/patch-consul-alerts.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- consul-alerts.go.orig 2016-11-30 21:41:15.770397000 -0800
-+++ consul-alerts.go 2016-11-30 21:41:25.037217000 -0800
-@@ -20,7 +20,7 @@
- "github.com/AcalephStorage/consul-alerts/Godeps/_workspace/src/github.com/docopt/docopt-go"
- )
-
--const version = "Consul Alerts 0.3.3"
-+const version = "Consul Alerts 0.4.0"
- const usage = `Consul Alerts.
-
- Usage: