aboutsummaryrefslogtreecommitdiff
path: root/sysutils/coreutils/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2014-01-24 01:01:53 +0000
committerJason Helfman <jgh@FreeBSD.org>2014-01-24 01:01:53 +0000
commit8e9e1e56528289a754486644f192c1722227244c (patch)
tree9b8ed0058034cc9a7ccdd981c5082e775c622989 /sysutils/coreutils/Makefile
parentc7dd9d68a4474075e096a1187601c25659514d44 (diff)
downloadports-8e9e1e56528289a754486644f192c1722227244c.tar.gz
ports-8e9e1e56528289a754486644f192c1722227244c.zip
Notes
Diffstat (limited to 'sysutils/coreutils/Makefile')
-rw-r--r--sysutils/coreutils/Makefile49
1 files changed, 12 insertions, 37 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index deaf069e4a1c..3ee2bd00c414 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= coreutils
-PORTVERSION= 8.20
-PORTREVISION= 2
+PORTVERSION= 8.22
CATEGORIES= sysutils textproc
-MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITES= GNU
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jharris@widomaker.com
@@ -30,47 +29,19 @@ USES= gmake perl5
USE_PERL5= build # build - required for tests and man page generation
USE_XZ= yes
USE_LDCONFIG= yes
-#USE_BISON= yes
INFO= coreutils
-MAN1= gbasename.1 gcat.1 gchcon.1 gchgrp.1 gchmod.1 gchown.1 gchroot.1 \
- gcksum.1 gcomm.1 gcp.1 gcsplit.1 gcut.1 gdate.1 gdd.1 gdf.1 gdir.1 \
- gdircolors.1 gdirname.1 gdu.1 gecho.1 genv.1 gexpand.1 gexpr.1 \
- gfactor.1 gfalse.1 gfmt.1 gfold.1 ggroups.1 ghead.1 ghostid.1 \
- gid.1 ginstall.1 gjoin.1 gkill.1 glink.1 gln.1 \
- glogname.1 gls.1 gmd5sum.1 gmkdir.1 gmkfifo.1 gmknod.1 gmktemp.1 \
- gmv.1 gnice.1 gnl.1 gnohup.1 god.1 gpaste.1 gpathchk.1 gpinky.1 \
- gpr.1 gprintenv.1 gprintf.1 gptx.1 gpwd.1 greadlink.1 grealpath.1 grm.1 \
- grmdir.1 gruncon.1 gseq.1 gsha1sum.1 gshred.1 gsleep.1 gsort.1 \
- gsplit.1 gstdbuf.1 gnustat.1 gstty.1 gsum.1 gsync.1 gtac.1 \
- gtail.1 gtee.1 gtest.1 gtimeout.1 gtouch.1 gtr.1 gtrue.1 gtruncate.1 \
- gtsort.1 gtty.1 guname.1 gunexpand.1 guniq.1 gunlink.1 guptime.1 \
- gusers.1 gvdir.1 gwc.1 gwho.1 gwhoami.1 gyes.1 gbase64.1 gsha224sum.1 \
- gsha256sum.1 gsha384sum.1 gsha512sum.1 gshuf.1 gnproc.1
-
OPTIONS_DEFINE= GMP NLS
OPTIONS_DEFAULT=NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+GMP_CONFIGURE_ENABLE= gmp
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGMP}
-LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
-.else
-CONFIGURE_ARGS+=--without-gmp
-.endif
-
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} >= 800039
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-stty.c
.endif
@@ -78,7 +49,11 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-stty.c
post-build:
@${REINPLACE_CMD} -e "s/ lib / /g" ${WRKSRC}/Makefile
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/g* \
+ ${STAGEDIR}${PREFIX}/libexec/coreutils/glibstdbuf.so
+
#regression-test: build
# (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>