aboutsummaryrefslogtreecommitdiff
path: root/sysutils/coreutils/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-17 01:30:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-17 01:30:15 +0000
commit4a2e1af213351825dec4a2a4ce15225bce3259ab (patch)
tree103209f576fa7574daa3024ee1a456428c326886 /sysutils/coreutils/Makefile
parent6984f7b2cb9c3eab761d01f30c86de5d7b89ef73 (diff)
downloadports-4a2e1af213351825dec4a2a4ce15225bce3259ab.tar.gz
ports-4a2e1af213351825dec4a2a4ce15225bce3259ab.zip
Notes
Diffstat (limited to 'sysutils/coreutils/Makefile')
-rw-r--r--sysutils/coreutils/Makefile70
1 files changed, 70 insertions, 0 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
new file mode 100644
index 000000000000..8828fdcb02cb
--- /dev/null
+++ b/sysutils/coreutils/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: coreutils
+# Date created: 18 November 2003
+# Whom: Jason Harris <jharris@widomaker.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= coreutils
+PORTVERSION= 5.0
+CATEGORIES= sysutils textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= jharris@widomaker.com
+COMMENT= The Free Software Foundation's core utilities
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+
+CONFLICTS= sh-utils-* fileutils-* textutils-* id-utils-*
+
+# Global variables
+#
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS= --program-prefix=g
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+USE_GMAKE= yes
+
+INFO= coreutils
+
+MAN1= gbasename.1 gcat.1 gchgrp.1 gchmod.1 gchown.1 gchroot.1 gcksum.1 \
+ gcomm.1 gcp.1 gcsplit.1 gcut.1 gdate.1 gdd.1 gdf.1 gdir.1 \
+ gdircolors.1 gdirname.1 gdu.1 gecho.1 genv.1 gexpand.1 gexpr.1 \
+ gfactor.1 gfalse.1 gfmt.1 gfold.1 ggroups.1 ghead.1 ghostid.1 \
+ ghostname.1 gid.1 ginstall.1 gjoin.1 glink.1 gln.1 glogname.1 gls.1 \
+ gmd5sum.1 gmkdir.1 gmkfifo.1 gmknod.1 gmv.1 gnice.1 gnl.1 gnohup.1 \
+ god.1 gpaste.1 gpathchk.1 gpinky.1 gpr.1 gprintenv.1 gprintf.1 gptx.1 \
+ gpwd.1 greadlink.1 grm.1 grmdir.1 gseq.1 gsha1sum.1 gshred.1 gsleep.1 \
+ gsort.1 gsplit.1 gstat.1 gstty.1 gsu.1 gsum.1 gsync.1 gtac.1 gtail.1 \
+ gtee.1 gtest.1 gtouch.1 gtr.1 gtrue.1 gtsort.1 gtty.1 guname.1 \
+ gunexpand.1 guniq.1 gunlink.1 guptime.1 gusers.1 gvdir.1 gwc.1 gwho.1 \
+ gwhoami.1 gyes.1
+
+# Local variables
+#
+
+INSTALL_INFO?= install-info
+
+# Patch
+#
+
+post-patch:
+.if !defined(WITH_SUID)
+ @${REINPLACE_CMD} -e "s/u\+s/u\+w/g" ${WRKSRC}/src/Makefile.in
+.endif
+
+# Post-install
+#
+
+post-install: install-info
+
+install-info:
+ @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME}.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>