aboutsummaryrefslogtreecommitdiff
path: root/sysutils/coreutils
diff options
context:
space:
mode:
authorJeremy Chadwick <koitsu@FreeBSD.org>2008-08-29 02:36:25 +0000
committerJeremy Chadwick <koitsu@FreeBSD.org>2008-08-29 02:36:25 +0000
commit0f313cf5f3a6632bd14f04ee8c1ead22d22e34d5 (patch)
tree4af04ef80c8596ff55791ad80732e38baee069db /sysutils/coreutils
parent6fb1378c86b9fb99ffa658fdf2165dc2ad2b50bc (diff)
downloadports-0f313cf5f3a6632bd14f04ee8c1ead22d22e34d5.tar.gz
ports-0f313cf5f3a6632bd14f04ee8c1ead22d22e34d5.zip
Notes
Diffstat (limited to 'sysutils/coreutils')
-rw-r--r--sysutils/coreutils/Makefile2
-rw-r--r--sysutils/coreutils/files/extra-patch-stty.c32
2 files changed, 19 insertions, 15 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index dbee798a8611..b1a74f17a763 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -52,7 +52,7 @@ MAN1= gbasename.1 gcat.1 gchgrp.1 gchmod.1 gchown.1 gchroot.1 gcksum.1 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800000
+.if ${OSVERSION} >= 800039
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-stty.c
.endif
diff --git a/sysutils/coreutils/files/extra-patch-stty.c b/sysutils/coreutils/files/extra-patch-stty.c
index 8734e33e9665..8704c918a4dc 100644
--- a/sysutils/coreutils/files/extra-patch-stty.c
+++ b/sysutils/coreutils/files/extra-patch-stty.c
@@ -1,16 +1,20 @@
--- src/stty.c.orig 2007-03-18 14:36:43.000000000 -0700
-+++ src/stty.c 2008-08-28 04:43:28.000000000 -0700
-@@ -45,6 +45,13 @@
++++ src/stty.c 2008-08-28 18:54:40.000000000 -0700
+@@ -282,8 +282,6 @@
#endif
- #ifdef HAVE_SYS_IOCTL_H
- # include <sys/ioctl.h>
-+/*
-+ * XXX - Workaround for missing TAB1 and TAB2 bits on 8.0-CURRENT;
-+ * available in src/ioctl_compat.h, only when _KERNEL is defined.
-+ */
-+# define _KERNEL
-+# include <sys/ioctl_compat.h>
-+# undef _KERNEL
- #endif
-
- #ifdef WINSIZE_IN_PTEM
+ #ifdef TABDLY
+ {"tab3", output, SANE_UNSET, TAB3, TABDLY},
+- {"tab2", output, SANE_UNSET, TAB2, TABDLY},
+- {"tab1", output, SANE_UNSET, TAB1, TABDLY},
+ {"tab0", output, SANE_SET, TAB0, TABDLY},
+ #else
+ # ifdef OXTABS
+@@ -632,7 +630,7 @@
+ fputs (_("\
+ * [-]onocr do not print carriage returns in the first column\n\
+ [-]opost postprocess output\n\
+- * tabN horizontal tab delay style, N in [0..3]\n\
++ * tabN horizontal tab delay style, N in [0,3]\n\
+ * tabs same as tab0\n\
+ * -tabs same as tab3\n\
+ * vtN vertical tab delay style, N in [0..1]\n\