aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cotty
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-17 06:33:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-17 06:33:00 +0000
commite93762eb546b2b6cda6466a9351a54da518a6929 (patch)
tree475093f6b952db1bcf4616fd27d0848b5bda5643 /sysutils/cotty
parentf0772a5f5e04df0ab247a7b6fcfce4260425cd36 (diff)
downloadports-e93762eb546b2b6cda6466a9351a54da518a6929.tar.gz
ports-e93762eb546b2b6cda6466a9351a54da518a6929.zip
Notes
Diffstat (limited to 'sysutils/cotty')
-rw-r--r--sysutils/cotty/Makefile27
-rw-r--r--sysutils/cotty/distinfo1
-rw-r--r--sysutils/cotty/pkg-comment1
-rw-r--r--sysutils/cotty/pkg-descr10
-rw-r--r--sysutils/cotty/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/cotty/Makefile b/sysutils/cotty/Makefile
new file mode 100644
index 000000000000..291a0b762157
--- /dev/null
+++ b/sysutils/cotty/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cotty
+# Date created: 26 January 2001
+# Whom: Oliver Breuninger <ob@breuninger.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cotty
+PORTVERSION= 0.4c
+CATEGORIES= sysutils
+MASTER_SITES= http://fare.tunes.org/files/fwprc/
+EXTRACT_SUFX= .c.gz
+
+MAINTAINER= ob@breuninger.org
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${GZCAT}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= > ${WRKSRC}/${DISTNAME}.c
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/cotty ${WRKSRC}/${DISTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cotty ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/cotty/distinfo b/sysutils/cotty/distinfo
new file mode 100644
index 000000000000..17e4acb917ef
--- /dev/null
+++ b/sysutils/cotty/distinfo
@@ -0,0 +1 @@
+MD5 (cotty-0.4c.c.gz) = a0603589857faeeb7d102b678233641e
diff --git a/sysutils/cotty/pkg-comment b/sysutils/cotty/pkg-comment
new file mode 100644
index 000000000000..132f0e6e9421
--- /dev/null
+++ b/sysutils/cotty/pkg-comment
@@ -0,0 +1 @@
+Simple command-line pseudo terminal manager
diff --git a/sysutils/cotty/pkg-descr b/sysutils/cotty/pkg-descr
new file mode 100644
index 000000000000..19f2c95e211c
--- /dev/null
+++ b/sysutils/cotty/pkg-descr
@@ -0,0 +1,10 @@
+Simple command-line pseudo terminal manager:
+allows to run coprocesses talking to each other thru their tty and/or pty.
+
+Most useful to drive from scripts programs that want a tty, as in
+ cotty -d -- pppd silent 192.168.0.1:192.168.0.2 \
+ -- ssh -t root@remote pppd
+This particular use has been obsoleted under Linux
+(but probably not under the various free BSDs and proprietary Unices),
+as it can be done without cotty with
+ pppd pty 'ssh -t root@remote pppd' silent 192.168.0.1:192.168.0.2
diff --git a/sysutils/cotty/pkg-plist b/sysutils/cotty/pkg-plist
new file mode 100644
index 000000000000..1bce4096c291
--- /dev/null
+++ b/sysutils/cotty/pkg-plist
@@ -0,0 +1 @@
+bin/cotty