aboutsummaryrefslogtreecommitdiff
path: root/sysutils/crashme
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 06:03:49 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 06:03:49 +0000
commitdb82fd31f26cbf4ff05cc7c616b4766602631322 (patch)
treeb24c62304c09f33e5c9f93340235b9f5924df955 /sysutils/crashme
parentfa5d0c0b55bf15d7a15bd26b3985d5da69229322 (diff)
downloadports-db82fd31f26cbf4ff05cc7c616b4766602631322.tar.gz
ports-db82fd31f26cbf4ff05cc7c616b4766602631322.zip
Notes
Diffstat (limited to 'sysutils/crashme')
-rw-r--r--sysutils/crashme/Makefile27
-rw-r--r--sysutils/crashme/distinfo1
-rw-r--r--sysutils/crashme/pkg-comment1
-rw-r--r--sysutils/crashme/pkg-descr10
-rw-r--r--sysutils/crashme/pkg-plist2
5 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/crashme/Makefile b/sysutils/crashme/Makefile
new file mode 100644
index 000000000000..3bc31c752d60
--- /dev/null
+++ b/sysutils/crashme/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: crashme
+# Date created: Apr 1, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crashme
+PORTVERSION= 2.4
+CATEGORIES= sysutils
+MASTER_SITES= http://people.delphi.com/gjc/
+DISTNAME= crashme
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mark@kyne.com.au
+
+USE_GMAKE= yes
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile
+MAN1= crashme.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/crashme ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pddet ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/crashme.man ${PREFIX}/man/man1/crashme.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/crashme/distinfo b/sysutils/crashme/distinfo
new file mode 100644
index 000000000000..11280a6a89d6
--- /dev/null
+++ b/sysutils/crashme/distinfo
@@ -0,0 +1 @@
+MD5 (crashme.tgz) = 8a1e115adbfd1fd175bd0c49f87f3589
diff --git a/sysutils/crashme/pkg-comment b/sysutils/crashme/pkg-comment
new file mode 100644
index 000000000000..132277246682
--- /dev/null
+++ b/sysutils/crashme/pkg-comment
@@ -0,0 +1 @@
+A tool to test an operating system's robustness
diff --git a/sysutils/crashme/pkg-descr b/sysutils/crashme/pkg-descr
new file mode 100644
index 000000000000..59028b330d63
--- /dev/null
+++ b/sysutils/crashme/pkg-descr
@@ -0,0 +1,10 @@
+Crashme is a very simple program that tests the operating
+environment's robustness by invoking random data as if it were a
+procedure. The standard signals are caught and handled with a setjmp
+back to a loop which will try again to produce a fault by executing
+random data. Some people call this stress testing.
+
+WWW: http://people.delphi.com/gjc/crashme.html
+
+- Mark Pulford
+mark@kyne.com.au
diff --git a/sysutils/crashme/pkg-plist b/sysutils/crashme/pkg-plist
new file mode 100644
index 000000000000..ad1aa76c9364
--- /dev/null
+++ b/sysutils/crashme/pkg-plist
@@ -0,0 +1,2 @@
+bin/crashme
+bin/pddet