aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cromwell
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:29:04 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:29:04 +0000
commitb882a2132c31dda66546e40706fffb73dab8af3b (patch)
treee4d82341c21500f586fc29674518ee13fcce70f1 /sysutils/cromwell
parent0694735737dbc60d44107eef0b44c0c5256541d6 (diff)
downloadports-b882a2132c31dda66546e40706fffb73dab8af3b.tar.gz
ports-b882a2132c31dda66546e40706fffb73dab8af3b.zip
Notes
Diffstat (limited to 'sysutils/cromwell')
-rw-r--r--sysutils/cromwell/Makefile61
-rw-r--r--sysutils/cromwell/distinfo6
-rw-r--r--sysutils/cromwell/files/pkg-message.in11
-rw-r--r--sysutils/cromwell/pkg-descr6
4 files changed, 84 insertions, 0 deletions
diff --git a/sysutils/cromwell/Makefile b/sysutils/cromwell/Makefile
new file mode 100644
index 000000000000..f97fd68219de
--- /dev/null
+++ b/sysutils/cromwell/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: cromwell
+# Date created: 8 March 2006
+# Whom: Rink Springer <rink@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cromwell
+PORTVERSION= 20060308
+CATEGORIES= sysutils
+MASTER_SITES= http://rink.nu/downloads/xbox/
+DISTNAME= cromwell-snapshot-${PORTVERSION}
+
+# This patch allows Cromwell to load kernels directly from UFS partitions
+PATCH_SITES= http://rink.nu/downloads/xbox-patches/
+PATCHFILES= cromwell-ufs.diff
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= rink@FreeBSD.org
+COMMENT= Linux (and FreeBSD :-) BIOS images for the Microsoft Xbox
+
+USE_PERL5_BUILD= yes
+
+SUB_FILES= pkg-message
+
+PLIST_DIRS= %%DATADIR%%
+PLIST_FILES= %%DATADIR%%/cromwell.bin \
+ %%DATADIR%%/cromwell_1024.bin \
+ %%DATADIR%%/ethboot \
+ %%DATADIR%%/xromwell.xbe
+
+# Xbox is an i386 box, mostly
+ONLY_FOR_ARCHS= i386
+
+WRKSRC= ${WRKDIR}/cromwell
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Not supported below 5.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,perl,${PERL},g' \
+ -e 's,^CC.=,CC ?=,' \
+ -e 's,CFLAGS=,CFLAGS+=,' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/cromwell/image/cromwell.bin ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/cromwell/image/cromwell_1024.bin ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/cromwell/boot_eth/ethboot ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/cromwell/xbe/xromwell.xbe ${DATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cromwell/distinfo b/sysutils/cromwell/distinfo
new file mode 100644
index 000000000000..b05209c78917
--- /dev/null
+++ b/sysutils/cromwell/distinfo
@@ -0,0 +1,6 @@
+MD5 (cromwell-snapshot-20060308.tar.bz2) = 2a2cb2d059e7b663faee99404751ede5
+SHA256 (cromwell-snapshot-20060308.tar.bz2) = 2dc344bb72ed7d0a21dfb15125d758d46a86e0aab0e3e49c6cecdfdfa1c0631e
+SIZE (cromwell-snapshot-20060308.tar.bz2) = 991871
+MD5 (cromwell-ufs.diff) = a73e22b9717d61e5b4d2c9517a308dee
+SHA256 (cromwell-ufs.diff) = bcfce0638cf5279f6bb3110a3cfc594daee434be5450596ddf14a149296315c1
+SIZE (cromwell-ufs.diff) = 81387
diff --git a/sysutils/cromwell/files/pkg-message.in b/sysutils/cromwell/files/pkg-message.in
new file mode 100644
index 000000000000..d325bbceb55b
--- /dev/null
+++ b/sysutils/cromwell/files/pkg-message.in
@@ -0,0 +1,11 @@
+The following files have been installed in %%PREFIX%%/share/cromwell:
+
+- cromwell.bin, cromwell_1024.bin
+ Images flashable to the Xbox EEPROM (for Xboxes < 1.6), using the
+ sysutils/raincoat port.
+
+- ethboot
+ ELF image which can be netbooted.
+
+- xromwell.xbe
+ XBE image which can be loaded using 'alternative' Dashboard versions.
diff --git a/sysutils/cromwell/pkg-descr b/sysutils/cromwell/pkg-descr
new file mode 100644
index 000000000000..c68aa8fe61a0
--- /dev/null
+++ b/sysutils/cromwell/pkg-descr
@@ -0,0 +1,6 @@
+Cromwell is a 100% open source BIOS for the Microsoft Xbox. Its original intent
+is to boot Linux on the Xbox, but later versions can boot FreeBSD as well.
+
+As there have been no recent releases, this version was checked out of the
+SourceForge xbox-linux CVS. An patch is provided to allow Cromwell to load
+kernels from UFS partitions.