aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cronic
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2016-04-27 11:15:42 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2016-04-27 11:15:42 +0000
commit5fa4ad2b761fff91f9758f717eaae32ecb48cd20 (patch)
tree35a22c7d0c2e2ed8a528f0c40d691b17aaa2b630 /sysutils/cronic
parent4fe6527cd300589a13c5f3cf73e2edfb5b4cc594 (diff)
sysutils/cronic: NEW PORT - Shell script that handles cron error detection
Cronic is a small shim shell script for wrapping cron jobs so that cron only sends email when an error has occurred. Cronic defines an error as any non-trace error output or a non-zero result code. Cronic filters Bash execution traces (or anything matching PS4) from the error output, so jobs can be run with execution tracing to aid forensic debugging. WWW: http://habilis.net/cronic PR: 208747 Submitted by: David Harrigan <dharrigan@gmail.com>
Notes
Notes: svn path=/head/; revision=414100
Diffstat (limited to 'sysutils/cronic')
-rw-r--r--sysutils/cronic/Makefile33
-rw-r--r--sysutils/cronic/distinfo2
-rw-r--r--sysutils/cronic/pkg-descr7
3 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/cronic/Makefile b/sysutils/cronic/Makefile
new file mode 100644
index 000000000000..df47611b9fe8
--- /dev/null
+++ b/sysutils/cronic/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= cronic
+PORTVERSION= 3
+CATEGORIES= sysutils
+MASTER_SITES= http://habilis.net/cronic/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+EXTRACT_SUFX=
+
+MAINTAINER= dharrigan@gmail.com
+COMMENT= Shell script that handles cron error detection
+
+LICENSE= CC0-1.0
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= shebangfix
+NO_WRKSUBDIR= yes
+NO_ARCH= yes
+NO_BUILD= yes
+
+SHEBANG_FILES= ${PORTNAME}-v${PORTVERSION}
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/cronic/distinfo b/sysutils/cronic/distinfo
new file mode 100644
index 000000000000..256ba8d9d720
--- /dev/null
+++ b/sysutils/cronic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cronic-v3) = 25d9772e142ebdcaa72433431e26d855ae82b085709faf0d2169b3bda867aeac
+SIZE (cronic-v3) = 854
diff --git a/sysutils/cronic/pkg-descr b/sysutils/cronic/pkg-descr
new file mode 100644
index 000000000000..d3fe8b64157a
--- /dev/null
+++ b/sysutils/cronic/pkg-descr
@@ -0,0 +1,7 @@
+Cronic is a small shim shell script for wrapping cron jobs so that cron only
+sends email when an error has occurred. Cronic defines an error as any
+non-trace error output or a non-zero result code. Cronic filters Bash
+execution traces (or anything matching PS4) from the error output, so jobs can
+be run with execution tracing to aid forensic debugging.
+
+WWW: http://habilis.net/cronic