aboutsummaryrefslogtreecommitdiff
path: root/sysutils/curly
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-01-16 14:53:01 +0000
committerCy Schubert <cy@FreeBSD.org>2012-01-16 14:53:01 +0000
commit7a5498b47165b29c43ffda219ee73a43b2d84335 (patch)
tree6cf56ee34caff0104234b0196bf0955721333c6c /sysutils/curly
parent246ec6f46b61ec3bc2adb89294bb2d656afa0ffe (diff)
Notes
Diffstat (limited to 'sysutils/curly')
-rw-r--r--sysutils/curly/Makefile43
-rw-r--r--sysutils/curly/distinfo2
-rw-r--r--sysutils/curly/files/patch-machine.h13
-rw-r--r--sysutils/curly/pkg-descr2
-rw-r--r--sysutils/curly/pkg-plist2
5 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/curly/Makefile b/sysutils/curly/Makefile
new file mode 100644
index 000000000000..d81807aeb172
--- /dev/null
+++ b/sysutils/curly/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: curly
+# Date created: Nov 1 2002
+# Whom: Stephen Gunn <csg@fedex.com>, <csg@waterspout.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= curly
+PORTVERSION= 3.4
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
+ http://www.komquats.com/distfiles/ \
+ http://people.freebsd.org/~cy/distfiles/
+
+DISTNAME= xapply-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Generalize listed filenames to csh-extended glob patterns
+
+BUILD_DEPENDS= makeme:${PORTSDIR}/devel/msrc0 \
+ mkcmd:${PORTSDIR}/devel/mkcmd
+
+MAKE_FLAGS=
+MAKEFILE=
+MAN1= ${PORTNAME}.1
+MLINKS= ${PORTNAME}.1 un${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,CFLAGS=,CFLAGS+=,' -e 's,^DEBUG,#DEBUG,'\
+ -e 's,gcc,${CC},' ${WRKSRC}/bin/curly/Make.host
+
+do-build:
+ ( cd ${WRKSRC}/bin/${PORTNAME} && ${SETENV} ${MAKE_ENV} makeme \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET} )
+
+do-install:
+ ( cd ${WRKSRC}/bin/curly && ${SETENV} ${MAKENV} makeme \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET} )
+ ${INSTALL_MAN} ${WRKSRC}/bin/${PORTNAME}/${PORTNAME}.man \
+ ${PREFIX}/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/curly/distinfo b/sysutils/curly/distinfo
new file mode 100644
index 000000000000..544a1d9cf4c8
--- /dev/null
+++ b/sysutils/curly/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xapply-3.4.tgz) = 68b9408310da0270d763a2c1c2beeadbbccef857bf5d00312748a1de8a5ea445
+SIZE (xapply-3.4.tgz) = 31354
diff --git a/sysutils/curly/files/patch-machine.h b/sysutils/curly/files/patch-machine.h
new file mode 100644
index 000000000000..417f055257f2
--- /dev/null
+++ b/sysutils/curly/files/patch-machine.h
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- bin/curly/machine.h.orig Wed Nov 13 08:08:13 2002
++++ bin/curly/machine.h Wed Nov 13 08:08:48 2002
+@@ -19,7 +19,7 @@
+ #endif
+
+ #if !defined(NEED_MALLOC_EXTERN)
+-#define NEED_MALLOC_EXTERN (!USE_MALLOC_H && !defined(NEXT2) && !defined(IRIX) && !defined(BSDI))
++#define NEED_MALLOC_EXTERN (!USE_MALLOC_H && !defined(NEXT2) && !defined(IRIX) && !defined(BSDI) && !defined(FREEBSD))
+ #endif
+
+ #if !defined(USE_STDLIB)
diff --git a/sysutils/curly/pkg-descr b/sysutils/curly/pkg-descr
new file mode 100644
index 000000000000..6077f44de4aa
--- /dev/null
+++ b/sysutils/curly/pkg-descr
@@ -0,0 +1,2 @@
+Curly filters a list of filenames to a greatest-common-denominator
+glob pattern used by most shells.
diff --git a/sysutils/curly/pkg-plist b/sysutils/curly/pkg-plist
new file mode 100644
index 000000000000..05c0f2ef3a2e
--- /dev/null
+++ b/sysutils/curly/pkg-plist
@@ -0,0 +1,2 @@
+bin/curly
+bin/uncurly