aboutsummaryrefslogtreecommitdiff
path: root/sysutils/daemontools-encore/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-11-21 16:56:24 +0000
committerSteve Wills <swills@FreeBSD.org>2017-11-21 16:56:24 +0000
commit4e15df801dd1e5bac66658956d08fdbac9e88a3c (patch)
treea617547a2e64c42adc38c9e006069b7b0ece4e3c /sysutils/daemontools-encore/Makefile
parent01486588c1aa154f9536b0dd0120c366e183b777 (diff)
downloadports-4e15df801dd1e5bac66658956d08fdbac9e88a3c.tar.gz
ports-4e15df801dd1e5bac66658956d08fdbac9e88a3c.zip
Notes
Diffstat (limited to 'sysutils/daemontools-encore/Makefile')
-rw-r--r--sysutils/daemontools-encore/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/daemontools-encore/Makefile b/sysutils/daemontools-encore/Makefile
index 4cb1ec22cf20..677d748d108a 100644
--- a/sysutils/daemontools-encore/Makefile
+++ b/sysutils/daemontools-encore/Makefile
@@ -18,6 +18,28 @@ CONFLICTS= daemontools-[0-9]* freedt-[0-9]* serialmail-[0-9]*
ALL_TARGET= default
+S_EARLY_DESC= Start early, before the normal daemons
+S_NORMAL_DESC= Start normally in the usual boot sequence
+
+OPTIONS_SINGLE= SEQ
+OPTIONS_SINGLE_SEQ= S_EARLY S_NORMAL
+
+OPTIONS_DEFAULT= S_NORMAL
+
+.include <bsd.port.options.mk>
+
+. if ${PORT_OPTIONS:MS_EARLY}
+SVSCAN_REQUIRE?= SERVERS
+SVSCAN_BEFORE?= DAEMON
+. endif
+
+. if ${PORT_OPTIONS:MS_NORMAL}
+SVSCAN_REQUIRE?= LOGIN
+SVSCAN_BEFORE?=
+. endif
+
+SUB_LIST+= SVSCAN_REQUIRE=${SVSCAN_REQUIRE} SVSCAN_BEFORE=${SVSCAN_BEFORE}
+
USE_RC_SUBR= svscan
MANFILES= \