aboutsummaryrefslogtreecommitdiff
path: root/sysutils/daemontools/Makefile
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-06-22 09:22:15 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-06-22 09:22:15 +0000
commit38d0ebaebf110a4ee5a76f883fae67df96b018a6 (patch)
tree10a2e674ea17f4655cbde28a59db9369dd801f4c /sysutils/daemontools/Makefile
parent57d0aa6054b4fd89354d3a47d169313673cb87c8 (diff)
downloadports-38d0ebaebf110a4ee5a76f883fae67df96b018a6.tar.gz
ports-38d0ebaebf110a4ee5a76f883fae67df96b018a6.zip
Notes
Diffstat (limited to 'sysutils/daemontools/Makefile')
-rw-r--r--sysutils/daemontools/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/daemontools/Makefile b/sysutils/daemontools/Makefile
index 5904f65e3b30..f78311cb94df 100644
--- a/sysutils/daemontools/Makefile
+++ b/sysutils/daemontools/Makefile
@@ -17,9 +17,22 @@ NO_PACKAGE= Unsure of djb\'s license
ALL_TARGET= it
INSTALL_TARGET= setup check
+SAMPLERC= svscan.sh.sample
+SERVICEDIR?= /var/service/
+
post-patch:
@echo "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
@echo "${CC} -s" > ${WRKSRC}/conf-ld
@echo "${PREFIX}" > ${WRKSRC}/conf-home
+post-build:
+ @${SED} "s!/usr/local/!${PREFIX}/!;s!/var/service!${SERVICEDIR}!g" \
+ ${FILESDIR}/${SAMPLERC} > ${WRKDIR}/${SAMPLERC}
+
+post-install:
+ @${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 \
+ ${PREFIX}/share/examples/${PORTNAME}
+ @${INSTALL_DATA} ${WRKDIR}/${SAMPLERC} \
+ ${PREFIX}/share/examples/${PORTNAME}
+
.include <bsd.port.mk>