aboutsummaryrefslogtreecommitdiff
path: root/sysutils/daemontools
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-11-12 13:41:43 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-11-12 13:41:43 +0000
commitfae6e72bf36080cd71846f434506d6660d740d19 (patch)
tree945632e14fe4de40dd3fb7141a3c237f1c54a294 /sysutils/daemontools
parentfbd71ae76f32b140516693d495c5a397b892492f (diff)
downloadports-fae6e72bf36080cd71846f434506d6660d740d19.tar.gz
ports-fae6e72bf36080cd71846f434506d6660d740d19.zip
Notes
Diffstat (limited to 'sysutils/daemontools')
-rw-r--r--sysutils/daemontools/Makefile11
-rw-r--r--sysutils/daemontools/distinfo3
-rw-r--r--sysutils/daemontools/files/patch-multilog.c31
3 files changed, 39 insertions, 6 deletions
diff --git a/sysutils/daemontools/Makefile b/sysutils/daemontools/Makefile
index 44717a649a5c..6dde2940a399 100644
--- a/sysutils/daemontools/Makefile
+++ b/sysutils/daemontools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= daemontools
PORTVERSION= 0.76
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= sysutils
MASTER_SITES= http://cr.yp.to/daemontools/ \
ftp://cr.yp.to/daemontools/
@@ -16,6 +16,11 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= roam@FreeBSD.org
COMMENT= Service monitoring and logging utilities by djb
+LICENSE= PD
+LICENSE_NAME= public domain
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_TEXT= The daemontools-0.76.tar.gz archive is in the public domain as of 2007.12.28.
+
OPTIONS= MAN "Install Gerrit Pape's manual pages" on \
S_EARLY "Start early, before the normal daemons" off \
S_NORMAL "Start normally in the usual boot sequence" on \
@@ -26,7 +31,7 @@ OPTIONS= MAN "Install Gerrit Pape's manual pages" on \
.if defined(WITH_S_EARLY)
. if defined(WITH_S_NORMAL)
-IGNORE= Exactly one of S_EARLY and S_NORMAL must be specified.
+IGNORE= needs exactly one of S_EARLY and S_NORMAL to be specified
. else
SVSCAN_REQUIRE?= SERVERS
SVSCAN_BEFORE?= DAEMON
@@ -36,7 +41,7 @@ SVSCAN_BEFORE?= DAEMON
SVSCAN_REQUIRE?= LOGIN
SVSCAN_BEFORE?=
. else
-IGNORE= Either S_EARLY or S_NORMAL must be specified.
+IGNORE= needs either S_EARLY or S_NORMAL to be specified
. endif
.endif
diff --git a/sysutils/daemontools/distinfo b/sysutils/daemontools/distinfo
index 2e364398b7da..0f446537b1e4 100644
--- a/sysutils/daemontools/distinfo
+++ b/sysutils/daemontools/distinfo
@@ -1,9 +1,6 @@
-MD5 (daemontools-0.76.tar.gz) = 1871af2453d6e464034968a0fbcb2bfc
SHA256 (daemontools-0.76.tar.gz) = a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f
SIZE (daemontools-0.76.tar.gz) = 36975
-MD5 (daemontools-0.76-man-20010714.tar.gz) = 7f8105a2d6f3f7f9482dbdb6f4c78d1f
SHA256 (daemontools-0.76-man-20010714.tar.gz) = d99a12be71a7bff2fc46546dce02bf102eba401dbadddc29f0fe4bb6d8826c1b
SIZE (daemontools-0.76-man-20010714.tar.gz) = 7992
-MD5 (daemontools-0.76.sigq12.patch) = fe2b0ddbd1ea2e72b29c7d78d5e9b0f3
SHA256 (daemontools-0.76.sigq12.patch) = 149569b2c1a81435d4b9be5905564b2743cdcb8e5ebd1c626d5cb401761e06ae
SIZE (daemontools-0.76.sigq12.patch) = 1975
diff --git a/sysutils/daemontools/files/patch-multilog.c b/sysutils/daemontools/files/patch-multilog.c
new file mode 100644
index 000000000000..474451a8af9c
--- /dev/null
+++ b/sysutils/daemontools/files/patch-multilog.c
@@ -0,0 +1,31 @@
+Description: Skip the timestamp when matching specified patterns.
+Origin: http://marc.info/?m=96056408505485
+Author: Gerritt Pape <pape@smarden.org>
+Last-Update: 2010-11-12
+
+--- multilog.c.orig
++++ multilog.c
+@@ -496,7 +496,7 @@
+ flagtimestamp = 0;
+ if (script[0])
+ if (script[0][0] == 't')
+- flagtimestamp = 1;
++ flagtimestamp = 26;
+
+ for (i = 0;i <= 1000;++i) line[i] = '\n';
+ linelen = 0;
+@@ -529,12 +529,12 @@
+ switch(*action) {
+ case '+':
+ if (!flagselected)
+- if (match(action + 1,line,linelen))
++ if (match(action + 1,line + flagtimestamp,linelen - flagtimestamp))
+ flagselected = 1;
+ break;
+ case '-':
+ if (flagselected)
+- if (match(action + 1,line,linelen))
++ if (match(action + 1,line + flagtimestamp,linelen - flagtimestamp))
+ flagselected = 0;
+ break;
+ case 'e':