aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dd_rescue
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-07-02 14:56:54 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-07-02 14:56:54 +0000
commit5acf7425dcd3e8f620aba540f86aaf1ece40a931 (patch)
tree97b984dc798b536562c7043d1517f47bcc3f807f /sysutils/dd_rescue
parent2951a5883b6edb70129737bddd996ac7457f4c96 (diff)
downloadports-5acf7425dcd3e8f620aba540f86aaf1ece40a931.tar.gz
ports-5acf7425dcd3e8f620aba540f86aaf1ece40a931.zip
Notes
Diffstat (limited to 'sysutils/dd_rescue')
-rw-r--r--sysutils/dd_rescue/Makefile3
-rw-r--r--sysutils/dd_rescue/files/patch-Makefile15
2 files changed, 14 insertions, 4 deletions
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index 2b4e5098f74b..4efe951fc3f8 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -13,13 +13,14 @@ MASTER_SITES= http://www.garloff.de/kurt/linux/ddrescue/
MAINTAINER= nobutaka@freebsd.org
COMMENT= A dd tool suitable for rescuing data from a medium with errors
+USE_GETOPT_LONG=yes
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= default
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
+MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -lgnugetopt"
.endif
do-install:
diff --git a/sysutils/dd_rescue/files/patch-Makefile b/sysutils/dd_rescue/files/patch-Makefile
index be2e34499e79..d88779faa2df 100644
--- a/sysutils/dd_rescue/files/patch-Makefile
+++ b/sysutils/dd_rescue/files/patch-Makefile
@@ -1,12 +1,21 @@
--- Makefile.orig Fri Oct 22 16:38:03 2004
-+++ Makefile Tue Mar 15 01:00:23 2005
-@@ -6,9 +6,7 @@
++++ Makefile Sat Jul 2 23:40:24 2005
+@@ -6,9 +6,6 @@
DESTDIR =
-CC = gcc
- RPM_OPT_FLAGS = -O2 -Wall -g
+-RPM_OPT_FLAGS = -O2 -Wall -g
-CFLAGS = $(RPM_OPT_FLAGS) $(EXTRA_CFLAGS)
DEFINES = -DVERSION=\"$(VERSION)\"
INSTALL = install
INSTALLFLAGS = -s
+@@ -25,7 +22,7 @@
+ default: $(TARGETS)
+
+ dd_rescue: dd_rescue.c
+- $(CC) $(CFLAGS) $(DEFINES) $< -o $@
++ $(CC) $(CFLAGS) $(DEFINES) $(LIBS) $< -o $@
+
+ clean:
+ rm -f $(TARGETS) $(OBJECTS) core