aboutsummaryrefslogtreecommitdiff
path: root/sysutils/debootstrap
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-07 09:47:51 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-07 09:47:51 +0000
commitc4214db1562ededefc85fe5e03d139c73b585422 (patch)
tree927b81af662ed42af305c794f375282725b9518f /sysutils/debootstrap
parented5e824cbb9bfb91b02ece719d14bd617629d62b (diff)
downloadports-c4214db1562ededefc85fe5e03d139c73b585422.tar.gz
ports-c4214db1562ededefc85fe5e03d139c73b585422.zip
Notes
Diffstat (limited to 'sysutils/debootstrap')
-rw-r--r--sysutils/debootstrap/Makefile17
-rw-r--r--sysutils/debootstrap/distinfo4
-rw-r--r--sysutils/debootstrap/files/patch-Makefile16
-rw-r--r--sysutils/debootstrap/files/patch-debootstrap15
-rw-r--r--sysutils/debootstrap/pkg-plist5
5 files changed, 33 insertions, 24 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index 784ca76cfecf..a3a73a078d73 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -2,35 +2,32 @@
# $FreeBSD$
PORTNAME= debootstrap
-PORTVERSION= 1.0.53
+PORTVERSION= 1.0.60
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/d/${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lifanov@mail.lifanov.com
COMMENT= Install Debian base system into a directory
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
NO_BUILD= yes
-USES= gmake
-MAKE_ARGS= DESTDIR="${PREFIX}"
-
-MAN8= debootstrap.8
+USES= gmake tar:xz
+MAKE_ARGS= DESTDIR="${STAGEDIR}"
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= Debian GNU/kFreeBSD available only for i386 and amd64
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,g' \
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
+ ${WRKSRC}/Makefile \
${WRKSRC}/debootstrap
post-install:
@${INSTALL_MAN} ${WRKSRC}/debootstrap.8 \
- ${MAN8PREFIX}/man/man8/debootstrap.8
- @${CAT} ${PKGMESSAGE}
+ ${STAGEDIR}${PREFIX}/man/man8/debootstrap.8
.include <bsd.port.mk>
diff --git a/sysutils/debootstrap/distinfo b/sysutils/debootstrap/distinfo
index a16445874c58..79f7edd3dbea 100644
--- a/sysutils/debootstrap/distinfo
+++ b/sysutils/debootstrap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (debootstrap_1.0.53.tar.gz) = 26b74baee6909e9ce363891cc355fced6d875ca8c3715e72ff9dfb580c9cc272
-SIZE (debootstrap_1.0.53.tar.gz) = 59064
+SHA256 (debootstrap_1.0.60.tar.xz) = 886b140a6801012aba3f502d1f50f5b8e94fc032965400a6c2da19437a75dd4b
+SIZE (debootstrap_1.0.60.tar.xz) = 49612
diff --git a/sysutils/debootstrap/files/patch-Makefile b/sysutils/debootstrap/files/patch-Makefile
index 654d0b926cf1..a026251e4969 100644
--- a/sysutils/debootstrap/files/patch-Makefile
+++ b/sysutils/debootstrap/files/patch-Makefile
@@ -1,26 +1,24 @@
---- Makefile.orig 2011-08-15 20:29:37.000000000 +0200
-+++ Makefile 2011-08-25 19:19:09.951348991 +0200
-@@ -13,17 +13,17 @@
+--- ./Makefile.orig 2011-08-10 07:59:34.000000000 -0400
++++ ./Makefile 2014-08-06 19:37:57.799160204 -0400
+@@ -13,17 +13,15 @@
rm -f devices.tar.gz
rm -rf dev
-DSDIR=$(DESTDIR)/usr/share/debootstrap
-+DSDIR=$(PREFIX)/share/debootstrap
++DSDIR=$(DESTDIR)%%PREFIX%%/share/debootstrap
install:
mkdir -p $(DSDIR)/scripts
- mkdir -p $(DESTDIR)/usr/sbin
-+ mkdir -p $(PREFIX)/sbin
++ mkdir -p $(DESTDIR)%%PREFIX%%/sbin
cp -a scripts/* $(DSDIR)/scripts/
- install -o root -g root -m 0644 functions $(DSDIR)/
-+ install -o root -g wheel -m 0644 functions $(DSDIR)/
++ cp -a functions $(DSDIR)/
- sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/sbin/debootstrap
- chown root:root $(DESTDIR)/usr/sbin/debootstrap
- chmod 0755 $(DESTDIR)/usr/sbin/debootstrap
-+ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(PREFIX)/sbin/debootstrap
-+ chown root:wheel $(PREFIX)/sbin/debootstrap
-+ chmod 0755 $(PREFIX)/sbin/debootstrap
++ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)%%PREFIX%%/sbin/debootstrap
ifeq ($(shell uname),Linux)
install -o root -g root -m 0644 devices.tar.gz $(DSDIR)/
diff --git a/sysutils/debootstrap/files/patch-debootstrap b/sysutils/debootstrap/files/patch-debootstrap
index c5d324651423..ec8bb7778b51 100644
--- a/sysutils/debootstrap/files/patch-debootstrap
+++ b/sysutils/debootstrap/files/patch-debootstrap
@@ -1,6 +1,15 @@
---- debootstrap.orig 2011-08-25 20:19:23.294346076 +0200
-+++ debootstrap 2011-08-25 20:22:42.850735086 +0200
-@@ -419,6 +419,10 @@
+--- ./debootstrap.orig 2014-02-07 10:25:58.000000000 -0500
++++ ./debootstrap 2014-08-06 19:34:46.435155899 -0400
+@@ -13,7 +13,7 @@
+ if [ -x /debootstrap/debootstrap ]; then
+ DEBOOTSTRAP_DIR=/debootstrap
+ else
+- DEBOOTSTRAP_DIR=/usr/share/debootstrap
++ DEBOOTSTRAP_DIR=%%PREFIX%%/share/debootstrap
+ fi
+ fi
+
+@@ -425,6 +425,10 @@
esac
fi
diff --git a/sysutils/debootstrap/pkg-plist b/sysutils/debootstrap/pkg-plist
index 43c939ffdbcc..3bc9d7c46411 100644
--- a/sysutils/debootstrap/pkg-plist
+++ b/sysutils/debootstrap/pkg-plist
@@ -1,4 +1,7 @@
+@mode 0755
sbin/debootstrap
+@mode
+man/man8/debootstrap.8.gz
share/debootstrap/functions
share/debootstrap/scripts/breezy
share/debootstrap/scripts/dapper
@@ -32,7 +35,9 @@ share/debootstrap/scripts/sid
share/debootstrap/scripts/squeeze
share/debootstrap/scripts/stable
share/debootstrap/scripts/testing
+share/debootstrap/scripts/trusty
share/debootstrap/scripts/unstable
+share/debootstrap/scripts/utopic
share/debootstrap/scripts/warty
share/debootstrap/scripts/warty.buildd
share/debootstrap/scripts/wheezy