aboutsummaryrefslogtreecommitdiff
path: root/sysutils/debootstrap
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-03-14 20:07:14 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-03-14 20:07:14 +0000
commit6746702236047a42fae28684317ba084149c15fc (patch)
tree8c7c742dc51016eb4402791723e6f69c9e8c10e7 /sysutils/debootstrap
parentb75bf04da43998de2ebe0b416b17cd761fdc3ea6 (diff)
downloadports-6746702236047a42fae28684317ba084149c15fc.tar.gz
ports-6746702236047a42fae28684317ba084149c15fc.zip
Notes
Diffstat (limited to 'sysutils/debootstrap')
-rw-r--r--sysutils/debootstrap/Makefile1
-rw-r--r--sysutils/debootstrap/files/patch-functions67
-rw-r--r--sysutils/debootstrap/pkg-descr6
3 files changed, 71 insertions, 3 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index 7a390fcd0753..91026192924a 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= debootstrap
PORTVERSION= 1.0.28
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/d/${PORTNAME}
diff --git a/sysutils/debootstrap/files/patch-functions b/sysutils/debootstrap/files/patch-functions
index 0bd37d537641..acdd53e04af5 100644
--- a/sysutils/debootstrap/files/patch-functions
+++ b/sysutils/debootstrap/files/patch-functions
@@ -1,5 +1,5 @@
--- functions.orig 2011-02-22 01:25:08.000000000 +0100
-+++ functions 2011-02-26 21:46:35.811100782 +0100
++++ functions 2011-03-14 20:42:00.536562918 +0100
@@ -232,7 +232,11 @@
# args: dest checksum size
local expchecksum="$2"
@@ -48,3 +48,68 @@
rm -f "$pkgdest"
gunzip "$pkgdest.gz"
elif get "$m/$path" "$pkgdest"; then
+@@ -934,12 +938,16 @@
+ hurd-*)
+ ;;
+ *)
+- umount_on_exit /dev/pts
+- umount_on_exit /dev/shm
+- umount_on_exit /proc/bus/usb
+- umount_on_exit /proc
+- umount "$TARGET/proc" 2>/dev/null || true
+- in_target mount -t proc proc /proc
++ if [ `uname -s` = "FreeBSD" ] ; then
++ mount -t linprocfs proc $TARGET/proc
++ else
++ umount_on_exit /dev/pts
++ umount_on_exit /dev/shm
++ umount_on_exit /proc/bus/usb
++ umount_on_exit /proc
++ umount "$TARGET/proc" 2>/dev/null || true
++ in_target mount -t proc proc /proc
++ fi
+ if [ -d "$TARGET/sys" ] && \
+ grep -q '[[:space:]]sysfs' /proc/filesystems 2>/dev/null; then
+ umount_on_exit /sys
+@@ -964,13 +972,17 @@
+ hurd-*)
+ setup_devices_hurd ;;
+ *)
+- if [ -e "$DEVICES_TARGZ" ]; then
+- zcat "$DEVICES_TARGZ" | (cd "$TARGET"; tar -xf -)
++ if [ "`uname -s`" = "FreeBSD" ]; then
++ mount -t devfs devfs $TARGET/dev
+ else
+- if [ -e /dev/.devfsd ] ; then
+- in_target mount -t devfs devfs /dev
++ if [ -e "$DEVICES_TARGZ" ]; then
++ zcat "$DEVICES_TARGZ" | (cd "$TARGET"; tar -xf -)
+ else
+- error 1 NODEVTGZ "no %s. cannot create devices" "$DEVICES_TARGZ"
++ if [ -e /dev/.devfsd ] ; then
++ in_target mount -t devfs devfs /dev
++ else
++ error 1 NODEVTGZ "no %s. cannot create devices" "$DEVICES_TARGZ"
++ fi
+ fi
+ fi
+ ;;
+@@ -1178,12 +1190,14 @@
+ kfreebsd-*|hurd-*)
+ ;;
+ *)
+- mknod "$1/test-dev-null" c 1 3 || return 1
+- if ! echo test > "$1/test-dev-null"; then
++ if [ "`uname -s`" != "FreeBSD" ]; then
++ mknod "$1/test-dev-null" c 1 3 || return 1
++ if ! echo test > "$1/test-dev-null"; then
++ rm -f "$1/test-dev-null"
++ return 1
++ fi
+ rm -f "$1/test-dev-null"
+- return 1
+ fi
+- rm -f "$1/test-dev-null"
+ ;;
+ esac
+
diff --git a/sysutils/debootstrap/pkg-descr b/sysutils/debootstrap/pkg-descr
index e85a1f4f29fb..55802155103c 100644
--- a/sysutils/debootstrap/pkg-descr
+++ b/sysutils/debootstrap/pkg-descr
@@ -2,8 +2,10 @@ debootstrap is a tool which will install a Debian base system into
a subdirectory of another, already installed system. It doesn't require an
installation CD, just access to a Debian repository.
-In FreeBSD, you can use debootstrap to install Debian GNU/kFreeBSD into
+In FreeBSD, you can use debootstrap to install Debian into
a subdirectory of your existing FreeBSD installation (i386 or amd64)
-and then run Debian GNU/kFreeBSD (i386 or amd64) in a jail or chroot.
+and then run Debian GNU/kFreeBSD (i386 or amd64) or Debian Linux (i386)
+in a jail or chroot.
WWW: http://wiki.debian.org/Debootstrap
+