aboutsummaryrefslogtreecommitdiff
path: root/sysutils/debootstrap
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-08 01:26:31 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-08 01:26:31 +0000
commitf53f5d7b9d175f7137d129871546aa79e153f315 (patch)
treec2ac4c0f25beeb1907cb128a1493a5f2abc4c43d /sysutils/debootstrap
parentfc2a931701ddd1c54294aca397050926e8f58db7 (diff)
downloadports-f53f5d7b9d175f7137d129871546aa79e153f315.tar.gz
ports-f53f5d7b9d175f7137d129871546aa79e153f315.zip
Notes
Diffstat (limited to 'sysutils/debootstrap')
-rw-r--r--sysutils/debootstrap/Makefile7
-rw-r--r--sysutils/debootstrap/files/patch-debootstrap23
2 files changed, 27 insertions, 3 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index a3a73a078d73..d86b1235b935 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -3,6 +3,7 @@
PORTNAME= debootstrap
PORTVERSION= 1.0.60
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/d/${PORTNAME}
@@ -11,11 +12,13 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= lifanov@mail.lifanov.com
COMMENT= Install Debian base system into a directory
-RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget \
+ dpkg:${PORTSDIR}/archivers/dpkg
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
NO_BUILD= yes
-USES= gmake tar:xz
+USES= gmake perl5 tar:xz
+USE_PERL5= run
MAKE_ARGS= DESTDIR="${STAGEDIR}"
ONLY_FOR_ARCHS= i386 amd64
diff --git a/sysutils/debootstrap/files/patch-debootstrap b/sysutils/debootstrap/files/patch-debootstrap
index ec8bb7778b51..aed3294eb02c 100644
--- a/sysutils/debootstrap/files/patch-debootstrap
+++ b/sysutils/debootstrap/files/patch-debootstrap
@@ -1,5 +1,5 @@
--- ./debootstrap.orig 2014-02-07 10:25:58.000000000 -0500
-+++ ./debootstrap 2014-08-06 19:34:46.435155899 -0400
++++ ./debootstrap 2014-08-07 20:46:10.626600981 -0400
@@ -13,7 +13,7 @@
if [ -x /debootstrap/debootstrap ]; then
DEBOOTSTRAP_DIR=/debootstrap
@@ -9,6 +9,19 @@
fi
fi
+@@ -399,10 +399,10 @@
+
+ if in_path dpkg && \
+ dpkg --print-architecture >/dev/null 2>&1; then
+- HOST_ARCH=`/usr/bin/dpkg --print-architecture`
++ HOST_ARCH=`%%PREFIX%%/bin/dpkg --print-architecture`
+ elif in_path udpkg && \
+ udpkg --print-architecture >/dev/null 2>&1; then
+- HOST_ARCH=`/usr/bin/udpkg --print-architecture`
++ HOST_ARCH=`%%PREFIX%%/bin/udpkg --print-architecture`
+ elif [ -e $DEBOOTSTRAP_DIR/arch ]; then
+ HOST_ARCH=`cat $DEBOOTSTRAP_DIR/arch`
+ fi
@@ -425,6 +425,10 @@
esac
fi
@@ -20,3 +33,11 @@
if [ -z "$ARCH" ]; then
ARCH=$HOST_ARCH
fi
+@@ -621,7 +625,6 @@
+ if ! am_doing_phase second_stage; then
+ cp "$0" "$TARGET/debootstrap/debootstrap"
+ cp $DEBOOTSTRAP_DIR/functions "$TARGET/debootstrap/functions"
+- cp $DEBOOTSTRAP_DIR/devices.tar.gz "$TARGET/debootstrap/devices.tar.gz"
+ cp $SCRIPT "$TARGET/debootstrap/suite-script"
+ echo "$ARCH" >"$TARGET/debootstrap/arch"
+ echo "$SUITE" >"$TARGET/debootstrap/suite"