aboutsummaryrefslogtreecommitdiff
path: root/sysutils/desktopbsd-tools
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2008-09-03 15:01:19 +0000
committerLars Engels <lme@FreeBSD.org>2008-09-03 15:01:19 +0000
commit05916d799f62a14ab8d6de9b75ad8e4079f10a9c (patch)
treec622673a3b999ce98ab2f33138c001d0794739f5 /sysutils/desktopbsd-tools
parente0179e8e519ecb0e53005a65812191425e05736e (diff)
downloadports-05916d799f62a14ab8d6de9b75ad8e4079f10a9c.tar.gz
ports-05916d799f62a14ab8d6de9b75ad8e4079f10a9c.zip
Notes
Diffstat (limited to 'sysutils/desktopbsd-tools')
-rw-r--r--sysutils/desktopbsd-tools/Makefile4
-rw-r--r--sysutils/desktopbsd-tools/files/patch-libdesktopbsd-netinterface.cpp12
-rw-r--r--sysutils/desktopbsd-tools/files/patch-libdesktopbsd-wirelessinterface.cpp21
3 files changed, 33 insertions, 4 deletions
diff --git a/sysutils/desktopbsd-tools/Makefile b/sysutils/desktopbsd-tools/Makefile
index 53a4f9d84363..96a84137dce5 100644
--- a/sysutils/desktopbsd-tools/Makefile
+++ b/sysutils/desktopbsd-tools/Makefile
@@ -46,10 +46,6 @@ RUN_DEPENDS+= csup:${PORTSDIR}/net/csup
RUN_DEPENDS+= portsnap:${PORTSDIR}/ports-mgmt/portsnap
.endif
-.if ${OSVERSION} >= 800000
-BROKEN= does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
"/Installation/d; /Documentation/d; /InitialConf/d" \
diff --git a/sysutils/desktopbsd-tools/files/patch-libdesktopbsd-netinterface.cpp b/sysutils/desktopbsd-tools/files/patch-libdesktopbsd-netinterface.cpp
new file mode 100644
index 000000000000..7b295ab5b001
--- /dev/null
+++ b/sysutils/desktopbsd-tools/files/patch-libdesktopbsd-netinterface.cpp
@@ -0,0 +1,12 @@
+--- libdesktopbsd/netinterface.cpp.orig 2007-07-29 09:36:00.000000000 +1100
++++ libdesktopbsd/netinterface.cpp 2008-07-04 17:00:31.000000000 +1100
+@@ -22,6 +22,9 @@
+ #include <ifaddrs.h>
+ #include <net/route.h>
+ #include <net/if.h>
++#if defined(__FreeBSD_version) && __FreeBSD_version >= 800038
++#include <net80211/_ieee80211.h>
++#endif
+ #include <net80211/ieee80211.h>
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>
diff --git a/sysutils/desktopbsd-tools/files/patch-libdesktopbsd-wirelessinterface.cpp b/sysutils/desktopbsd-tools/files/patch-libdesktopbsd-wirelessinterface.cpp
new file mode 100644
index 000000000000..c0a57e0b1ff7
--- /dev/null
+++ b/sysutils/desktopbsd-tools/files/patch-libdesktopbsd-wirelessinterface.cpp
@@ -0,0 +1,21 @@
+--- libdesktopbsd/wirelessinterface.cpp.orig 2007-09-02 21:21:11.000000000 +1100
++++ libdesktopbsd/wirelessinterface.cpp 2008-07-04 17:02:25.000000000 +1100
+@@ -76,6 +76,8 @@
+
+ #include "wirelessinterface.h"
+
++#include <sys/param.h> /* __FreeBSD_version */
++
+ #include <net/ethernet.h>
+ #include <net/if_dl.h>
+ #include <net/if_types.h>
+@@ -86,6 +88,9 @@
+ #include <ifaddrs.h>
+ #include <net/route.h>
+ #include <net/if.h>
++#if defined(__FreeBSD_version) && __FreeBSD_version >= 800038
++#include <net80211/_ieee80211.h>
++#endif
+ #include <net80211/ieee80211.h>
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>