aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dircomp
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-20 13:03:20 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-20 13:03:20 +0000
commita0695e59f62a7a5c5c1c08f25c33ecfa9a1cb985 (patch)
treedadd67ce0d2b874516494fbd55cbe84cea1260a0 /sysutils/dircomp
parent3ea06755462de8f621dbc4fc7b81b8b4263b8da5 (diff)
downloadports-a0695e59f62a7a5c5c1c08f25c33ecfa9a1cb985.tar.gz
ports-a0695e59f62a7a5c5c1c08f25c33ecfa9a1cb985.zip
Notes
Diffstat (limited to 'sysutils/dircomp')
-rw-r--r--sysutils/dircomp/Makefile37
-rw-r--r--sysutils/dircomp/distinfo3
-rw-r--r--sysutils/dircomp/pkg-descr7
3 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/dircomp/Makefile b/sysutils/dircomp/Makefile
new file mode 100644
index 000000000000..2e760dbcc114
--- /dev/null
+++ b/sysutils/dircomp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: DirComp
+# Date created: 20 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DirComp
+PORTVERSION= 1.3.01
+CATEGORIES= sysutils
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Compare two directories
+
+.ifndef WITHOUT_X11
+LIB_DEPENDS= XGP-0.8.10.0:${PORTSDIR}/devel/libXGP
+PLIST_FILES+= bin/XDirComp
+.else
+LIB_DEPENDS= YGP-0.8.10.0:${PORTSDIR}/devel/libYGP
+MK_PATCH+= s/@MYSUBDIRS@/Common/g;
+.endif
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+PLIST_FILES+= bin/DirComp \
+ share/locale/de/LC_MESSAGES/DirComp.mo \
+ share/locale/en/LC_MESSAGES/DirComp.mo \
+ share/locale/es/LC_MESSAGES/DirComp.mo
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's/^(SUBDIRS.*)doc/\1/;${MK_PATCH}' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/sysutils/dircomp/distinfo b/sysutils/dircomp/distinfo
new file mode 100644
index 000000000000..d7f86f06934a
--- /dev/null
+++ b/sysutils/dircomp/distinfo
@@ -0,0 +1,3 @@
+MD5 (DirComp-1.3.01.tar.bz2) = 991bef79f91f6dda974513628dc38b95
+SHA256 (DirComp-1.3.01.tar.bz2) = c8cf6f34716a2a038f1c3f8ec2d97bc2a4d5e29e516394aa2774e55bbb6f1e19
+SIZE (DirComp-1.3.01.tar.bz2) = 344488
diff --git a/sysutils/dircomp/pkg-descr b/sysutils/dircomp/pkg-descr
new file mode 100644
index 000000000000..90bc7fc75443
--- /dev/null
+++ b/sysutils/dircomp/pkg-descr
@@ -0,0 +1,7 @@
+The utility DirComp compares two directories (and - if specified - their
+subdirectories), where the comparison can be done both by existence and
+by date (of change) or contents. This comparison can be limited to
+certain files and and/directories matching specified name- or time-of-
+change restrictions.
+
+http://dircomp.sourceforge.net/