aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dirdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-10-23 01:24:54 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-10-23 01:24:54 +0000
commitf81f721be815308e7f458c5caa96b0370161ad03 (patch)
treea10654c6b0cab0275ffd30fc4a46971ede688c92 /sysutils/dirdiff
parent036a0b3d569630b5dd0086d7796ca68ea009defd (diff)
downloadports-f81f721be815308e7f458c5caa96b0370161ad03.tar.gz
ports-f81f721be815308e7f458c5caa96b0370161ad03.zip
Notes
Diffstat (limited to 'sysutils/dirdiff')
-rw-r--r--sysutils/dirdiff/Makefile23
-rw-r--r--sysutils/dirdiff/files/patch-aa31
-rw-r--r--sysutils/dirdiff/files/patch-ab10
-rw-r--r--sysutils/dirdiff/pkg-descr146
-rw-r--r--sysutils/dirdiff/pkg-plist2
5 files changed, 22 insertions, 190 deletions
diff --git a/sysutils/dirdiff/Makefile b/sysutils/dirdiff/Makefile
index a0027e57e40a..92786ee3d6d0 100644
--- a/sysutils/dirdiff/Makefile
+++ b/sysutils/dirdiff/Makefile
@@ -14,7 +14,26 @@ MASTER_SITES= ftp://ftp.samba.org/pub/paulus/
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphical diff tool
-BUILD_DEPENDS= tclsh8.4:${PORTSDIR}/lang/tcl84
-RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_TCL_BUILD= yes
+USE_LDCONFIG= yes
+USE_TK= yes
+
+PLIST_FILES= bin/dirdiff lib/libfilecmp.so.0
+
+CFLAGS+= -fPIC -I${TCL_INCLUDEDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|.0.0|.0|g ; \
+ s|^CFLAGS=|CFLAGS?=|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|^exec wish |exec ${WISH:T} |' ${WRKSRC}/dirdiff
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/dirdiff ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libfilecmp.so.0 ${PREFIX}/lib
.include <bsd.port.mk>
diff --git a/sysutils/dirdiff/files/patch-aa b/sysutils/dirdiff/files/patch-aa
deleted file mode 100644
index 30dd058d7e36..000000000000
--- a/sysutils/dirdiff/files/patch-aa
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.orig Tue Apr 19 19:52:01 2005
-+++ Makefile Wed Jul 6 15:05:14 2005
-@@ -2,21 +2,21 @@
- #
- # In fact all we have to make is the libfilecmp.so.0.0 library.
-
--BINDIR=$(DESTDIR)/usr/bin
--LIBDIR=$(DESTDIR)/usr/lib
-+BINDIR=$(DESTDIR)${PREFIX}/bin
-+LIBDIR=$(DESTDIR)${PREFIX}/lib
- INSTALL=install
-
- # You may need to change the -I arguments depending on your system
--CFLAGS=-O3 -I/usr/include/tcl8.3/ -I/usr/include/tcl
-+CFLAGS+=-fPIC -I/usr/local/include/tcl8.4/
-
--all: libfilecmp.so.0.0
-+all: libfilecmp.so.0
-
--libfilecmp.so.0.0: filecmp.c
-+libfilecmp.so.0: filecmp.c
- $(CC) $(CFLAGS) -shared -o $@ filecmp.c
-
--install: dirdiff libfilecmp.so.0.0
-+install: dirdiff libfilecmp.so.0
- $(INSTALL) -c dirdiff $(BINDIR)
-- $(INSTALL) -c libfilecmp.so.0.0 $(LIBDIR)
-+ $(INSTALL) -c libfilecmp.so.0 $(LIBDIR)
-
- clean:
- rm -f libfilecmp.so.0.0
diff --git a/sysutils/dirdiff/files/patch-ab b/sysutils/dirdiff/files/patch-ab
deleted file mode 100644
index 88f9620af856..000000000000
--- a/sysutils/dirdiff/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- dirdiff.orig Tue Mar 13 20:30:41 2001
-+++ dirdiff Fri Mar 5 04:55:43 2004
-@@ -1,6 +1,6 @@
- #!/bin/sh
- # Tcl ignores the next line \
--exec wish "$0" -- "${1+$@}"
-+exec wish8.4 "$0" -- "${1+$@}"
-
- # Copyright (C) 1999-2001 Paul Mackerras. All rights reserved.
- # This program is free software; it may be used, copied, modified
diff --git a/sysutils/dirdiff/pkg-descr b/sysutils/dirdiff/pkg-descr
index 9b836897c42c..24b48c71d9eb 100644
--- a/sysutils/dirdiff/pkg-descr
+++ b/sysutils/dirdiff/pkg-descr
@@ -1,8 +1,3 @@
- Dirdiff-2.1.
-
- Paul Mackerras
- <paulus@samba.org>
-
Dirdiff is a graphical tool for displaying the differences between
directory trees and for merging changes from one tree into another.
Dirdiff can handle up to 5 trees. It displays a main window with a
@@ -12,143 +7,4 @@ you to display the differences between any two of the versions in
another window. Another menu allows you to copy the file from one
tree to another.
-The differences window basically displays the output of `diff -u' with
-colored backgrounds to indicate which version each line comes from.
-The differences window also has a series of checkboxes which allow you
-to selectively apply changes from one version to another. You apply
-the selected changes using the merge menu. Dirdiff will then pop up
-another window containing the merged file. You can then edit the
-merged version and save it back into file.
-
-Dirdiff now also has a file mode, which can be used for viewing the
-differences between files and for merging changes from one file into
-another. This mode is invoked if regular files are specified on the
-command line (or in the new directory/file chooser, see below) rather
-than directories. (Dirdiff will exit with an error message if some
-files and some directories are specified.)
-
-
-What's new in dirdiff-2.1.
---------------------------
-
-* The diff display window can now display 3-way, 4-way and 5-way diffs
- as well as the normal 2-way diffs. When a line is identified as
- coming from multiple files, most of it will be colored for the
- newest of those files, and extra colored bars at the left of the
- line will identify which other files it is in.
-
-* You can now modify the diff display interactively (for example, to
- make it more understandable). You can use the middle mouse button
- to drag the blue separator bars to expose more context, or drag
- colored diff lines up and down (the movement is constrained so as to
- not alter the meaning of the diff). Dragging context lines splits
- them into colored diff lines.
-
-* There is now a menu on the diff display window for generating
- patches embodying the changes that could be made with the merge
- menu. That is, the diff lines that are checked in the diff viewer
- will be made into - and + lines in the generated patch.
-
-* The BitKeeper integration feature has been removed. I plan to add
- generic features for integration with arbitrary SCM systems in
- future.
-
-
-What was new in dirdiff-2.0.
-----------------------------
-
-* Some great new features from Dorothy Robinson:
-
- - A dialog box for choosing the directories to be diffed, if dirdiff
- is invoked without specifying any directories or files on the
- command line.
-
- - Colored icons instead of squares in the file list window.
-
- - Colored icons in the Diff and Copy/Del menus (provided you are
- using Tk 8.4 or later).
-
- - Modifications so dirdiff can be used under Windows.
-
- - A color key showing the ordering of the colors.
-
- - Use of two-level menus for the Diff, Copy/Del and Patch menus (the
- Diff and Copy/Del menus use two levels only when there are
- sufficient alternatives for it to make things simpler).
-
- - A filename search function using the filename bar in the file list
- window.
-
- - Options to allow the user to select external diff and file viewer
- programs.
-
-* There is now a mode for ignoring files in a directory if they match
- any of the patterns listed in the .cvsignore in that directory.
- This is invoked with the -C command-line option or by choosing the
- "Ignore files in .cvsignore" option in the Options menu.
-
-* Some users have requested a mode in which, when a directory exists
- in one tree but not another, dirdiff display the files in that
- directory as existing in the one tree but not the other (rather than
- displaying just a single line for the directory). This mode is
- enabled by choosing the "Show files that aren't in some dirs" option
- in the Options menu.
-
-* Trees can now be marked as "read-only" in the Options menu. This
- means that menu options that would modify those trees (in the
- Copy/Del, Touch and Merge menus) will not be offered.
-
-* Files can be added to the excluded file list by selecting them and
- choosing "Exclude selection" under the File menu.
-
-* Changes to the "Underline tabs" mode now take effect immediately.
-
-
-Installation.
--------------
-
-Dirdiff is a Tcl/TK script, so no compilation is required. Dirdiff
-however can make use of a shared library called filecmp.so.0.0 for
-comparing files. This is optional, but it has two benefits: (a)
-comparing files is faster with filecmp.so.0.0 (without it, dirdiff has
-to start an external process running `cmp'), and (b) filecmp.so.0.0
-can optionally ignore RCS and BK strings when it is comparing two files.
-
-The Makefile in this directory will compile filecmp.so.0.0, and
-install it and dirdiff. By default dirdiff is installed in /usr/bin
-and filecmp.so.0.0 is installed in /usr/lib. Doing `make' will
-compile filecmp.so.0.0; `make install' will install dirdiff and
-filecmp.so.0.0.
-
-
-Usage.
-------
-
-To use dirdiff, you invoke it from the command line with a list of
-directories (between 2 and 5). For example, suppose I have 3 copies
-of the Linux kernel source code, in directories called linux, bk, and
-pmac. I can see the differences between these 3 trees with a command
-like:
-
-$ dirdiff linux bk pmac
-
-This will display the file list window and start comparing the trees,
-displaying files which differ as they are found. To see the
-differences between two versions, click on the file name and then
-select the versions to compare from the Diff menu. To copy from one
-tree to another, click on the file name and select the copy operation
-from the Copy menu.
-
-In the differences window, there are checkboxes to the left of all the
-sections which are different. You can use button 1 to select an
-individual checkbox, or shift-button 1 or button 3 to select a whole
-group. Selecting a line means that you are asking for that change to
-be made when you update either of the files using the Merge menu. The
-line will be removed if it is already present or added if it is not
-present.
-
-Starting with dirdiff-2.0, you can start dirdiff without any arguments
-and it will pop up a dialog box where you can enter the directories to
-be compared.
-
-
+WWW: http://freshmeat.net/projects/dirdiff/
diff --git a/sysutils/dirdiff/pkg-plist b/sysutils/dirdiff/pkg-plist
deleted file mode 100644
index b8a59a2d5b59..000000000000
--- a/sysutils/dirdiff/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/dirdiff
-lib/libfilecmp.so.0