aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dirvish/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-04 13:28:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-04 13:28:47 +0000
commitff3b5867ac3f8f5fd4f35789ad01bcce4bd2eb8e (patch)
treeb3e85d7b25c680964cb10f3de8582e6b2124a45c /sysutils/dirvish/Makefile
parent915db8d4e83bdfb3368add7a5d6463ff65a281df (diff)
downloadports-ff3b5867ac3f8f5fd4f35789ad01bcce4bd2eb8e.tar.gz
ports-ff3b5867ac3f8f5fd4f35789ad01bcce4bd2eb8e.zip
Notes
Diffstat (limited to 'sysutils/dirvish/Makefile')
-rw-r--r--sysutils/dirvish/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/dirvish/Makefile b/sysutils/dirvish/Makefile
new file mode 100644
index 000000000000..b440fdeeac17
--- /dev/null
+++ b/sysutils/dirvish/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: dirvish
+# Date created: 28 April 2005
+# Whom: Loren M. Lang
+#
+# $FreeBSD$
+#
+
+PORTNAME= dirvish
+PORTVERSION= 1.2
+CATEGORIES= sysutils archivers
+MASTER_SITES= http://www.dirvish.org/
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= lorenl@alzatex.com
+COMMENT= Network backup system based off of rsync
+
+RUN_DEPENDS= ${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
+ ${SITE_PERL}/Time/Period.pm:${PORTSDIR}/devel/p5-Time-Period
+
+MAN5= dirvish.conf.5
+MAN8= dirvish.8 dirvish-expire.8 dirvish-locate.8 dirvish-runall.8
+
+WRKSRC= ${WRKDIR}/Dirvish-${PORTVERSION}
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+do-install:
+ @(cd ${INSTALL_WRKSRC} && ${SH} install.sh < /dev/null)
+ ${MKDIR} ${PREFIX}/etc/dirvish
+
+.include <bsd.port.mk>