aboutsummaryrefslogtreecommitdiff
path: root/sysutils/disktool
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-28 20:36:30 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-28 20:36:30 +0000
commit99b92e4d722c825b0a8cb2a9a84d9cd6023d2e26 (patch)
treed51041e4f7517035d2e40478495d4b7d5f22587f /sysutils/disktool
parent2ec826ae424bd92fd08824f039234f74f9cf372a (diff)
downloadports-99b92e4d722c825b0a8cb2a9a84d9cd6023d2e26.tar.gz
ports-99b92e4d722c825b0a8cb2a9a84d9cd6023d2e26.zip
Notes
Diffstat (limited to 'sysutils/disktool')
-rw-r--r--sysutils/disktool/Makefile9
-rw-r--r--sysutils/disktool/files/extrapatch-disktool.c15
2 files changed, 23 insertions, 1 deletions
diff --git a/sysutils/disktool/Makefile b/sysutils/disktool/Makefile
index 213968e8abcd..691585e6f2ec 100644
--- a/sysutils/disktool/Makefile
+++ b/sysutils/disktool/Makefile
@@ -7,6 +7,7 @@
PORTNAME= disktool
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://ftp.auxio.org/pub/mirrors/step.polymtl.ca/pub/Xview/apps/disktool/
DISTNAME= disktool-2.0c
@@ -26,6 +27,12 @@ ALL_TARGET= disktool
MAN1= disktool.1
PLIST_FILES= bin/disktool
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-disktool.c
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
@@ -34,4 +41,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/disktool.man \
${PREFIX}/man/man1/disktool.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/disktool/files/extrapatch-disktool.c b/sysutils/disktool/files/extrapatch-disktool.c
new file mode 100644
index 000000000000..c769cc803d7e
--- /dev/null
+++ b/sysutils/disktool/files/extrapatch-disktool.c
@@ -0,0 +1,15 @@
+--- disktool.c.orig Fri Oct 28 14:10:55 2005
++++ disktool.c Fri Oct 28 14:13:09 2005
+@@ -168,9 +168,9 @@
+ }
+
+ /* ==========================================================================*/
+-long kbytes(blocks, blocksize)
+- long blocks;
+- long blocksize;
++int64_t kbytes(blocks, blocksize)
++ int64_t blocks;
++ uint64_t blocksize;
+ {
+ /* Return number of kilobytes given the number of blocks and the block size.
+ This isn't quite trivial because a 32 bit signed long integer could easily