aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dmidecode
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2003-11-19 21:23:26 +0000
committerAnders Nordby <anders@FreeBSD.org>2003-11-19 21:23:26 +0000
commitfac8a2d3537d89bc93ef23f6e3f466e57bb0e052 (patch)
tree2cb885dffd0f490375e95b3e8ffb8940bd086af0 /sysutils/dmidecode
parent36062a41a8216b9c468d6896931121f55a10893e (diff)
downloadports-fac8a2d3537d89bc93ef23f6e3f466e57bb0e052.tar.gz
ports-fac8a2d3537d89bc93ef23f6e3f466e57bb0e052.zip
Notes
Diffstat (limited to 'sysutils/dmidecode')
-rw-r--r--sysutils/dmidecode/Makefile35
-rw-r--r--sysutils/dmidecode/distinfo1
-rw-r--r--sysutils/dmidecode/pkg-descr6
-rw-r--r--sysutils/dmidecode/pkg-plist8
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/dmidecode/Makefile b/sysutils/dmidecode/Makefile
new file mode 100644
index 000000000000..bf519cb01c63
--- /dev/null
+++ b/sysutils/dmidecode/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: dmidecode
+# Date created: 19 November 2003
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dmidecode
+PORTVERSION= 2.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}.pkg/${PORTVERSION}
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= A tool for dumping DMI (SMBIOS) contents in human-readable format
+
+ONLY_FOR_ARCHS= i386 amd64 ia64
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+DOCS= AUTHORS CHANGELOG README
+
+post-patch:
+ ${REINPLACE_CMD} -e "s@^(CC|PREFIX).*@@" ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/dmidecode/distinfo b/sysutils/dmidecode/distinfo
new file mode 100644
index 000000000000..657a47251a46
--- /dev/null
+++ b/sysutils/dmidecode/distinfo
@@ -0,0 +1 @@
+MD5 (dmidecode-2.3.tar.bz2) = b826e2eda9a1710c85e11e5c26920d23
diff --git a/sysutils/dmidecode/pkg-descr b/sysutils/dmidecode/pkg-descr
new file mode 100644
index 000000000000..f737912c603e
--- /dev/null
+++ b/sysutils/dmidecode/pkg-descr
@@ -0,0 +1,6 @@
+Dmidecode is a tool or dumping a computer's DMI (some say SMBIOS) table
+contents in a human-readable format. The output contains a description of the
+system's hardware components, as well as other useful pieces of information
+such as serial numbers and BIOS revision.
+
+WWW: http://www.nongnu.org/dmidecode/
diff --git a/sysutils/dmidecode/pkg-plist b/sysutils/dmidecode/pkg-plist
new file mode 100644
index 000000000000..0e91d87dd3d1
--- /dev/null
+++ b/sysutils/dmidecode/pkg-plist
@@ -0,0 +1,8 @@
+sbin/biosdecode
+sbin/dmidecode
+sbin/ownership
+sbin/vpddecode
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%