aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dmidecode
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-25 19:34:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-25 19:34:54 +0000
commit0adb0c207ec33527612d6d3206016a4168a2a5ba (patch)
treecae7ae29cad3330782b2159c570896a2e7a43022 /sysutils/dmidecode
parent56e8b9c3863edbcd9661d1a2836adf95f16d194b (diff)
downloadports-0adb0c207ec33527612d6d3206016a4168a2a5ba.tar.gz
ports-0adb0c207ec33527612d6d3206016a4168a2a5ba.zip
Notes
Diffstat (limited to 'sysutils/dmidecode')
-rw-r--r--sysutils/dmidecode/Makefile4
-rw-r--r--sysutils/dmidecode/distinfo4
-rw-r--r--sysutils/dmidecode/files/patch-Makefile33
3 files changed, 23 insertions, 18 deletions
diff --git a/sysutils/dmidecode/Makefile b/sysutils/dmidecode/Makefile
index 68d1ba89b828..9d568464b477 100644
--- a/sysutils/dmidecode/Makefile
+++ b/sysutils/dmidecode/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dmidecode
-PORTVERSION= 2.6
+PORTVERSION= 2.7
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -20,7 +20,7 @@ ONLY_FOR_ARCHS= i386 amd64 ia64
USE_BZIP2= yes
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
-MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" DOCSDIR="${DOCSDIR}"
PORTDOCS= AUTHORS CHANGELOG README
diff --git a/sysutils/dmidecode/distinfo b/sysutils/dmidecode/distinfo
index a1b558795333..bc7598f94736 100644
--- a/sysutils/dmidecode/distinfo
+++ b/sysutils/dmidecode/distinfo
@@ -1,2 +1,2 @@
-MD5 (dmidecode-2.6.tar.bz2) = 16a31f6e70f6f1de864105c633e1a4c0
-SIZE (dmidecode-2.6.tar.bz2) = 40215
+MD5 (dmidecode-2.7.tar.bz2) = 7aaf44ff2501cafc33634bbaa0d2af13
+SIZE (dmidecode-2.7.tar.bz2) = 44749
diff --git a/sysutils/dmidecode/files/patch-Makefile b/sysutils/dmidecode/files/patch-Makefile
index 406565c4f852..259133cfca73 100644
--- a/sysutils/dmidecode/files/patch-Makefile
+++ b/sysutils/dmidecode/files/patch-Makefile
@@ -1,31 +1,36 @@
---- Makefile.orig Mon Feb 28 21:43:00 2005
-+++ Makefile Sun Mar 20 22:16:32 2005
-@@ -8,9 +8,9 @@
+--- Makefile.orig Wed Jun 15 20:22:35 2005
++++ Makefile Fri Nov 25 20:31:58 2005
+@@ -8,25 +8,25 @@
# Licensed under the GNU Public License.
#
-CC = gcc
-CFLAGS = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
-- -Wcast-align -Wwrite-strings -Wmissing-prototypes
-+CFLAGS += -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
-+ -Wcast-align -Wwrite-strings -Wmissing-prototypes ${CPPFLAGS} \
-+ -DHAVE_DECL_GETOPT
+- -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline
++CFLAGS+= -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
++ -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline
++CFLAGS+= ${CPPFLAGS}
#CFLAGS += -DBIGENDIAN
#CFLAGS += -DALIGNMENT_WORKAROUND
-@@ -19,12 +19,11 @@
+ # When debugging, disable -O2 and enable -g.
+-CFLAGS += -O2
++#CFLAGS += -O2
#CFLAGS += -g
# Pass linker flags here
-LDFLAGS =
-+LDFLAGS +=
++LDFLAGS+=
DESTDIR =
-prefix = /usr/local
--sbindir = $(prefix)/sbin
--mandir = $(prefix)/man
-+sbindir = $(PREFIX)/sbin
-+mandir = $(PREFIX)/man
++prefix = $(PREFIX)
+ sbindir = $(prefix)/sbin
+-mandir = $(prefix)/share/man
++mandir = $(MANPREFIX)/man
man8dir = $(mandir)/man8
+-docdir = $(prefix)/share/doc/dmidecode
++docdir = $(DOCSDIR)
- all : dmidecode biosdecode ownership vpddecode
+ INSTALL := install
+ INSTALL_DATA := $(INSTALL) -m 644