aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dolly+/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-07-20 22:09:47 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-07-20 22:09:47 +0000
commitfdf5e9f29ad4a3efe26c2431f89f91e25cf20d37 (patch)
treedc1fd7dd06fb249578016d46cc3842a0032f202b /sysutils/dolly+/Makefile
parent10379bfe47e40791475f72651976cd3ac17ea2f5 (diff)
downloadports-fdf5e9f29ad4a3efe26c2431f89f91e25cf20d37.tar.gz
ports-fdf5e9f29ad4a3efe26c2431f89f91e25cf20d37.zip
Notes
Diffstat (limited to 'sysutils/dolly+/Makefile')
-rw-r--r--sysutils/dolly+/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/dolly+/Makefile b/sysutils/dolly+/Makefile
new file mode 100644
index 000000000000..841cfb85a2f2
--- /dev/null
+++ b/sysutils/dolly+/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: dolly+
+# Date created: Thu Jul 15 10:13:27 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dolly+
+PORTVERSION= 0.93
+CATEGORIES= sysutils net
+MASTER_SITES= http://corvus.kek.jp/~manabe/pcf/dolly/
+DISTNAME= dolly${PORTVERSION:S/./_/}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Improved version of dolly harddisk/partition network clone utility
+
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+
+PROGRAM_BIN_FILES= dollyC
+PROGRAM_SBIN_FILES= dollyS dping
+
+PLIST_FILES= bin/dollyC \
+ sbin/dollyS \
+ sbin/dping
+
+do-configure:
+# CXX{,FLAGS}, PTHREAD_* safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|^(CXXFLAGS[[:space:]]*=.*)$$|\1 ${CXXFLAGS} ${PTHREAD_CFLAGS}|' \
+ -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+
+do-install:
+.for file in ${PROGRAM_BIN_FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin/
+.endfor
+.for file in ${PROGRAM_SBIN_FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/sbin/
+.endfor
+
+.include <bsd.port.mk>