aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dtc/Makefile
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2006-11-20 14:19:39 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2006-11-20 14:19:39 +0000
commit7e035d537f565289335c1402b8468bad10df6509 (patch)
tree26bdf2636414fd71e13951268d7463fd7f03a9f4 /sysutils/dtc/Makefile
parent37363d36c2c98620d3ba8150d15c39859919a90d (diff)
Notes
Diffstat (limited to 'sysutils/dtc/Makefile')
-rw-r--r--sysutils/dtc/Makefile76
1 files changed, 63 insertions, 13 deletions
diff --git a/sysutils/dtc/Makefile b/sysutils/dtc/Makefile
index 657787b8b0c6..220053c43b29 100644
--- a/sysutils/dtc/Makefile
+++ b/sysutils/dtc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dtc
-PORTVERSION= 0.17.0.4
+PORTVERSION= 0.24.6.1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.gplhost.com/pub/dtc/bsd/
@@ -14,32 +14,82 @@ MAINTAINER= thomas@goirand.fr
COMMENT= A hosting web GUI for admin and accounting all hosting services
RUN_DEPENDS= ${LOCALBASE}/share/pear/Crypt/CBC.php:${PORTSDIR}/security/pear-Crypt_CBC \
- proftpd-mysql>=0:${PORTSDIR}/ftp/proftpd-mysql \
- ${LOCALBASE}/libexec/apache/mod_log_sql.so:${PORTSDIR}/www/mod_log_sql2 \
- ${LOCALBASE}/bin/webalizer:${PORTSDIR}/www/webalizer \
- ${LOCALBASE}/www/cgi-bin/sbox:${PORTSDIR}/www/sbox-dtc
+ ${LOCALBASE}/libexec/apache22/mod_log_sql.so:${PORTSDIR}/www/mod_log_sql2-dtc \
+ ${LOCALBASE}/www/cgi-bin/sbox:${PORTSDIR}/www/sbox-dtc \
+ ${LOCALBASE}/bin/sudo:${PORTSDIR}/security/sudo \
+ ${LOCALBASE}/bin/run-mailcap:${PORTSDIR}/misc/mime-support \
+ ${LOCALBASE}/lib/nss_mysql.so:${PORTSDIR}/net/libnss-mysql \
+ ${LOCALBASE}/sbin/chrootuid:${PORTSDIR}/security/chrootuid \
+ ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/net/rrdtool \
+ ${X11BASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera \
+ ${X11BASE}/lib/X11/fonts/webfonts/verdana.ttf:${PORTSDIR}/x11-fonts/webfonts \
+ ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql50-server
NO_BUILD= yes
-USE_MYSQL= yes
USE_PHP= mysql pcre session
.if defined(WITH_PHP5)
DEFAULT_PHP_VER=5
-IGNORE_WITH_PHP=4
+BROKEN_WITH_PHP=4
+RUN_DEPENDS+= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
USE_PHP+= bz2 gd mbstring mcrypt mysql mysqli openssl pcre \
pear session sockets xml zlib
.endif
-DTCROOT?= www/dtc
-DTCDIR= ${PREFIX}/${DTCROOT}
-PLIST_SUB+= DTCROOT="${DTCROOT}"
+.if defined(DTC_TOASTER)
+RUN_DEPENDS+= ${LOCALBASE}/bin/webalizer:${PORTSDIR}/www/webalizer \
+ ${LOCALBASE}/www/awstats:${PORTSDIR}/www/awstats \
+ ${LOCALBASE}/bin/mhonarc:${PORTSDIR}/www/mhonarc \
+ ${LOCALBASE}/bin/mlmmj-list:${PORTSDIR}/mail/mlmmj \
+ ${LOCALBASE}/sbin/pure-ftpd:${PORTSDIR}/ftp/pure-ftpd \
+ ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix \
+ ${LOCALBASE}/cyrus/bin/deliver:${PORTSDIR}/mail/cyrus-imapd23
+USE_APACHE= 2.2+
+
+.else
+
+.if defined(WITH_WEBALIZER)
+RUN_DEPENDS+= ${LOCALBASE}/bin/webalizer:${PORTSDIR}/www/webalizer
+.endif
+
+.if defined(WITH_AWSTATS)
+RUN_DEPENDS+= ${LOCALBASE}/www/awstats:${PORTSDIR}/www/awstats
+.endif
+
+.if defined(WITH_MHONARC)
+RUN_DEPENDS+= ${LOCALBASE}/bin/mhonarc:${PORTSDIR}/www/mhonarc
+.endif
+
+.if defined(WITH_MLMMJ)
+RUN_DEPENDS+= ${LOCALBASE}/bin/mlmmj-list:${PORTSDIR}/mail/mlmmj
+.endif
+
+.if defined(WITH_PUREFTPD)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/pure-ftpd:${PORTSDIR}/ftp/pure-ftpd
+.elif defined(WITH_PROFTPD)
+RUN_DEPENDS+= proftpd-mysql>=0:${PORTSDIR}/ftp/proftpd-mysql
+.endif
+
+.if defined(WITH_POSTFIX)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix
+.if defined(WITH_CYRUS_IMAPD)
+RUN_DEPENDS+= ${LOCALBASE}/cyrus/bin/deliver:${PORTSDIR}/mail/cyrus-imapd23
+.endif
+.elif defined(WITH_COURIER)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/courier/courierd:${PORTSDIR}/mail/courier \
+ ${LOCALBASE}/lib/pam_mysql.so:${PORTSDIR}/security/pam-mysql
+.endif
-# Now tested and working. In fact, under BSD it's easyer to use Apache2 now.
-# If you know what to do so all dependancies are set correctly, please help!
.if defined(WITH_APACHE2)
-IGNORE= with Apache 2 is untested
+USE_APACHE= 2.2+
.endif
+.endif
+
+DTCROOT?= www/dtc
+DTCDIR= ${PREFIX}/${DTCROOT}
+PLIST_SUB+= DTCROOT="${DTCROOT}"
+
SUB_FILES= dtc-install dtc-deinstall
SUB_LIST+= QMAIL_DIR="${QMAIL_DIR}"