aboutsummaryrefslogtreecommitdiff
path: root/sysutils/du2ps
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-03-21 08:59:21 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-03-21 08:59:21 +0000
commit6dfe7ff622a0c7300c683e4885e9def33da1663b (patch)
tree184b73843558cbe17654fdbb490d5145e95f07fa /sysutils/du2ps
parentb874d8a8f2ed6944e814f7059a7cbfc6a9accc00 (diff)
downloadports-6dfe7ff622a0c7300c683e4885e9def33da1663b.tar.gz
ports-6dfe7ff622a0c7300c683e4885e9def33da1663b.zip
Notes
Diffstat (limited to 'sysutils/du2ps')
-rw-r--r--sysutils/du2ps/Makefile3
-rw-r--r--sysutils/du2ps/distinfo3
-rw-r--r--sysutils/du2ps/files/patch-ac36
-rw-r--r--sysutils/du2ps/files/patch-du2ps.c11
4 files changed, 48 insertions, 5 deletions
diff --git a/sysutils/du2ps/Makefile b/sysutils/du2ps/Makefile
index db147c894bcc..cedf143561c7 100644
--- a/sysutils/du2ps/Makefile
+++ b/sysutils/du2ps/Makefile
@@ -7,8 +7,9 @@
PORTNAME= du2ps
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= sysutils
-MASTER_SITES= http://www.shobi-u.ac.jp/~tnagae/src/ps-c/du2ps/du2ps-2.1/
+MASTER_SITES= http://www.research.co.jp/software/du2ps/
EXTRACT_SUFX= .tgz
MAINTAINER= mistral@imasy.or.jp
diff --git a/sysutils/du2ps/distinfo b/sysutils/du2ps/distinfo
index 00eab78daa03..a0ca9aac3c4a 100644
--- a/sysutils/du2ps/distinfo
+++ b/sysutils/du2ps/distinfo
@@ -1 +1,2 @@
-MD5 (du2ps-2.1.tgz) = f39e4724cb1a8831f0355fbeb8d819a6
+MD5 (du2ps-2.1.tgz) = e0f1366513b1a257cfdb4676bb8c4f9c
+SIZE (du2ps-2.1.tgz) = 9152
diff --git a/sysutils/du2ps/files/patch-ac b/sysutils/du2ps/files/patch-ac
index 7b7471ab2312..a979c3fc7f77 100644
--- a/sysutils/du2ps/files/patch-ac
+++ b/sysutils/du2ps/files/patch-ac
@@ -1,6 +1,6 @@
---- nodeop.c.orig Tue Mar 15 18:15:58 1994
-+++ nodeop.c Wed Jun 6 15:03:28 2001
-@@ -142,7 +142,8 @@
+--- nodeop.c.orig Wed Mar 16 13:10:45 1994
++++ nodeop.c Sun Mar 21 17:44:55 2004
+@@ -142,7 +142,8 @@ int depth;
/* for each child */
for(np = nodep->child; NODE_NULL != np; np = np->peer){
@@ -10,3 +10,33 @@
drawrect(np, y, height, depth);
+@@ -172,9 +173,9 @@ parse()
+ if('/' == *n) n++; /* skip leading / */
+ path[depth = 0] = n;
+
+- for(; NULL != *n; n++){
++ for(; '\0' != *n; n++){
+ if('/' == *n){
+- *n = NULL;
++ *n = '\0';
+ path[++depth] = n + 1;
+ if(depth > MAXDEPTH) break;
+ }
+@@ -193,7 +194,7 @@ parse()
+
+ if (1 == top->nchild) {
+ top = top->child;
+- while (NULL != *n) n++;
++ while ('\0' != *n) n++;
+ *n = '/';
+ }
+ else if(1 < top->nchild){
+@@ -204,7 +205,7 @@ parse()
+ }
+ else break;
+ }
+- *n = NULL;
++ *n = '\0';
+ return strdup(name);
+ }
+
diff --git a/sysutils/du2ps/files/patch-du2ps.c b/sysutils/du2ps/files/patch-du2ps.c
new file mode 100644
index 000000000000..17e0fdc93dc6
--- /dev/null
+++ b/sysutils/du2ps/files/patch-du2ps.c
@@ -0,0 +1,11 @@
+--- du2ps.c.orig Wed Mar 16 11:41:16 1994
++++ du2ps.c Sun Mar 21 17:36:26 2004
+@@ -57,7 +57,7 @@
+ for(; NULL != *mes; mes++) puts(*mes);
+ }
+
+-void
++int
+ main(argc,argv)
+ int argc;
+ char **argv;