aboutsummaryrefslogtreecommitdiff
path: root/sysutils/duplicity-devel/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-07-03 06:57:30 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-07-03 06:57:30 +0000
commitad5bdb8126bb509771b46b52045a24725fda9e5d (patch)
tree72be6df03cec3759b6173d06d74b0f69d4373982 /sysutils/duplicity-devel/Makefile
parent700261726cfd6e498217d45e46501d01a549af62 (diff)
downloadports-ad5bdb8126bb509771b46b52045a24725fda9e5d.tar.gz
ports-ad5bdb8126bb509771b46b52045a24725fda9e5d.zip
Notes
Diffstat (limited to 'sysutils/duplicity-devel/Makefile')
-rw-r--r--sysutils/duplicity-devel/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/duplicity-devel/Makefile b/sysutils/duplicity-devel/Makefile
new file mode 100644
index 000000000000..134d0aee0e5f
--- /dev/null
+++ b/sysutils/duplicity-devel/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: duplicity
+# Date created: Wed Jun 11 19:53:46 CEST 2003
+# Whom: Gerhard Häring <gh@ghaering.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= duplicity
+PORTVERSION= 0.4.0
+CATEGORIES= sysutils
+MASTER_SITES= http://savannah.nongnu.org/download/duplicity/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gh@ghaering.de
+COMMENT= Untrusted backup using rsync algorithm
+
+LIB_DEPENDS= rsync.1:${PORTSDIR}/net/librsync
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+MAN1= duplicity.1 rdiffdir.1
+
+DOCFILES= CHANGELOG COPYING README
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/duplicity.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/rdiffdir.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>