aboutsummaryrefslogtreecommitdiff
path: root/sysutils/duplicity-devel/files
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-07-03 06:57:30 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-07-03 06:57:30 +0000
commitad5bdb8126bb509771b46b52045a24725fda9e5d (patch)
tree72be6df03cec3759b6173d06d74b0f69d4373982 /sysutils/duplicity-devel/files
parent700261726cfd6e498217d45e46501d01a549af62 (diff)
downloadports-ad5bdb8126bb509771b46b52045a24725fda9e5d.tar.gz
ports-ad5bdb8126bb509771b46b52045a24725fda9e5d.zip
Notes
Diffstat (limited to 'sysutils/duplicity-devel/files')
-rw-r--r--sysutils/duplicity-devel/files/patch-setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/duplicity-devel/files/patch-setup.py b/sysutils/duplicity-devel/files/patch-setup.py
new file mode 100644
index 000000000000..2484a45dd4ee
--- /dev/null
+++ b/sysutils/duplicity-devel/files/patch-setup.py
@@ -0,0 +1,38 @@
+*** /tmp/duplicity-0.4.0/setup.py Sat Nov 30 23:41:29 2002
+--- setup.py Wed Jun 11 20:31:32 2003
+***************
+*** 9,14 ****
+--- 9,18 ----
+ print "Sorry, duplicity requires version 2.2 or later of python"
+ sys.exit(1)
+
++ LOCALBASE = os.environ.get("LOCALBASE", "/usr/local")
++ include_dirs = ['%s/include' % LOCALBASE]
++ library_dirs = ['%s/lib/' % LOCALBASE]
++
+ setup(name="duplicity",
+ version=version_string,
+ description="Untrusted backup using rsync algorithm",
+***************
+*** 19,28 ****
+ package_dir = {"duplicity": "src"},
+ ext_modules = [Extension("duplicity._librsync",
+ ["_librsyncmodule.c"],
+! libraries=["rsync"])],
+! scripts = ['rdiffdir', 'duplicity'],
+! data_files = [('share/man/man1', ['duplicity.1', 'rdiffdir.1']),
+! ('share/doc/duplicity-%s' % version_string,
+! ['COPYING', 'README', 'CHANGELOG'])])
+
+
+--- 23,32 ----
+ package_dir = {"duplicity": "src"},
+ ext_modules = [Extension("duplicity._librsync",
+ ["_librsyncmodule.c"],
+! libraries=["rsync"],
+! include_dirs=include_dirs,
+! library_dirs=library_dirs)],
+! scripts = ['rdiffdir', 'duplicity']
+! )
+
+