aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dvdbackup
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-12-11 21:18:01 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-12-11 21:18:01 +0000
commit6f8173f4909f8c381c7bcf08ee405b82a25ce835 (patch)
tree02a122decd5e5fad8cf389a7030dd7fc67dd6abc /sysutils/dvdbackup
parent67855a20126328d2aac0eb98eec2bc497e56947e (diff)
downloadports-6f8173f4909f8c381c7bcf08ee405b82a25ce835.tar.gz
ports-6f8173f4909f8c381c7bcf08ee405b82a25ce835.zip
Notes
Diffstat (limited to 'sysutils/dvdbackup')
-rw-r--r--sysutils/dvdbackup/Makefile1
-rw-r--r--sysutils/dvdbackup/files/patch-src::dvdbackup.c59
2 files changed, 60 insertions, 0 deletions
diff --git a/sysutils/dvdbackup/Makefile b/sysutils/dvdbackup/Makefile
index 0df16e0c32ad..88620908bc76 100644
--- a/sysutils/dvdbackup/Makefile
+++ b/sysutils/dvdbackup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dvdbackup
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://dvd-create.sourceforge.net/
diff --git a/sysutils/dvdbackup/files/patch-src::dvdbackup.c b/sysutils/dvdbackup/files/patch-src::dvdbackup.c
new file mode 100644
index 000000000000..bc7ebfc6d8d8
--- /dev/null
+++ b/sysutils/dvdbackup/files/patch-src::dvdbackup.c
@@ -0,0 +1,59 @@
+--- src/dvdbackup.c.orig Mon Aug 5 02:08:39 2002
++++ src/dvdbackup.c Sat Dec 11 16:10:31 2004
+@@ -210,6 +210,7 @@
+ fprintf(stderr,"\t-v X\t\twhere X is the amount of verbosity\n");
+ fprintf(stderr,"\t-I\t\tfor information about the DVD\n");
+ fprintf(stderr,"\t-o directory\twhere directory is your backup target\n");
++ fprintf(stderr,"\t-n\t\tuse this as DVD name (if we can't get it)\n");
+ fprintf(stderr,"\t-M\t\tbackup the whole DVD\n");
+ fprintf(stderr,"\t-F\t\tbackup the main feature of the DVD\n");
+ fprintf(stderr,"\t-T X\t\tbackup title set X\n");
+@@ -219,8 +220,8 @@
+ fprintf(stderr,"\t-a 0\t\tto get aspect ratio 4:3 instead of 16:9 if both are present\n");
+ fprintf(stderr,"\t-h\t\tprint a brief usage message\n");
+ fprintf(stderr,"\t-?\t\tprint a brief usage message\n\n");
+- fprintf(stderr,"\t-i is manditory\n");
+- fprintf(stderr,"\t-o is manditory except if you use -I\n");
++ fprintf(stderr,"\t-i is mandatory\n");
++ fprintf(stderr,"\t-o is mandatory except if you use -I\n");
+ fprintf(stderr,"\t-a is option to the -F switch and has no effect on other options\n");
+ fprintf(stderr,"\t-s and -e should prefereibly be used together with -t \n\n");
+ exit(1);
+@@ -1530,7 +1531,7 @@
+
+ /* Seek to title of first track, which is at (track_no * 32768) + 40 */
+
+- if ( 32808 != lseek(filehandle, 32808, SEEK_SET) ) {
++ if ( 32768 != lseek(filehandle, 32768, SEEK_SET) ) {
+ close(filehandle);
+ fprintf(stderr, "Can't seek DVD device %s - check your DVD device\n", device);
+ return(1);
+@@ -1538,12 +1539,18 @@
+
+ /* Read the DVD-Video title */
+
+- if ( 32 != read(filehandle, title, 32)) {
++#define DVD_SEC_SIZ 2048
++ {
++ char tempBuf[ DVD_SEC_SIZ ];
++
++ if ( DVD_SEC_SIZ != read(filehandle, tempBuf, DVD_SEC_SIZ)) {
+ close(filehandle);
+ fprintf(stderr, "Can't read title from DVD device %s\n", device);
+ return(1);
+ }
+
++ snprintf( title, 32, "%s", tempBuf + 40 );
++ }
+ /* Terminate the title string */
+
+ title[32] = '\0';
+@@ -2164,7 +2171,7 @@
+ DVDGetTitleName(dvd,title_name);
+
+
+- fprintf(stdout,"\n\n\nDVD-Video information of the DVD with tile %s\n\n", title_name);
++ fprintf(stdout,"\n\n\nDVD-Video information of the DVD with title %s\n\n", title_name);
+
+ /* Print file structure */
+