aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dvdbackup
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-01 10:01:14 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-01 10:01:14 +0000
commit88789d1abb5778dd8b59c3fdbcf4a1011d252789 (patch)
tree9b929b344b1acbdc9432b3e6aec4a159d9da29ca /sysutils/dvdbackup
parent02b6588d4585ac9bc71d3f71f10c68bbf37b2fed (diff)
downloadports-88789d1abb5778dd8b59c3fdbcf4a1011d252789.tar.gz
ports-88789d1abb5778dd8b59c3fdbcf4a1011d252789.zip
- Only check for largest title set if there is more than one title set.
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=130086
Diffstat (limited to 'sysutils/dvdbackup')
-rw-r--r--sysutils/dvdbackup/Makefile2
-rw-r--r--sysutils/dvdbackup/files/patch-src::dvdbackup.c11
2 files changed, 11 insertions, 2 deletions
diff --git a/sysutils/dvdbackup/Makefile b/sysutils/dvdbackup/Makefile
index 88620908bc76..5e8bdff69861 100644
--- a/sysutils/dvdbackup/Makefile
+++ b/sysutils/dvdbackup/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvdbackup
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://dvd-create.sourceforge.net/
diff --git a/sysutils/dvdbackup/files/patch-src::dvdbackup.c b/sysutils/dvdbackup/files/patch-src::dvdbackup.c
index bc7ebfc6d8d8..ee1f81bdfd1c 100644
--- a/sysutils/dvdbackup/files/patch-src::dvdbackup.c
+++ b/sysutils/dvdbackup/files/patch-src::dvdbackup.c
@@ -1,5 +1,5 @@
--- src/dvdbackup.c.orig Mon Aug 5 02:08:39 2002
-+++ src/dvdbackup.c Sat Dec 11 16:10:31 2004
++++ src/dvdbackup.c Tue Mar 1 05:01:19 2005
@@ -210,6 +210,7 @@
fprintf(stderr,"\t-v X\t\twhere X is the amount of verbosity\n");
fprintf(stderr,"\t-I\t\tfor information about the DVD\n");
@@ -19,6 +19,15 @@
fprintf(stderr,"\t-a is option to the -F switch and has no effect on other options\n");
fprintf(stderr,"\t-s and -e should prefereibly be used together with -t \n\n");
exit(1);
+@@ -782,7 +783,7 @@
+ to consider the second one a feature title we are doing two checks (biggest + biggest - second) /second == 1
+ and biggest%second * 3 < biggest */
+
+- if ( CheckSizeArray(size_size_array, 0, 1) == 1 ) {
++ if ( CheckSizeArray(size_size_array, 0, 1) == 1 && title_sets >1 ) {
+ /* We have a dual DVD with two feature films - now lets see if they have the same amount of chapters*/
+
+ chapters_1 = 0;
@@ -1530,7 +1531,7 @@
/* Seek to title of first track, which is at (track_no * 32768) + 40 */