aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dvtm/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-18 15:30:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-18 15:30:36 +0000
commitfb8eecf90077bb75867cb3e74710fa4be4a0499b (patch)
tree93a0b1de0a0a39bd4c53a13b1fe0ae362e5f3c75 /sysutils/dvtm/Makefile
parent03c2de95ff58c64d4012a9e746772efd13fdecf7 (diff)
Notes
Diffstat (limited to 'sysutils/dvtm/Makefile')
-rw-r--r--sysutils/dvtm/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/dvtm/Makefile b/sysutils/dvtm/Makefile
new file mode 100644
index 000000000000..4f714df90497
--- /dev/null
+++ b/sysutils/dvtm/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dvtm
+# Date created: May 18, 2008
+# Whom: Beat Gätzi <beat@chruetertee.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvtm
+PORTVERSION= 0.4.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.brain-dump.org/projects/dvtm/
+
+MAINTAINER= beat@chruetertee.ch
+COMMENT= Tiling window management for the console
+
+MAN1= dvtm.1
+PLIST_FILES= bin/dvtm bin/dvtm-status
+
+pre-everything::
+ @${ECHO_MSG} "You can build dvtm with your own config.h using the DVTM_CONF knob:"
+ @${ECHO_MSG} "make DVTM_CONF=/path/to/dvtm/config.h install clean"
+
+post-extract:
+.if defined(DVTM_CONF)
+ @${ECHO_MSG} "creating config.h from ${DVTM_CONF}"
+ @${CP} ${DVTM_CONF} ${WRKSRC}/config.h
+.endif
+
+.include <bsd.port.mk>