aboutsummaryrefslogtreecommitdiff
path: root/sysutils/e2fsprogs/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-01-27 01:24:41 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-01-27 01:24:41 +0000
commit47f9d8fd4663f9c3c71462af7c4b3275bde2e31a (patch)
tree46fc8d91d267324c4c6a8d84d37e354e6ac2ccb2 /sysutils/e2fsprogs/Makefile
parente9e59493e4b2d017ee2828e33f5ff60e1138bdc2 (diff)
downloadports-47f9d8fd4663f9c3c71462af7c4b3275bde2e31a.tar.gz
ports-47f9d8fd4663f9c3c71462af7c4b3275bde2e31a.zip
Notes
Diffstat (limited to 'sysutils/e2fsprogs/Makefile')
-rw-r--r--sysutils/e2fsprogs/Makefile46
1 files changed, 21 insertions, 25 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 61cdecbefa21..5c98a97fa282 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -7,26 +7,21 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.38
-PORTREVISION= 1
-CATEGORIES= sysutils
+PORTREVISION?= 2
+CATEGORIES?= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= matthias.andree@gmx.de
-COMMENT= Utilities and library to manipulate ext2/ext3 filesystems
+MAINTAINER?= matthias.andree@gmx.de
+COMMENT?= Utilities and library to manipulate ext2/ext3 filesystems
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
.endif
PATCH_STRIP= -p1
-USE_REINPLACE= yes
-USE_GMAKE= yes
-INSTALL_TARGET= install install-libs
-INSTALLS_SHLIB= yes
-NO_FILTER_SHLIBS= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-elf-shlibs --disable-fsck "--with-ldopts=-L${LOCALBASE}/lib"
+CONFIGURE_ARGS?= --disable-fsck --disable-e2initrd-helper "--with-ldopts=-L${LOCALBASE}/lib"
CONFIGURE_ENV+= CPPFLAGS='-I${WRKSRC}/lib -I${LOCALBASE}/include'
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
@@ -35,16 +30,12 @@ PLIST_SUB= NLS="@comment "
MAKE_ARGS+= STATIC_LIBS="../lib/libext2fs.a ../lib/libcom_err.a ../lib/libblkid.a ../lib/libuuid.a ${LOCALBASE}/lib/libintl.a ${LOCALBASE}/lib/libiconv.a"
PLIST_SUB= NLS=""
.endif
+INSTALLS_SHLIB= yes
-CONFLICTS= ossp-uuid-[0-9]*
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
+.if !defined(MASTERDIR)
+SUB_FILES= pkg-message
-MAN1= chattr.1 lsattr.1 uuidgen.1 compile_et.1 mk_cmds.1
-MAN3= uuid.3 uuid_clear.3 com_err.3 uuid_compare.3 uuid_copy.3 \
- uuid_generate.3 uuid_is_null.3 uuid_parse.3 uuid_time.3 \
- uuid_unparse.3 uuid_generate_random.3 uuid_generate_time.3 \
- libblkid.3
+MAN1= chattr.1 lsattr.1
MAN8= badblocks.8 debugfs.8 dumpe2fs.8 e2fsck.8 e2image.8 e2label.8 \
mke2fs.8 mklost+found.8 resize2fs.8 tune2fs.8 \
fsck.ext2.8 fsck.ext3.8 mkfs.ext2.8 mkfs.ext3.8 \
@@ -62,30 +53,35 @@ pre-everything::
post-extract:
${CHMOD} u+w ${WRKSRC}/po/*.po ${WRKSRC}/po/*.pot \
${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
.include <bsd.port.pre.mk>
post-patch:
${REINPLACE_CMD} -E -e 's:\$$\(libdir\)/pkgconfig:${PREFIX}/libdata/pkgconfig:' \
${WRKSRC}/lib/*/Makefile.in
+ @: # disable uuidgen
+ ${REINPLACE_CMD} \
+ -e 's/^\(UPROGS.*\) uuidgen\(.*\)/\1\2/' \
+ -e 's/^\(UMANPAGES.*\) uuidgen.1\(.*\)/\1\2/' \
+ ${WRKSRC}/misc/Makefile.in
-pre-install:
- ${RM} -f ${PKGMESSAGE}
- ${SED} -e "s:%%PREFIX%%:${PREFIX}:" ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
-
+.if ${MASTERDIR} == ${.CURDIR}
post-build:
.if !defined(WITHOUT_NLS)
- cd ${WRKSRC}/po && ${GMAKE} update-gmo
+ cd ${WRKSRC}/po && ${MAKE} update-gmo
.endif
- ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} ${LIBS} -o ${WRKSRC}/fsck_ext2fs ${FILESDIR}/fsck_ext2fs.c
- cd ${WRKSRC}/tests && ${GMAKE} check
+ ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -s -static ${LIBS} -o ${WRKSRC}/fsck_ext2fs ${FILESDIR}/fsck_ext2fs.c
+ cd ${WRKSRC}/tests && ${MAKE} check
post-install:
${RM} ${PREFIX}/sbin/filefrag
${RM} ${PREFIX}/man/man8/filefrag.8
+ ${RM} ${PREFIX}/info/libext2fs.info.gz
${INSTALL_PROGRAM} ${WRKSRC}/fsck_ext2fs ${PREFIX}/sbin/
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
+.endif
.include <bsd.port.post.mk>