aboutsummaryrefslogtreecommitdiff
path: root/sysutils/e2fsprogs
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-29 16:40:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-29 16:40:41 +0000
commit819d9c124427924bb257816d515e263599c6a09e (patch)
tree0dde06e3da6ff5f76eaf3188ab76dc061654c1f9 /sysutils/e2fsprogs
parentaeaa89702f78dacd625f208c3e0aaf86d56e8630 (diff)
downloadports-819d9c124427924bb257816d515e263599c6a09e.tar.gz
ports-819d9c124427924bb257816d515e263599c6a09e.zip
Notes
Diffstat (limited to 'sysutils/e2fsprogs')
-rw-r--r--sysutils/e2fsprogs/Makefile5
-rw-r--r--sysutils/e2fsprogs/distinfo4
-rw-r--r--sysutils/e2fsprogs/files/patch-update-to-20040224262
3 files changed, 3 insertions, 268 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 94bdc8d56880..db11ae25712e 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= e2fsprogs
-PORTVERSION= 1.35.w20040131.20040224135102
+PORTVERSION= 1.35
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-1.35-WIP-0131
MAINTAINER= matthias.andree@gmx.de
COMMENT= Utilities and library to manipulate an ext2 or ext3 filesystem
@@ -19,8 +18,6 @@ COMMENT= Utilities and library to manipulate an ext2 or ext3 filesystem
USE_GETTEXT= yes
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-1.35
-
USE_GCC= 3.3
PATCH_STRIP= -p1
USE_AUTOCONF= yes
diff --git a/sysutils/e2fsprogs/distinfo b/sysutils/e2fsprogs/distinfo
index 672f3b90507f..36f5dafd85b2 100644
--- a/sysutils/e2fsprogs/distinfo
+++ b/sysutils/e2fsprogs/distinfo
@@ -1,2 +1,2 @@
-MD5 (e2fsprogs-1.35-WIP-0131.tar.gz) = eccc46cd55d8295d686cf5ac6bbc3784
-SIZE (e2fsprogs-1.35-WIP-0131.tar.gz) = 3123309
+MD5 (e2fsprogs-1.35.tar.gz) = 8d25ffd60d405ef32d341704a2323807
+SIZE (e2fsprogs-1.35.tar.gz) = 3152299
diff --git a/sysutils/e2fsprogs/files/patch-update-to-20040224 b/sysutils/e2fsprogs/files/patch-update-to-20040224
deleted file mode 100644
index 7eb791dd47a1..000000000000
--- a/sysutils/e2fsprogs/files/patch-update-to-20040224
+++ /dev/null
@@ -1,262 +0,0 @@
-diff -Nru a/debugfs/debugfs.8.in b/debugfs/debugfs.8.in
---- a/debugfs/debugfs.8.in Wed Feb 25 02:10:02 2004
-+++ b/debugfs/debugfs.8.in Wed Feb 25 02:10:02 2004
-@@ -237,7 +237,7 @@
- of the inode
- .IR filespec .
- .TP
--.I initialize device blocksize
-+.I init_filesys device blocksize
- Create an ext2 file system on
- .I device
- with device size
-diff -Nru a/debugfs/debugfs.c b/debugfs/debugfs.c
---- a/debugfs/debugfs.c Wed Feb 25 02:10:02 2004
-+++ b/debugfs/debugfs.c Wed Feb 25 02:10:02 2004
-@@ -456,9 +456,26 @@
- if (inode->i_dtime)
- fprintf(out, "%sdtime: 0x%08x -- %s", prefix, inode->i_dtime,
- time_to_string(inode->i_dtime));
-- if (LINUX_S_ISLNK(inode->i_mode) && inode->i_blocks == 0)
-+ if (LINUX_S_ISLNK(inode->i_mode) && ext2fs_inode_data_blocks(current_fs,inode) == 0)
- fprintf(out, "%sFast_link_dest: %.*s\n", prefix,
- (int) inode->i_size, (char *)inode->i_block);
-+ else if (LINUX_S_ISBLK(inode->i_mode) || LINUX_S_ISCHR(inode->i_mode)) {
-+ int major, minor;
-+ const char *devnote;
-+
-+ if (inode->i_block[0]) {
-+ major = (inode->i_block[0] >> 8) & 255;
-+ minor = inode->i_block[0] & 255;
-+ devnote = "";
-+ } else {
-+ major = (inode->i_block[1] & 0xfff00) >> 8;
-+ minor = ((inode->i_block[1] & 0xff) |
-+ ((inode->i_block[1] >> 12) & 0xfff00));
-+ devnote = "(New-style) ";
-+ }
-+ fprintf(out, "%sDevice major/minor number: %02d:%02d (hex %02x:%02x)\n",
-+ devnote, major, minor, major, minor);
-+ }
- else if (do_dump_blocks)
- dump_blocks(out, prefix, inode_num);
- }
-@@ -1181,7 +1198,7 @@
- if (nr == 5) {
- major = strtoul(argv[3], argv+3, 0);
- minor = strtoul(argv[4], argv+4, 0);
-- if (major > 255 || minor > 255 || argv[3][0] || argv[4][0])
-+ if (major > 65535 || minor > 65535 || argv[3][0] || argv[4][0])
- nr = 0;
- }
- if (argc != nr)
-@@ -1215,7 +1232,13 @@
- memset(&inode, 0, sizeof(inode));
- inode.i_mode = mode;
- inode.i_atime = inode.i_ctime = inode.i_mtime = time(NULL);
-- inode.i_block[0] = major*256+minor;
-+ if ((major < 256) && (minor < 256)) {
-+ inode.i_block[0] = major*256+minor;
-+ inode.i_block[1] = 0;
-+ } else {
-+ inode.i_block[0] = 0;
-+ inode.i_block[1] = (minor & 0xff) | (major << 8) | ((minor & ~0xff) << 12);
-+ }
- inode.i_links_count = 1;
- if (debugfs_write_inode(newfile, &inode, argv[0]))
- return;
-diff -Nru a/e2fsck/Makefile.in b/e2fsck/Makefile.in
---- a/e2fsck/Makefile.in Wed Feb 25 02:10:02 2004
-+++ b/e2fsck/Makefile.in Wed Feb 25 02:10:02 2004
-@@ -25,9 +25,9 @@
- $(DEPSTATIC_LIBUUID)
-
- PROFILED_LIBS= $(PROFILED_LIBEXT2FS) $(PROFILED_LIBCOM_ERR) \
-- $(PROFILED_BLKID) $(PROFILED_LIBUUID) $(LIBINTL)
-+ $(PROFILED_LIBBLKID) $(PROFILED_LIBUUID) $(LIBINTL)
- PROFILED_DEPLIBS= $(PROFILED_LIBEXT2FS) $(PROFILED_LIBCOM_ERR) \
-- $(PROFILED_BLKID) $(DEPPROFILED_LIBUUID)
-+ $(PROFILED_LIBBLKID) $(DEPPROFILED_LIBUUID)
-
- .c.o:
- $(CC) -c $(ALL_CFLAGS) $< -o $@
-diff -Nru a/e2fsck/e2fsck.8.in b/e2fsck/e2fsck.8.in
---- a/e2fsck/e2fsck.8.in Wed Feb 25 02:10:02 2004
-+++ b/e2fsck/e2fsck.8.in Wed Feb 25 02:10:02 2004
-@@ -8,7 +8,7 @@
- .SH SYNOPSIS
- .B e2fsck
- [
--.B \-pacnyrdfvstDFSV
-+.B \-pacnyrdfkvstDFSV
- ]
- [
- .B \-b
-@@ -159,6 +159,14 @@
- @JDEV@.BI \-j " external-journal"
- @JDEV@Set the pathname where the external-journal for this filesystem can be
- @JDEV@found.
-+.TP
-+.BI \-k
-+When combined with the
-+.B \-c
-+option, any existing bad blocks in the bad blocks list are preserved,
-+and any new bad blocks found by running
-+.BR badblocks (8)
-+will be added to the existing bad blocks list.
- .TP
- .BI \-l " filename"
- Add the block numbers listed in the file specified by
-diff -Nru a/e2fsck/e2fsck.c b/e2fsck/e2fsck.c
---- a/e2fsck/e2fsck.c Wed Feb 25 02:10:02 2004
-+++ b/e2fsck/e2fsck.c Wed Feb 25 02:10:02 2004
-@@ -180,8 +180,10 @@
- pass_t e2fsck_pass;
-
- #ifdef HAVE_SETJMP_H
-- if (setjmp(ctx->abort_loc))
-+ if (setjmp(ctx->abort_loc)) {
-+ ctx->flags &= ~E2F_FLAG_SETJMP_OK;
- return (ctx->flags & E2F_FLAG_RUN_RETURN);
-+ }
- ctx->flags |= E2F_FLAG_SETJMP_OK;
- #endif
-
-diff -Nru a/e2fsck/pass1b.c b/e2fsck/pass1b.c
---- a/e2fsck/pass1b.c Wed Feb 25 02:10:02 2004
-+++ b/e2fsck/pass1b.c Wed Feb 25 02:10:02 2004
-@@ -248,7 +248,8 @@
-
- clear_problem_context(&pctx);
-
-- fix_problem(ctx, PR_1B_PASS_HEADER, &pctx);
-+ if (!(ctx->options & E2F_OPT_PREEN))
-+ fix_problem(ctx, PR_1B_PASS_HEADER, &pctx);
- pctx.errcode = ext2fs_open_inode_scan(fs, ctx->inode_buffer_blocks,
- &scan);
- if (pctx.errcode) {
-@@ -382,7 +383,8 @@
-
- clear_problem_context(&pctx);
-
-- fix_problem(ctx, PR_1C_PASS_HEADER, &pctx);
-+ if (!(ctx->options & E2F_OPT_PREEN))
-+ fix_problem(ctx, PR_1C_PASS_HEADER, &pctx);
-
- /*
- * Search through all directories to translate inodes to names
-@@ -412,7 +414,8 @@
-
- clear_problem_context(&pctx);
-
-- fix_problem(ctx, PR_1D_PASS_HEADER, &pctx);
-+ if (!(ctx->options & E2F_OPT_PREEN))
-+ fix_problem(ctx, PR_1D_PASS_HEADER, &pctx);
- e2fsck_read_bitmaps(ctx);
-
- pctx.num = dup_inode_count; /* dict_count(&ino_dict); */
-diff -Nru a/e2fsck/problem.c b/e2fsck/problem.c
---- a/e2fsck/problem.c Wed Feb 25 02:10:02 2004
-+++ b/e2fsck/problem.c Wed Feb 25 02:10:02 2004
-@@ -724,12 +724,12 @@
- /* Duplicate/bad block(s) in inode */
- { PR_1B_DUP_BLOCK,
- " %b",
-- PROMPT_NONE, PR_LATCH_DBLOCK },
-+ PROMPT_NONE, PR_LATCH_DBLOCK | PR_PREEN_NOHDR },
-
- /* Duplicate/bad block(s) end */
- { PR_1B_DUP_BLOCK_END,
- "\n",
-- PROMPT_NONE, 0 },
-+ PROMPT_NONE, PR_PREEN_NOHDR },
-
- /* Error while scanning inodes */
- { PR_1B_ISCAN_ERROR,
-diff -Nru a/e2fsck/unix.c b/e2fsck/unix.c
---- a/e2fsck/unix.c Wed Feb 25 02:10:02 2004
-+++ b/e2fsck/unix.c Wed Feb 25 02:10:02 2004
-@@ -53,6 +53,7 @@
- static int verbose;
-
- static int replace_bad_blocks;
-+static int keep_bad_blocks;
- static char *bad_blocks_file;
-
- e2fsck_t e2fsck_global_ctx; /* Try your very best not to use this! */
-@@ -554,7 +555,7 @@
- ctx->program_name = *argv;
- else
- ctx->program_name = "e2fsck";
-- while ((c = getopt (argc, argv, "panyrcC:B:dE:fvtFVM:b:I:j:P:l:L:N:SsD")) != EOF)
-+ while ((c = getopt (argc, argv, "panyrcC:B:dE:fvtFVM:b:I:j:P:l:L:N:SsDk")) != EOF)
- switch (c) {
- case 'C':
- ctx->progress = e2fsck_update_progress;
-@@ -675,6 +676,8 @@
- "of e2fsck\n"));
- exit(1);
- #endif
-+ case 'k':
-+ keep_bad_blocks++;
- default:
- usage(ctx);
- }
-@@ -1034,7 +1037,7 @@
- if (bad_blocks_file)
- read_bad_blocks_file(ctx, bad_blocks_file, replace_bad_blocks);
- else if (cflag)
-- read_bad_blocks_file(ctx, 0, 1); /* Test disk */
-+ read_bad_blocks_file(ctx, 0, !keep_bad_blocks); /* Test disk */
- if (ctx->flags & E2F_FLAG_SIGNAL_MASK)
- fatal_error(ctx, 0);
- #ifdef ENABLE_SWAPFS
-diff -Nru a/lib/ext2fs/ext2fs.h b/lib/ext2fs/ext2fs.h
---- a/lib/ext2fs/ext2fs.h Wed Feb 25 02:10:02 2004
-+++ b/lib/ext2fs/ext2fs.h Wed Feb 25 02:10:02 2004
-@@ -977,7 +977,7 @@
- /*
- * Resize memory
- */
--_INLINE_ errcode_t ext2fs_resize_mem(unsigned long old_size EXT2FS_ATTR((unused)),
-+_INLINE_ errcode_t ext2fs_resize_mem(unsigned long EXT2FS_ATTR((unused)) old_size,
- unsigned long size, void *ptr)
- {
- void *p;
-diff -Nru a/lib/ext2fs/namei.c b/lib/ext2fs/namei.c
---- a/lib/ext2fs/namei.c Wed Feb 25 02:10:02 2004
-+++ b/lib/ext2fs/namei.c Wed Feb 25 02:10:02 2004
-@@ -47,7 +47,7 @@
- if (link_count++ > 5) {
- return EXT2_ET_SYMLINK_LOOP;
- }
-- if (ei.i_blocks) {
-+ if (ext2fs_inode_data_blocks(fs,&ei)) {
- retval = ext2fs_get_mem(fs->blocksize, &buffer);
- if (retval)
- return retval;
-diff -Nru a/misc/fsck.c b/misc/fsck.c
---- a/misc/fsck.c Wed Feb 25 02:10:02 2004
-+++ b/misc/fsck.c Wed Feb 25 02:10:02 2004
-@@ -439,7 +439,7 @@
- for (i=0; i <num_args; i++)
- argv[argc++] = string_copy(args[i]);
-
-- if (progress & !progress_active()) {
-+ if (progress && !progress_active()) {
- if ((strcmp(type, "ext2") == 0) ||
- (strcmp(type, "ext3") == 0)) {
- argv[argc++] = string_copy("-C0");
-diff -Nru a/util/gen-tarball.in b/util/gen-tarball.in
---- a/util/gen-tarball.in Wed Feb 25 02:10:02 2004
-+++ b/util/gen-tarball.in Wed Feb 25 02:10:02 2004
-@@ -79,7 +79,8 @@
- (cd $top_srcdir/.. ; find $base_e2fsprogs \( -name \*~ -o -name \*.orig \
- -o -name CVS -o -name \*.rej -o -name Makefile.pq \
- -o -name TAGS -o -name \*.old -o -name \*.gmo -o -name SCCS \
-- -o -name changed-files -o -name .#\* -o -name \*.tar.gz \) \
-+ -o -name changed-files -o -name .#\* -o -name \*.tar.gz \
-+ -o -name autom4te.cache \) \
- -print) | sed -e "s/^$base_e2fsprogs/$SRCROOT/" > $exclude
- sed -e "s;^;$SRCROOT/;" < $srcdir/$list.exclude >> $exclude
-