aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ecore-config
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
commit9a2e4c8b780fc607dc4b4adabefb354c84401a96 (patch)
treef59767aed29b447d3d80ab987e898598663c27e3 /sysutils/ecore-config
parent621c804e48a9fdddd6a00d78585fa8cb20c8460e (diff)
Notes
Diffstat (limited to 'sysutils/ecore-config')
-rw-r--r--sysutils/ecore-config/Makefile70
-rw-r--r--sysutils/ecore-config/distinfo3
-rw-r--r--sysutils/ecore-config/pkg-descr5
-rw-r--r--sysutils/ecore-config/pkg-plist7
4 files changed, 85 insertions, 0 deletions
diff --git a/sysutils/ecore-config/Makefile b/sysutils/ecore-config/Makefile
new file mode 100644
index 000000000000..b45888a8ffca
--- /dev/null
+++ b/sysutils/ecore-config/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: ecore-config
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= config
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (config module)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+USE_EFL= ecore eet evas
+USE_EFL_ECORE= ipc con
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_config
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS= --enable-ecore-con \
+ --enable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --enable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_ipc/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_ipc/libecore_ipc\.la,-lecore_ipc,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/libecore_con\.la,-lecore_con,'\
+ ${BUILD_WRKSRC}/Makefile.in ${WRKSRC}/src/bin/Makefile.in
+ @${REINPLACE_CMD} -E \
+ -e 's,../lib/ecore_ipc/.libs/libecore_ipc.la,-lecore_ipc,g' \
+ -e 's,../lib/ecore_con/.libs/libecore_con.la,-lecore_con,g' \
+ -e 's,../lib/ecore/.libs/libecore.la,-lecore,g' \
+ ${WRKSRC}/src/bin/Makefile.in
+
+post-build:
+ @(cd ${WRKSRC}/src/bin; ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-config.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+ @(cd ${WRKSRC}/src/bin; ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.include <bsd.port.mk>
diff --git a/sysutils/ecore-config/distinfo b/sysutils/ecore-config/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/sysutils/ecore-config/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/sysutils/ecore-config/pkg-descr b/sysutils/ecore-config/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/sysutils/ecore-config/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/sysutils/ecore-config/pkg-plist b/sysutils/ecore-config/pkg-plist
new file mode 100644
index 000000000000..e8ffe0b62bff
--- /dev/null
+++ b/sysutils/ecore-config/pkg-plist
@@ -0,0 +1,7 @@
+bin/ecore_config
+include/Ecore_Config.h
+lib/libecore_config.a
+lib/libecore_config.la
+lib/libecore_config.so
+lib/libecore_config.so.9
+libdata/pkgconfig/ecore-config.pc