aboutsummaryrefslogtreecommitdiff
path: root/sysutils/env4801/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-04-03 11:54:33 +0000
committerLars Thegler <lth@FreeBSD.org>2005-04-03 11:54:33 +0000
commit4951bf14689281122ee5ccb6d0932b9fa02e676e (patch)
tree2e34d2e19f67904f460ce7bf5e9afc2d52d682fa /sysutils/env4801/Makefile
parent1c2c4d471d5c5abe969ea131de66b8ff25889851 (diff)
Notes
Diffstat (limited to 'sysutils/env4801/Makefile')
-rw-r--r--sysutils/env4801/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/env4801/Makefile b/sysutils/env4801/Makefile
new file mode 100644
index 000000000000..10752ade0179
--- /dev/null
+++ b/sysutils/env4801/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: env4801
+# Date created: Tue, Nov 24th, 2004
+# Whom: Patrick M. Hausen (pmh@hausen.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= env4801
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://phk.freebsd.dk/soekris/env4801/
+DISTFILES= Makefile env4801.c
+DIST_SUBDIR= env4801
+
+MAINTAINER= pmh@hausen.com
+COMMENT= Output the voltages and temperatures of a Soekris Net4801 computer
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+RC_SCRIPTS_SUB= PREFIX=${PREFIX}
+
+PLIST_FILES= sbin/env4801 etc/rc.d/env4801.sh
+
+post-extract:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/env4801.sh > ${WRKSRC}/env4801.sh
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/env4801 ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/env4801.sh ${PREFIX}/etc/rc.d
+
+post-install:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PKGMESSAGE}
+
+.include <bsd.port.mk>