aboutsummaryrefslogtreecommitdiff
path: root/sysutils/env4801
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-04-03 11:54:33 +0000
committerLars Thegler <lth@FreeBSD.org>2005-04-03 11:54:33 +0000
commit4951bf14689281122ee5ccb6d0932b9fa02e676e (patch)
tree2e34d2e19f67904f460ce7bf5e9afc2d52d682fa /sysutils/env4801
parent1c2c4d471d5c5abe969ea131de66b8ff25889851 (diff)
downloadports-4951bf14689281122ee5ccb6d0932b9fa02e676e.tar.gz
ports-4951bf14689281122ee5ccb6d0932b9fa02e676e.zip
Notes
Diffstat (limited to 'sysutils/env4801')
-rw-r--r--sysutils/env4801/Makefile37
-rw-r--r--sysutils/env4801/distinfo4
-rw-r--r--sysutils/env4801/files/env4801.sh10
-rw-r--r--sysutils/env4801/pkg-descr16
-rw-r--r--sysutils/env4801/pkg-message10
5 files changed, 77 insertions, 0 deletions
diff --git a/sysutils/env4801/Makefile b/sysutils/env4801/Makefile
new file mode 100644
index 000000000000..10752ade0179
--- /dev/null
+++ b/sysutils/env4801/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: env4801
+# Date created: Tue, Nov 24th, 2004
+# Whom: Patrick M. Hausen (pmh@hausen.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= env4801
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://phk.freebsd.dk/soekris/env4801/
+DISTFILES= Makefile env4801.c
+DIST_SUBDIR= env4801
+
+MAINTAINER= pmh@hausen.com
+COMMENT= Output the voltages and temperatures of a Soekris Net4801 computer
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+RC_SCRIPTS_SUB= PREFIX=${PREFIX}
+
+PLIST_FILES= sbin/env4801 etc/rc.d/env4801.sh
+
+post-extract:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/env4801.sh > ${WRKSRC}/env4801.sh
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/env4801 ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/env4801.sh ${PREFIX}/etc/rc.d
+
+post-install:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/env4801/distinfo b/sysutils/env4801/distinfo
new file mode 100644
index 000000000000..62972dfab99f
--- /dev/null
+++ b/sysutils/env4801/distinfo
@@ -0,0 +1,4 @@
+MD5 (env4801/Makefile) = 84e12097921baf6e9b3e9f938be6a29c
+SIZE (env4801/Makefile) = 379
+MD5 (env4801/env4801.c) = 4578ff38083aac95e71a127899294c88
+SIZE (env4801/env4801.c) = 1995
diff --git a/sysutils/env4801/files/env4801.sh b/sysutils/env4801/files/env4801.sh
new file mode 100644
index 000000000000..f49b07233f12
--- /dev/null
+++ b/sysutils/env4801/files/env4801.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+
+case "$1" in
+start|restart)
+ %%PREFIX%%/sbin/env4801 -i
+ ;;
+stop)
+ ;;
+esac
diff --git a/sysutils/env4801/pkg-descr b/sysutils/env4801/pkg-descr
new file mode 100644
index 000000000000..1004fc9d7637
--- /dev/null
+++ b/sysutils/env4801/pkg-descr
@@ -0,0 +1,16 @@
+Soekris Net4801 Environmental Monitor
+
+This is a small program to output the voltages and temperatures
+from the PC87366 chip in the Net4801 computer from Soekris.com.
+
+First run the program with a "-i" to initialize the hardware:
+
+ # env4801 -i
+
+Then, as often as you feel like, read out the measured values:
+
+ # env4801
+
+Author: Poul-Henning Kamp (phk@freebsd.org)
+WWW: http://phk.freebsd.dk/soekris/env4801/
+ http://www.soekris.com/
diff --git a/sysutils/env4801/pkg-message b/sysutils/env4801/pkg-message
new file mode 100644
index 000000000000..0df42d546ea4
--- /dev/null
+++ b/sysutils/env4801/pkg-message
@@ -0,0 +1,10 @@
+
+================================================================
+This port installed %%PREFIX%%/etc/rc.d/env4801.sh to initialize
+the hardware at boot time. The env4801 utility will only run on
+a Soekris Engineering Net4801 device. See pkg-descr for more
+information as currently there is no manpage.
+
+Make sure you have /dev/io enabled by putting io_load="YES" in
+/boot/loader.conf or device io in your kernel config file.
+================================================================