aboutsummaryrefslogtreecommitdiff
path: root/sysutils/eventwatcher
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-20 21:38:55 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-20 21:38:55 +0000
commit9516dcc72be16c18f85f2c3eb8e12730ed03b489 (patch)
tree08a4d74f9badc73d80b5ddfb6a5a2e159c6b1e25 /sysutils/eventwatcher
parent2a652e50f3b4bc476fa602416d55c2ce922a4fba (diff)
downloadports-9516dcc72be16c18f85f2c3eb8e12730ed03b489.tar.gz
ports-9516dcc72be16c18f85f2c3eb8e12730ed03b489.zip
Notes
Diffstat (limited to 'sysutils/eventwatcher')
-rw-r--r--sysutils/eventwatcher/Makefile27
-rw-r--r--sysutils/eventwatcher/distinfo2
-rw-r--r--sysutils/eventwatcher/pkg-descr9
-rw-r--r--sysutils/eventwatcher/pkg-plist39
4 files changed, 77 insertions, 0 deletions
diff --git a/sysutils/eventwatcher/Makefile b/sysutils/eventwatcher/Makefile
new file mode 100644
index 000000000000..0ac6ae49cd26
--- /dev/null
+++ b/sysutils/eventwatcher/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: eventwatcher
+# Date created: 20 Aug 2004
+# Whom: Lauri Watts <lauri@kde.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eventwatcher
+PORTVERSION= 0.4.1
+CATEGORIES= sysutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= eventwatcher
+
+MAINTAINER= lauri@kde.org
+COMMENT= KDE log file/event viewer
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_KDELIBS_VER=3
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2 ||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/sysutils/eventwatcher/distinfo b/sysutils/eventwatcher/distinfo
new file mode 100644
index 000000000000..94921ce1fb71
--- /dev/null
+++ b/sysutils/eventwatcher/distinfo
@@ -0,0 +1,2 @@
+MD5 (eventwatcher-0.4.1.tar.bz2) = 10430576d7594fba0094b11490ecb0b7
+SIZE (eventwatcher-0.4.1.tar.bz2) = 516143
diff --git a/sysutils/eventwatcher/pkg-descr b/sysutils/eventwatcher/pkg-descr
new file mode 100644
index 000000000000..415b94e19129
--- /dev/null
+++ b/sysutils/eventwatcher/pkg-descr
@@ -0,0 +1,9 @@
+EventWatcher is a KDE application which notifies you about various events.
+
+"Events" are pieces of information about, for example, news ticker or blog
+updates, new emails, user logons, system warnings, hardware events etc.
+They get collected by EventWatcher plugins and sent to the main application
+which lives in the KDE system tray for most of the time and displays this
+information.
+
+WWW: http://eventwatcher.sourceforge.net/
diff --git a/sysutils/eventwatcher/pkg-plist b/sysutils/eventwatcher/pkg-plist
new file mode 100644
index 000000000000..c8e7854e6446
--- /dev/null
+++ b/sysutils/eventwatcher/pkg-plist
@@ -0,0 +1,39 @@
+bin/eventwatcher
+include/eventwatcher/eventdata.h
+include/eventwatcher/plugin.h
+lib/kde3/eventwatcherdcopplugin.la
+lib/kde3/eventwatcherdcopplugin.so
+lib/kde3/eventwatcherlogplugin.la
+lib/kde3/eventwatcherlogplugin.so
+lib/kde3/eventwatcherlogplugin_config.la
+lib/kde3/eventwatcherlogplugin_config.so
+lib/kde3/eventwatcherrssplugin.la
+lib/kde3/eventwatcherrssplugin.so
+lib/kde3/eventwatcherrssplugin_config.la
+lib/kde3/eventwatcherrssplugin_config.so
+lib/libeventwatcherplugin.la
+lib/libeventwatcherplugin.so
+lib/libeventwatcherplugin.so.0
+share/applnk/Utilities/eventwatcher.desktop
+share/apps/eventwatcher/eventwatcherui.rc
+share/apps/eventwatcher/icons/crystalsvg/16x16/apps/dcopplugin.png
+share/apps/eventwatcher/icons/crystalsvg/16x16/apps/logplugin.png
+share/apps/eventwatcher/icons/crystalsvg/16x16/apps/rssplugin.png
+share/apps/eventwatcher/icons/crystalsvg/22x22/apps/eventwatchergray.png
+share/apps/eventwatcher/icons/crystalsvg/22x22/apps/eventwatcherlight.png
+share/config.kcfg/eventwatcher.kcfg
+share/icons/hicolor/16x16/apps/eventwatcher.png
+share/icons/hicolor/22x22/apps/eventwatcher.png
+share/icons/hicolor/32x32/apps/eventwatcher.png
+share/services/eventwatcherdcop.desktop
+share/services/eventwatcherlog.desktop
+share/services/eventwatcherrss.desktop
+share/servicetypes/eventwatcherplugin.desktop
+@dirrm share/apps/eventwatcher/icons/crystalsvg/22x22/apps
+@dirrm share/apps/eventwatcher/icons/crystalsvg/22x22
+@dirrm share/apps/eventwatcher/icons/crystalsvg/16x16/apps
+@dirrm share/apps/eventwatcher/icons/crystalsvg/16x16
+@dirrm share/apps/eventwatcher/icons/crystalsvg
+@dirrm share/apps/eventwatcher/icons
+@dirrm share/apps/eventwatcher
+@dirrm include/eventwatcher