aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fastest_cvsup
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-22 23:29:45 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-22 23:29:45 +0000
commitb2ab67ff3f937fb712205e77ca8e6f4c8116ff8a (patch)
tree9459e000f758799cd1c23daaed82b4734057cff3 /sysutils/fastest_cvsup
parent157067734b24175ffebf96fa235fe22ac8076b14 (diff)
downloadports-b2ab67ff3f937fb712205e77ca8e6f4c8116ff8a.tar.gz
ports-b2ab67ff3f937fb712205e77ca8e6f4c8116ff8a.zip
Notes
Diffstat (limited to 'sysutils/fastest_cvsup')
-rw-r--r--sysutils/fastest_cvsup/Makefile8
-rw-r--r--sysutils/fastest_cvsup/files/extrapatch-fastest_cvsup27
2 files changed, 34 insertions, 1 deletions
diff --git a/sysutils/fastest_cvsup/Makefile b/sysutils/fastest_cvsup/Makefile
index 2f352a75b466..1f4bfb394eb5 100644
--- a/sysutils/fastest_cvsup/Makefile
+++ b/sysutils/fastest_cvsup/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fastest_cvsup
PORTVERSION= 0.2.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://fastest-cvsup.sourceforge.net/download/
@@ -20,8 +20,14 @@ USE_PERL5= yes
MAN7= fastest_cvsup.7
PLIST_FILES= bin/fastest_cvsup
+OPTIONS= ROUNDTRIP "Build with round-trip patch" off
+
.include <bsd.port.pre.mk>
+.if defined(WITH_ROUNDTRIP)
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-fastest_cvsup
+.endif
+
.if ${PERL_LEVEL} < 500805
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
.endif
diff --git a/sysutils/fastest_cvsup/files/extrapatch-fastest_cvsup b/sysutils/fastest_cvsup/files/extrapatch-fastest_cvsup
new file mode 100644
index 000000000000..7750773f9c39
--- /dev/null
+++ b/sysutils/fastest_cvsup/files/extrapatch-fastest_cvsup
@@ -0,0 +1,27 @@
+--- fastest_cvsup 2006/01/13 13:24:38 1.1
++++ fastest_cvsup 2006/01/13 13:43:08
+@@ -526,9 +526,9 @@
+
+ if ( $VERBOSE ) { # print pretty display
+
+- my $ms = sprintf("%.2f", 1000 * $time_taken); # time in ms
++ $time{$server} = 1000 * $time_taken ; # time in ms
+ print $SERVER_RESULT, "server replied: $reply\n";
+- print $SERVER_RESULT, "time taken: $ms ms\n";
++ print $SERVER_RESULT, "time taken: " . sprintf("%.2f",$time{$server}) . " ms\n";
+
+ }
+ }
+@@ -547,9 +547,9 @@
+
+ if ( $VERBOSE ) {
+ print "\n", $GENERAL_INFO, "Speed Daemons:\n" if $fastest[0]; # just checking ;)
+- print $SERVER_RESULT, "1st: $fastest[0]\n" if $fastest[0];
+- print $SERVER_RESULT, "2nd: $fastest[1]\n" if $fastest[1];
+- print $SERVER_RESULT, "3rd: $fastest[2]\n" if $fastest[2];
++ printf("%s1st: %-24s %.2f ms\n", $SERVER_RESULT, $fastest[0], $time{$fastest[0]}) if $fastest[0];
++ printf("%s2st: %-24s %.2f ms\n", $SERVER_RESULT, $fastest[1], $time{$fastest[1]}) if $fastest[1];
++ printf("%s3st: %-24s %.2f ms\n", $SERVER_RESULT, $fastest[2], $time{$fastest[2]}) if $fastest[2];
+ }
+ else { # otherwise just output the fastest.
+ print $fastest[0];