aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fatback/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-07-01 11:12:09 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-07-01 11:12:09 +0000
commitc8af5566cff076eecd1d074f19e0233fe78271ca (patch)
tree64818d4ea4360527b3b23dd6dc65f3c1201c5799 /sysutils/fatback/Makefile
parentb8010beedc64ca62b205458e6873c6b9770efb2b (diff)
downloadports-c8af5566cff076eecd1d074f19e0233fe78271ca.tar.gz
ports-c8af5566cff076eecd1d074f19e0233fe78271ca.zip
Notes
Diffstat (limited to 'sysutils/fatback/Makefile')
-rw-r--r--sysutils/fatback/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/fatback/Makefile b/sysutils/fatback/Makefile
new file mode 100644
index 000000000000..cb2c60bedeff
--- /dev/null
+++ b/sysutils/fatback/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fatback
+# Date created: 18 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fatback
+DISTVERSION= 1.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Recover deleted files from FAT filesystems
+
+GNU_CONFIGURE= yes
+
+MAN1= fatback.1
+INFO= fatback-manual
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/fatback-manual.info ${PREFIX}/${INFO_PATH}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in fatback-manual.texi texinfo.tex ChangeLog AUTHORS
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>