aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fcron/files
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-04 17:54:23 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-04 17:54:23 +0000
commite6ee415d32a0ca52a3522a462e9bd7a7749251db (patch)
tree04f59169b99031512094406cd1b3bad700e950ab /sysutils/fcron/files
parent07fc24d77c4a82a82ec602d2e2c148356eb26984 (diff)
Notes
Diffstat (limited to 'sysutils/fcron/files')
-rw-r--r--sysutils/fcron/files/fcron.in19
-rw-r--r--sysutils/fcron/files/fcrontab-operator9
-rw-r--r--sysutils/fcron/files/fcrontab-root20
-rw-r--r--sysutils/fcron/files/patch-Makefile.in29
-rw-r--r--sysutils/fcron/files/patch-conf.c9
-rw-r--r--sysutils/fcron/files/patch-configure20
-rw-r--r--sysutils/fcron/files/patch-configure.in22
-rw-r--r--sysutils/fcron/files/patch-script::boot-install11
-rw-r--r--sysutils/fcron/files/pkg-message.in14
9 files changed, 82 insertions, 71 deletions
diff --git a/sysutils/fcron/files/fcron.in b/sysutils/fcron/files/fcron.in
new file mode 100644
index 000000000000..4f5dcc660492
--- /dev/null
+++ b/sysutils/fcron/files/fcron.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: fcron
+# REQUIRE: LOGIN
+# BEFORE: securelevel
+# KEYWORD: shutdown
+
+. %%RC_SUBR%%
+
+name="fcron"
+rcvar="`set_rcvar`"
+command="%%PREFIX%%/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/sysutils/fcron/files/fcrontab-operator b/sysutils/fcron/files/fcrontab-operator
new file mode 100644
index 000000000000..2eb01377e355
--- /dev/null
+++ b/sysutils/fcron/files/fcrontab-operator
@@ -0,0 +1,9 @@
+# Derived from the default /etc/crontab for FreeBSD
+# See fcrontab(5) for syntax and semantics
+#
+SHELL=/bin/sh
+PATH=/etc:/bin:/sbin:/usr/bin:/usr/sbin
+HOME=/var/log
+#
+# Save some entropy so that /dev/random can re-seed on boot.
+@ 11 /usr/libexec/save-entropy
diff --git a/sysutils/fcron/files/fcrontab-root b/sysutils/fcron/files/fcrontab-root
new file mode 100644
index 000000000000..e5d366664a56
--- /dev/null
+++ b/sysutils/fcron/files/fcrontab-root
@@ -0,0 +1,20 @@
+# Derived from the default /etc/crontab for FreeBSD
+# See fcrontab(5) for syntax and semantics
+#
+SHELL=/bin/sh
+PATH=/etc:/bin:/sbin:/usr/bin:/usr/sbin
+HOME=/var/log
+#
+@serial,lavg5(1.5) 5 /usr/libexec/atrun
+#
+# Rotate log files every hour, if necessary.
+%hourly * newsyslog
+#
+# Perform daily/weekly/monthly maintenance.
+%daily,serial * * periodic daily
+%weekly,serial * * periodic weekly
+%monthly,serial * * * periodic monthly
+#
+# Adjust the time zone if the CMOS clock keeps local time, as opposed to
+# UTC time. See adjkerntz(8) for details.
+1,31 0-5 * * * root adjkerntz -a
diff --git a/sysutils/fcron/files/patch-Makefile.in b/sysutils/fcron/files/patch-Makefile.in
deleted file mode 100644
index 0c31473ce67a..000000000000
--- a/sysutils/fcron/files/patch-Makefile.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.in.org Wed Jan 23 21:49:55 2002
-+++ Makefile.in Wed Jan 23 21:50:52 2002
-@@ -102,23 +102,20 @@
- if test ! -d $(DESTMAN)/man3; then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTMAN)/man3 ; fi
- if test ! -d $(DESTMAN)/man5; then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTMAN)/man5 ; fi
- if test ! -d $(DESTMAN)/man8; then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTMAN)/man8 ; fi
-- if test ! -d $(DESTDOC)/fcron-$(VERSION); then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTDOC)/fcron-$(VERSION) ; fi
- # create the spool dir (and change its mode if it already exists)
- $(INSTALL) -g $(GROUPNAME) -o $(USERNAME) -m 770 -d $(FCRONTABS)
-
- $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 110 -s fcron $(DESTSBIN)
- $(INSTALL) -g $(GROUPNAME) -o $(USERNAME) -m 6111 -s fcrontab $(DESTBIN)
- $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 6111 -s fcronsighup $(DESTBIN)
-- test -f $(ETC)/fcron.allow || test -f $(ETC)/fcron.deny || $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.allow $(SRCDIR)/files/fcron.deny $(ETC)
-- test -f $(ETC)/fcron.conf || $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.conf $(ETC)
-- test "${USEPAM}" = "0" || $(SRCDIR)/script/install-pam-conf $(SRCDIR) $(ETC) $(ROOTNAME) $(ROOTGROUP) "$(INSTALL)"
-+ $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.allow $(ETC)/fcron.allow.dist
-+ $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.deny $(ETC)/fcron.deny.dist
-+ $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.conf $(ETC)/fcron.conf.dist
- $(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcron.8 $(DESTMAN)/man8
- $(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcrontab.1 $(DESTMAN)/man1
- $(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcrontab.5 $(DESTMAN)/man5
- $(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcron.conf.5 $(DESTMAN)/man5
- $(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/bitstring.3 $(DESTMAN)/man3
-- $(INSTALL) -m 644 -o $(ROOTNAME) doc/README doc/LICENSE doc/CHANGES doc/*.html \
-- $(DESTDOC)/fcron-$(VERSION)/
-
- # in order to get correct rights when upgrading :
- find $(FCRONTABS) -type f \( -name "*.orig" -a ! -name "root.orig" \) -exec chown $(USERNAME):$(GROUPNAME) {} \; -exec chmod 640 {} \;
diff --git a/sysutils/fcron/files/patch-conf.c b/sysutils/fcron/files/patch-conf.c
deleted file mode 100644
index 081565cff8d3..000000000000
--- a/sysutils/fcron/files/patch-conf.c
+++ /dev/null
@@ -1,9 +0,0 @@
---- conf.c.orig Tue Dec 7 11:44:09 2004
-+++ conf.c Tue Dec 7 11:44:32 2004
-@@ -1086,5 +1086,6 @@
- break ;
-
- next_file:
-+ ;
- }
- }
diff --git a/sysutils/fcron/files/patch-configure b/sysutils/fcron/files/patch-configure
new file mode 100644
index 000000000000..aeb8d51e9702
--- /dev/null
+++ b/sysutils/fcron/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Tue Oct 4 18:39:16 2005
++++ configure Tue Oct 4 18:42:04 2005
+@@ -11767,17 +11767,9 @@
+ fi
+ ;;
+ *)
+- if test -d "$withval"; then
+ etcdir="$withval"
+ echo "$as_me:$LINENO: result: $withval" >&5
+ echo "${ECHO_T}$withval" >&6
+- else
+- { { echo "$as_me:$LINENO: error:
+-Directory $withval does not exist" >&5
+-echo "$as_me: error:
+-Directory $withval does not exist" >&2;}
+- { (exit 1); exit 1; }; }
+- fi
+ ;;
+ esac
+ else
diff --git a/sysutils/fcron/files/patch-configure.in b/sysutils/fcron/files/patch-configure.in
deleted file mode 100644
index aa6c0362f6e1..000000000000
--- a/sysutils/fcron/files/patch-configure.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- configure.in.orig Sun Jul 8 07:32:17 2001
-+++ configure.in Sat Aug 25 14:36:05 2001
-@@ -201,13 +201,13 @@
- fi
- ;;
- *)
-- if test -d "$withval"; then
-+# if test -d "$withval"; then
- etcdir="$withval"
-- AC_MSG_RESULT($withval)
-- else
-- AC_MSG_ERROR([
--Directory $withval does not exist])
-- fi
-+# AC_MSG_RESULT($withval)
-+# else
-+# AC_MSG_ERROR([
-+#Directory $withval does not exist])
-+# fi
- ;;
- esac ],
- if test -d "/etc"; then
diff --git a/sysutils/fcron/files/patch-script::boot-install b/sysutils/fcron/files/patch-script::boot-install
deleted file mode 100644
index 5cd5ceab6f6e..000000000000
--- a/sysutils/fcron/files/patch-script::boot-install
+++ /dev/null
@@ -1,11 +0,0 @@
---- script/boot-install.orig Fri Jul 20 14:44:40 2001
-+++ script/boot-install Fri Jul 20 14:44:48 2001
-@@ -11,7 +11,7 @@
- # the automatic answer
- # the src dir
-
--PATH="/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin"
-+PATH="/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/sbin"
- if test -d /usr/ucb; then
- PATH=/usr/ucb:$PATH
- fi
diff --git a/sysutils/fcron/files/pkg-message.in b/sysutils/fcron/files/pkg-message.in
new file mode 100644
index 000000000000..04257be00f2b
--- /dev/null
+++ b/sysutils/fcron/files/pkg-message.in
@@ -0,0 +1,14 @@
+===============================================================================
+To enable fcron, and disable the default system cron, add the following lines
+to your /etc/rc.conf:
+
+ fcron_enable="YES"
+ cron_enable="NO"
+
+and move any jobs in /etc/crontab to the root fcrontab(5) file. See:
+
+%%EXAMPLESDIR%%
+
+for a translation of the default FreeBSD /etc/crontab, and for sample PAM
+configuration files.
+===============================================================================