aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fcron
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-09 10:28:29 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-09 10:28:29 +0000
commit38a5712506f199745d0a2d40eec23dcd29d93feb (patch)
tree0a82bc6acfcbdf3186d9f7d6163f3043ae90c7c6 /sysutils/fcron
parent23998c8fc7bcdec503176858e245804d96eaa2ac (diff)
downloadports-38a5712506f199745d0a2d40eec23dcd29d93feb.tar.gz
ports-38a5712506f199745d0a2d40eec23dcd29d93feb.zip
Notes
Diffstat (limited to 'sysutils/fcron')
-rw-r--r--sysutils/fcron/Makefile19
-rw-r--r--sysutils/fcron/distinfo6
-rw-r--r--sysutils/fcron/files/pkg-message.in6
-rw-r--r--sysutils/fcron/pkg-install6
-rw-r--r--sysutils/fcron/pkg-plist1
5 files changed, 27 insertions, 11 deletions
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index 5a9dd6aee8ae..d96cff2a39de 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= fcron
-PORTVERSION= 3.0.0
-PORTREVISION= 2
+PORTVERSION= 3.0.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://fcron.free.fr/
+ http://fcron.free.fr/archives/ \
+ ftp://ftp.seul.org/pub/fcron/
MASTER_SITE_SUBDIR= system/daemons/cron
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
--with-rootname=root --with-rootgroup=wheel \
- --with-docdir=${DOCSDIR} --with-fcrondyn=no
+ --with-docdir=${DOCSDIR}
WRKSRC= ${WRKDIR}/fcron-${PORTVERSION}
@@ -36,12 +36,19 @@ MAN8= fcron.8
PORTDOCS= *
+.if defined(MANLANG) && exists(${WRKSRC}/doc/${MANLANG})
+DOCSRC= ${WRKSRC}/doc/${MANLANG}
+.else
+DOCSRC= ${WRKSRC}/doc/en
+.endif
+
pre-su-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fcron ${PREFIX}/sbin
${INSTALL_PROGRAM} -g fcron -o fcron -m 6111 ${WRKSRC}/fcrontab ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -g fcron -o fcron -m 6111 ${WRKSRC}/fcrondyn ${PREFIX}/bin
${INSTALL_PROGRAM} -g fcron -m 4110 ${WRKSRC}/fcronsighup ${PREFIX}/bin
.for f in fcron.allow fcron.conf fcron.deny
${INSTALL_DATA} -g fcron -m 640 ${WRKSRC}/files/${f} ${PREFIX}/etc/${f}.dist
@@ -49,12 +56,12 @@ do-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/fcrontab-* ${WRKSRC}/files/*.pam ${EXAMPLESDIR}
.for n in 1 5 8
- ${INSTALL_MAN} ${MAN${n}:S|^|${WRKSRC}/doc/man/|} ${PREFIX}/man/man${n}
+ ${INSTALL_MAN} ${MAN${n}:S|^|${DOCSRC}/man/|} ${PREFIX}/man/man${n}
.endfor
.if !defined(NOPORTDOCS)
. for d in txt HTML
${MKDIR} ${DOCSDIR}/${d}
- ${INSTALL_DATA} ${WRKSRC}/doc/${d}/* ${DOCSDIR}/${d}
+ ${INSTALL_DATA} ${DOCSRC}/${d}/* ${DOCSDIR}/${d}
. endfor
.endif
diff --git a/sysutils/fcron/distinfo b/sysutils/fcron/distinfo
index b79daca67320..0a55a004cc5d 100644
--- a/sysutils/fcron/distinfo
+++ b/sysutils/fcron/distinfo
@@ -1,3 +1,3 @@
-MD5 (fcron-3.0.0.src.tar.gz) = 55e92f8536c8b52c9b73b96a6a3e0fe3
-SHA256 (fcron-3.0.0.src.tar.gz) = 861e0ea68525f960e512aaebbc09d5848a9862982038a14a3e65c9e74ff2650e
-SIZE (fcron-3.0.0.src.tar.gz) = 409015
+MD5 (fcron-3.0.1.src.tar.gz) = 8e5dcb3a646c11294294895954ef0a48
+SHA256 (fcron-3.0.1.src.tar.gz) = 31288b04619bb9c7cd5fe6ff004c1e2c1340685cec2d0fa8725259c491699de9
+SIZE (fcron-3.0.1.src.tar.gz) = 536972
diff --git a/sysutils/fcron/files/pkg-message.in b/sysutils/fcron/files/pkg-message.in
index 04257be00f2b..f3409e1be538 100644
--- a/sysutils/fcron/files/pkg-message.in
+++ b/sysutils/fcron/files/pkg-message.in
@@ -5,6 +5,12 @@ to your /etc/rc.conf:
fcron_enable="YES"
cron_enable="NO"
+install the pam config files
+
+ mkdir -p %%PREFIX%%/etc/pam.d
+ cp %%EXAMPLESDIR%%/fcron.pam %%PREFIX%%/etc/pam.d/fcron
+ cp %%EXAMPLESDIR%%/fcrontab.pam %%PREFIX%%/etc/pam.d/fcrontab
+
and move any jobs in /etc/crontab to the root fcrontab(5) file. See:
%%EXAMPLESDIR%%
diff --git a/sysutils/fcron/pkg-install b/sysutils/fcron/pkg-install
index 15508f19d7b5..f7a366c4e644 100644
--- a/sysutils/fcron/pkg-install
+++ b/sysutils/fcron/pkg-install
@@ -3,11 +3,13 @@
if [ "$2" = PRE-INSTALL ]; then
user=fcron
group=fcron
+ uid=247
+ gid=247
if /usr/sbin/pw groupshow $group 2>/dev/null; then
echo "Using already existing group \"$group\"."
else
- if /usr/sbin/pw groupadd $group; then
+ if /usr/sbin/pw groupadd $group -g $gid; then
echo "Added group \"$group\"."
else
echo "Unable to add group \"$group\"."
@@ -19,7 +21,7 @@ if [ "$2" = PRE-INSTALL ]; then
if /usr/sbin/pw usershow $user 2>/dev/null; then
echo "Using already existing user \"$user\"."
else
- if /usr/sbin/pw useradd $user -g $group -c "fcron pseudo-user"; then
+ if /usr/sbin/pw useradd $user -u $uid -g $group -c "fcron pseudo-user"; then
echo "Added user \"$user\"."
else
echo "Unable to add user \"$user\"."
diff --git a/sysutils/fcron/pkg-plist b/sysutils/fcron/pkg-plist
index 63fde4f87b16..2fccda00cef4 100644
--- a/sysutils/fcron/pkg-plist
+++ b/sysutils/fcron/pkg-plist
@@ -1,5 +1,6 @@
bin/fcronsighup
bin/fcrontab
+bin/fcrondyn
etc/fcron.allow.dist
etc/fcron.conf.dist
etc/fcron.deny.dist