aboutsummaryrefslogtreecommitdiff
path: root/sysutils/filelight
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-11 18:52:42 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-11 18:52:42 +0000
commitac9fe28a8da96a94f87438097ad464a377871260 (patch)
tree6ecd4ccab5b9170e6270e39a5cc81656a4f81978 /sysutils/filelight
parent67d7bd9787b2a3142fd2ea7a5312f612f4431a7b (diff)
downloadports-ac9fe28a8da96a94f87438097ad464a377871260.tar.gz
ports-ac9fe28a8da96a94f87438097ad464a377871260.zip
Notes
Diffstat (limited to 'sysutils/filelight')
-rw-r--r--sysutils/filelight/Makefile8
-rw-r--r--sysutils/filelight/distinfo6
-rw-r--r--sysutils/filelight/files/mntent.h67
-rw-r--r--sysutils/filelight/files/mntent_compat.cpp156
-rw-r--r--sysutils/filelight/files/patch-canvas.h11
-rw-r--r--sysutils/filelight/files/patch-filemap.h11
-rw-r--r--sysutils/filelight/files/patch-scanmanager.cpp23
-rw-r--r--sysutils/filelight/files/patch-scanmanager.h11
-rw-r--r--sysutils/filelight/pkg-plist38
9 files changed, 18 insertions, 313 deletions
diff --git a/sysutils/filelight/Makefile b/sysutils/filelight/Makefile
index f7638ac666fe..e397e628781c 100644
--- a/sysutils/filelight/Makefile
+++ b/sysutils/filelight/Makefile
@@ -6,24 +6,22 @@
#
PORTNAME= filelight
-PORTVERSION= 0.6.4
-PORTREVISION= 5
+PORTVERSION= 1.0
CATEGORIES= sysutils kde
MASTER_SITES= http://www.methylblue.com/filelight/packages/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= decept0@gmail.com
COMMENT= Represent a file system as a set of concentric segmented-rings
USE_KDELIBS_VER=3
USE_AUTOTOOLS= libtool:15
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
INSTALLS_ICONS= yes
post-patch:
- @${CP} ${FILESDIR}/mntent* ${WRKSRC}/src
@${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
- @${RM} ${WRKSRC}/src/settingsdialog.h ${WRKSRC}/src/settingsdialog.cpp
.include <bsd.port.mk>
diff --git a/sysutils/filelight/distinfo b/sysutils/filelight/distinfo
index d62c7b266a65..740178c6d05a 100644
--- a/sysutils/filelight/distinfo
+++ b/sysutils/filelight/distinfo
@@ -1,3 +1,3 @@
-MD5 (filelight-0.6.4.tar.gz) = a45ded39158a3de9762aae1a8333f768
-SHA256 (filelight-0.6.4.tar.gz) = 82a0f0f3e3fffdea3dc0713c30763f4e7b2cad20379babd76ae1b3adfbb5249c
-SIZE (filelight-0.6.4.tar.gz) = 694495
+MD5 (filelight-1.0.tar.bz2) = aa885e53e09f40e7fdd371395140b957
+SHA256 (filelight-1.0.tar.bz2) = 0743d49e60a1b2fa7b54ecdc13fb15c7a6fb144169ba272bc566a18022c245d6
+SIZE (filelight-1.0.tar.bz2) = 530449
diff --git a/sysutils/filelight/files/mntent.h b/sysutils/filelight/files/mntent.h
deleted file mode 100644
index 24a574c8a579..000000000000
--- a/sysutils/filelight/files/mntent.h
+++ /dev/null
@@ -1,67 +0,0 @@
-/* -*-C++-*-
-
- mntent.h
-
- Copyright (C) 2002 Alan Eldridge
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2, or (at your option)
- any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software Foundation,
- Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
- $Id$
-
- 2002/09/08 alane@geeksrus.net
-*/
-
-#ifdef HAVE_MNTENT_H
-#include <mntent.h>
-#else
-
-#ifndef mntent_h_
-#define mntent_h_
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-#include <sys/param.h>
-#include <sys/ucred.h>
-#include <sys/mount.h>
-
-#define MOUNTED "dummy"
-#define MNTTYPE_NFS "nfs"
-
-const int MOPTSLEN (256 - (MNAMELEN * 2 + MFSNAMELEN + 2 * sizeof(int)));
-
-struct mntent {
-public:
- char mnt_fsname[ MNAMELEN ];
- char mnt_dir[ MNAMELEN ];
- char mnt_type[ MFSNAMELEN ];
- char mnt_opts[ MOPTSLEN ];
- int mnt_freq, mnt_passno;
-private:
- void clear();
-public:
- mntent() {
- clear();
- }
- struct mntent *from_statfs(struct statfs *pst);
-};
-
-FILE *setmntent(const char *szfn, char *szrw);
-struct mntent *getmntent(FILE *pf);
-char *hasmntopt(const struct mntent *pmnt, const char *szopt);
-int endmntent(FILE *pf);
-
-#endif /* mntent_h_ */
-#endif /* not HAVE_MNTENT_H */
diff --git a/sysutils/filelight/files/mntent_compat.cpp b/sysutils/filelight/files/mntent_compat.cpp
deleted file mode 100644
index 0675cd2ccf7f..000000000000
--- a/sysutils/filelight/files/mntent_compat.cpp
+++ /dev/null
@@ -1,156 +0,0 @@
-/* -*-C++-*-
-
- mntentemu.c++
-
- Copyright (C) 2002 Alan Eldridge
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2, or (at your option)
- any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software Foundation,
- Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
- $Id: mntent_compat.cc,v 1.3 2002/09/08 18:42:20 alane Exp $
-
- 2002/09/08 alane@geeksrus.net
-*/
-
-#ifndef HAVE_MNTENT_H
-
-#include "config.h"
-#include "mntent.h"
-
-#include <string>
-
-// globals (yuck, but easier for debugging)
-
-mntent G_mntent;
-int G_mntpos;
-int G_mntsize;
-bool G_mntfOpen = false;
-struct statfs *G_pmntstat = 0;
-
-// map option flags to names
-
-struct optmap {
- int fl;
- std::string st;
-};
-
-static struct optmap omap[] = {
- { MNT_SYNCHRONOUS, "sync" },
- { MNT_NOEXEC, "noexec" },
- { MNT_NOSUID, "nosuid" },
-#ifdef MNT_NODEV
- { MNT_NODEV, "nodev" },
-#endif
- { MNT_UNION, "union" },
- { MNT_ASYNC, "async" },
- { MNT_NOATIME, "noatime" },
- { MNT_NOCLUSTERR, "noclusterr" },
- { MNT_NOCLUSTERW, "noclusterw" },
- { MNT_NOSYMFOLLOW, "nosymfollow" },
- { MNT_SUIDDIR, "suiddir" },
- { 0, "noop" }
-};
-
-// zap everything for clarity
-
-void
-mntent::clear()
-{
- memset(mnt_fsname, 0, sizeof(mnt_fsname));
- memset(mnt_dir, 0, sizeof(mnt_dir));
- memset(mnt_type, 0, sizeof(mnt_type));
- memset(mnt_opts, 0, sizeof(mnt_opts));
- mnt_freq = mnt_passno = 0;
-}
-
-// fake it from a statfs struct
-
-mntent *
-mntent::from_statfs(struct statfs *pst)
-{
-
- clear();
- strcpy(mnt_fsname, pst->f_mntfromname);
- strcpy(mnt_dir, pst->f_mntonname);
- strcpy(mnt_type, pst->f_fstypename);
- mnt_freq = mnt_passno = 0;
-
- std::string opts;
- int fl = pst->f_flags;
-
- opts += (fl & MNT_RDONLY) ? "ro" : "rw";
- for (optmap *pmp = omap; pmp->fl != 0; pmp++) {
- if ((fl & pmp->fl) != 0) {
- opts += (" " + pmp->st);
- }
- }
- strcpy(mnt_opts, opts.c_str());
-
- return this;
-}
-
-// "rewind" the mtab file
-
-FILE *
-setmntent(const char *, char *)
-{
- if (!G_mntfOpen) {
- G_mntfOpen = true;
- }
-
- G_mntpos = 0;
- G_mntsize = getmntinfo(&G_pmntstat, MNT_NOWAIT);
-
- return reinterpret_cast<FILE *>(1);
-}
-
-// return ptr to opt string if present
-
-char *
-hasmntopt(const mntent *pmnt, const char *szopt)
-{
- std::string opt(szopt);
- std::string mntopts(pmnt->mnt_opts);
-
- std::string::size_type pos = mntopts.find(opt);
- const char *szret = (pos == std::string::npos) ? "" : pmnt->mnt_opts + pos;
-
- return const_cast<char *>(szret);
-}
-
-// get next mntent until all gone, then return 0
-
-struct mntent *
-getmntent(FILE *)
-{
- if (!G_mntfOpen) {
- return 0;
- } else if (G_mntpos < G_mntsize) {
- return G_mntent.from_statfs(G_pmntstat + G_mntpos++);
- } else {
- G_mntfOpen = false;
- return 0;
- }
-}
-
-// "close" the mtab file
-
-int
-endmntent(FILE *)
-{
- G_mntfOpen = false;
- return 0;
-}
-
-#endif /* ifndef HAVE_MNTENT_H */
diff --git a/sysutils/filelight/files/patch-canvas.h b/sysutils/filelight/files/patch-canvas.h
deleted file mode 100644
index 982b1a55d76c..000000000000
--- a/sysutils/filelight/files/patch-canvas.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/canvas.h.orig Sat Aug 14 00:36:14 2004
-+++ src/canvas.h Sat Aug 14 00:36:19 2004
-@@ -97,6 +97,8 @@
- KAction *m_actKonsole;
- KAction *m_actCenter;
- KAction *m_actRun;
-+
-+ friend class FileMap;
- };
-
- #endif
diff --git a/sysutils/filelight/files/patch-filemap.h b/sysutils/filelight/files/patch-filemap.h
deleted file mode 100644
index a1281568285f..000000000000
--- a/sysutils/filelight/files/patch-filemap.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/filemap.h.orig Sat Aug 14 00:36:51 2004
-+++ src/filemap.h Sat Aug 14 00:37:29 2004
-@@ -68,6 +68,8 @@
- double deltaRed, deltaGreen, deltaBlue;
-
- unsigned int MAP_2MARGIN;
-+
-+ friend class Segment;
- };
-
-
diff --git a/sysutils/filelight/files/patch-scanmanager.cpp b/sysutils/filelight/files/patch-scanmanager.cpp
deleted file mode 100644
index addb7716d0af..000000000000
--- a/sysutils/filelight/files/patch-scanmanager.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/scanmanager.cpp.orig Wed Jan 14 01:58:11 2004
-+++ src/scanmanager.cpp Wed Jan 14 02:03:36 2004
-@@ -29,7 +29,11 @@
- //readMounts()
- #include <fstab.h>
- #include <mntent.h>
-+#ifdef __FreeBSD__
-+#include "mntent_compat.cpp"
-+#else
- #include <sys/statfs.h>
-+#endif
-
- #include "scanmanager.h"
- #include "filetree.h"
-@@ -359,7 +363,7 @@
-
-
-
--static int selector( struct DIRENT const *ent )
-+static int selector( struct DIRENT *ent )
- {
- if( strcmp( ent->d_name, "." ) == 0 || strcmp( ent->d_name, ".." ) == 0 )
- return 0;
diff --git a/sysutils/filelight/files/patch-scanmanager.h b/sysutils/filelight/files/patch-scanmanager.h
deleted file mode 100644
index e27807831938..000000000000
--- a/sysutils/filelight/files/patch-scanmanager.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/scanmanager.h.orig Fri Aug 13 23:50:09 2004
-+++ src/scanmanager.h Sat Aug 14 00:32:26 2004
-@@ -65,6 +65,8 @@
- static bool readMounts();
- private:
- static QStringList localMounts, remoteMounts;
-+
-+ friend class ScanThread;
- };
-
-
diff --git a/sysutils/filelight/pkg-plist b/sysutils/filelight/pkg-plist
index b82cd40bb6ed..a4e6cc4c94ae 100644
--- a/sysutils/filelight/pkg-plist
+++ b/sysutils/filelight/pkg-plist
@@ -1,30 +1,16 @@
bin/filelight
-share/applnk/Utilities/filelight.desktop
+lib/kde3/libfilelight.a
+lib/kde3/libfilelight.la
+lib/kde3/libfilelight.so
+share/applications/kde/filelight.desktop
+share/apps/filelight/filelight_partui.rc
share/apps/filelight/filelightui.rc
share/config/filelightrc
-share/doc/HTML/en/filelight/common
-share/doc/HTML/en/filelight/index.cache.bz2
-share/doc/HTML/en/filelight/index.docbook
-share/icons/crystalsvg/22x22/apps/filelight.png
-share/icons/crystalsvg/48x48/apps/filelight.png
-share/icons/crystalsvg/64x64/apps/filelight.png
-share/locale/cy/LC_MESSAGES/filelight.mo
-share/locale/de/LC_MESSAGES/filelight.mo
-share/locale/nl/LC_MESSAGES/filelight.mo
-share/locale/ru/LC_MESSAGES/filelight.mo
-@dirrmtry share/icons/crystalsvg/64x64/apps
-@dirrmtry share/icons/crystalsvg/64x64
-@dirrmtry share/icons/crystalsvg/48x48/apps
-@dirrmtry share/icons/crystalsvg/48x48
-@dirrmtry share/icons/crystalsvg/22x22/apps
-@dirrmtry share/icons/crystalsvg/22x22
-@dirrmtry share/icons/crystalsvg
-@dirrmtry share/icons
-@dirrm share/doc/HTML/en/filelight
-@dirrmtry share/doc/HTML/en
-@dirrmtry share/doc/HTML
-@dirrmtry share/config
+share/icons/crystalsvg/32x32/actions/view_filelight.png
+share/icons/hicolor/16x16/apps/filelight.png
+share/icons/hicolor/22x22/apps/filelight.png
+share/icons/hicolor/32x32/apps/filelight.png
+share/icons/hicolor/48x48/apps/filelight.png
+share/icons/hicolor/64x64/apps/filelight.png
+share/services/filelight_part.desktop
@dirrm share/apps/filelight
-@dirrmtry share/apps
-@dirrmtry share/applnk/Utilities
-@dirrmtry share/applnk