aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fio
diff options
context:
space:
mode:
authorLuigi Rizzo <luigi@FreeBSD.org>2009-02-14 19:32:30 +0000
committerLuigi Rizzo <luigi@FreeBSD.org>2009-02-14 19:32:30 +0000
commitddd028e250e5b4d430a3695d52916be216067cba (patch)
treec7abf6715ea02e5d12042270f6d9a017b03a51a3 /sysutils/fio
parentb003deb680aa57c6bdb97cdcd6d223a92166afe7 (diff)
downloadports-ddd028e250e5b4d430a3695d52916be216067cba.tar.gz
ports-ddd028e250e5b4d430a3695d52916be216067cba.zip
Notes
Diffstat (limited to 'sysutils/fio')
-rw-r--r--sysutils/fio/Makefile33
-rw-r--r--sysutils/fio/distinfo3
-rw-r--r--sysutils/fio/files/patch-018
-rw-r--r--sysutils/fio/pkg-descr6
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/fio/Makefile b/sysutils/fio/Makefile
new file mode 100644
index 000000000000..f7524c1f0d07
--- /dev/null
+++ b/sysutils/fio/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: fio
+# Date created: Jan.15, 2009
+# Whom: luigi@FreeBSD.org
+#
+# Maintainers: Luigi Rizzo <luigi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fio
+PORTVERSION= 1.24
+CATEGORIES= sysutils
+MASTER_SITES= http://brick.kernel.dk/snaps/
+
+MAINTAINER= luigi@FreeBSD.org
+COMMENT= The program fio - flexible IO tester
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+SCRIPTS_ENV= "SHELL=bash"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+MAKEFILE= Makefile.FreeBSD
+
+MAN1= fio.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fio ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/fio_generate_plots ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/fio.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/sysutils/fio/distinfo b/sysutils/fio/distinfo
new file mode 100644
index 000000000000..869917237215
--- /dev/null
+++ b/sysutils/fio/distinfo
@@ -0,0 +1,3 @@
+MD5 (fio-1.24.tar.gz) = bcaf7367e04a5777ff350f02e256d394
+SHA256 (fio-1.24.tar.gz) = 6e67f90ff8af03a2eab782cae57d93f4c5c0d3f3eabc7855298aa9b3643b545e
+SIZE (fio-1.24.tar.gz) = 1446301
diff --git a/sysutils/fio/files/patch-01 b/sysutils/fio/files/patch-01
new file mode 100644
index 000000000000..2c77fe4daa2c
--- /dev/null
+++ b/sysutils/fio/files/patch-01
@@ -0,0 +1,8 @@
+--- fio_generate_plots.orig 2009-02-06 14:13:52.000000000 +0100
++++ fio_generate_plots 2009-02-14 20:00:49.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/local/bin/bash
+
+ # Use gnuplot to generate plots from fio run with -l and/or -w
+
diff --git a/sysutils/fio/pkg-descr b/sysutils/fio/pkg-descr
new file mode 100644
index 000000000000..198a2a9856f5
--- /dev/null
+++ b/sysutils/fio/pkg-descr
@@ -0,0 +1,6 @@
+Fio is an I/O testing tool that will spawn a number of threads or
+processes doing a particular type of I/O action as specified by
+the user. Fio can be driven by a 'job file' describing the I/O
+load one wants to simulate.
+
+WWW: http://git.kernel.dk/