aboutsummaryrefslogtreecommitdiff
path: root/sysutils/flexbackup/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-02-23 06:59:16 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-02-23 06:59:16 +0000
commite53b318dac7fbfda82ceca9af30fac7adbf93710 (patch)
tree1c14509d5eb3209f10d4d1fc940fab254f70c784 /sysutils/flexbackup/Makefile
parent44248a358c2df6599b6ca7cd13fac648a404cc53 (diff)
downloadports-e53b318dac7fbfda82ceca9af30fac7adbf93710.tar.gz
ports-e53b318dac7fbfda82ceca9af30fac7adbf93710.zip
Notes
Diffstat (limited to 'sysutils/flexbackup/Makefile')
-rw-r--r--sysutils/flexbackup/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/sysutils/flexbackup/Makefile b/sysutils/flexbackup/Makefile
index 95ffd4f595f0..e21cccac32df 100644
--- a/sysutils/flexbackup/Makefile
+++ b/sysutils/flexbackup/Makefile
@@ -6,25 +6,31 @@
#
PORTNAME= flexbackup
-PORTVERSION= 0.9.8
-PORTREVISION= 1
+PORTVERSION= 1.0.2
CATEGORIES= sysutils
MASTER_SITES= http://www.edwinh.org/flexbackup/tarball/ \
- ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= system/backup
+ http://www.reynoldsnet.org/flexbackup/tarball/
MAINTAINER= johnjen@reynoldsnet.org
-COMMENT= Perl-based, flexible tape backup system that uses dump, cpio, or afio
+COMMENT= Perl-based flexible tape backup system that uses dump/afio/cpio/tar
RUN_DEPENDS= afio:${PORTSDIR}/sysutils/afio \
- buffer:${PORTSDIR}/misc/buffer \
- gtar:${PORTSDIR}/archivers/gtar
+ buffer:${PORTSDIR}/misc/buffer
+
+.if defined(WITH_GTAR)
+RUN_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
+.endif
NO_BUILD= yes
USE_PERL5= yes
-post-patch:
- @${PERL} -pi -e "s|tar --|gtar --|g" ${WRKSRC}/flexbackup
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you are using and older version of FreeBSD that does not have GNU Tar"
+ @${ECHO_MSG} "imported as the system 'tar,' configure this port using WITH_GTAR=yes"
+ @${ECHO_MSG} "to enable the port dependency and use the 'path' variable in the"
+ @${ECHO_MSG} "flexbackup.conf file to point to 'gtar'"
+ @${ECHO_MSG} ""
post-configure:
@${CP} ${WRKSRC}/flexbackup.conf ${WRKSRC}/flexbackup.conf.sample