aboutsummaryrefslogtreecommitdiff
path: root/sysutils/freeipmi/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2007-09-10 11:47:49 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2007-09-10 11:47:49 +0000
commit765eb1f171551dc6c6785bf816ec6229073525a0 (patch)
tree76b30f1277a10e02abc946fb03a5c1bf884a16b7 /sysutils/freeipmi/Makefile
parent3d85064cc11f5e39f547889ca24aa3d9b34e24d4 (diff)
Notes
Diffstat (limited to 'sysutils/freeipmi/Makefile')
-rw-r--r--sysutils/freeipmi/Makefile47
1 files changed, 33 insertions, 14 deletions
diff --git a/sysutils/freeipmi/Makefile b/sysutils/freeipmi/Makefile
index 04f4ee7bfaae..d4ccc6fca19d 100644
--- a/sysutils/freeipmi/Makefile
+++ b/sysutils/freeipmi/Makefile
@@ -10,7 +10,7 @@
#
PORTNAME= freeipmi
-PORTVERSION= 0.3.3
+PORTVERSION= 0.4.3
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.zresearch.com/pub/freeipmi/${PORTVERSION}/ \
ftp://ftp.riss-telecom.ru/pub/mirrors/ftp.zresearch.com/pub/freeipmi/${PORTVERSION}/
@@ -25,21 +25,41 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+= --disable-init-scripts --disable-logrotate-config
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ PTHREAD_LIBS=-pthread
+CONFIGURE_ARGS+= --disable-init-scripts --disable-logrotate-config \
+ --localstatedir=/var \
+ --with-ipmipower-config-file=${PREFIX}/etc/ipmipower.conf \
+ --with-ipmi-monitoring-sdr-cache-dir=${CACHE_DIR}/ipmimonitoringsdrcache \
+ --with-ipmi-monitoring-sensor-config-file=${PREFIX}/etc/ipmi_monitoring_sensors.conf \
+ --with-ipmidetect-config-file=${PREFIX}/etc/ipmidetect.conf \
+ --with-ipmidetectd-config-file=${PREFIX}/etc/ipmidetectd.conf
USE_LDCONFIG= yes
NOT_FOR_ARCHS= ia64 sparc64 alpha
PLIST_SUB+= FREEIPMI_SHLIBVER=${FREEIPMI_SHLIBVER} \
- IPMICONSOLE_SHLIBVER=${IPMICONSOLE_SHLIBVER}
-MAN5+= ipmipower.conf.5 bmc-config.conf.5 ipmiconsole.conf.5
+ IPMICONSOLE_SHLIBVER=${IPMICONSOLE_SHLIBVER} \
+ IPMIDETECT_SHLIBVER=${IPMIDETECT_SHLIBVER} \
+ IPMIMONITORING_SHLIBVER=${IPMIMONITORING_SHLIBVER} \
+ CACHE_DIR=${CACHE_DIR} LOG_DIR=${LOG_DIR} RUN_DIR=${RUN_DIR}
+MAN3+= libipmiconsole.3 libipmimonitoring.3 libipmidetect.3
+MAN5+= ipmipower.conf.5 bmc-config.conf.5 ipmiconsole.conf.5 \
+ ipmidetect.conf.5 ipmidetectd.conf.5
MAN8+= bmc-watchdog.8 ipmipower.8 ipmi-raw.8 ipmi-sel.8 \
ipmi-sensors.8 ipmi-locate.8 bmc-info.8 ipmiping.8 \
- rmcpping.8 bmc-autoconfig.8 bmc-config.8 ipmiconsole.8
-INFO+= freeipmi freeipmi-faq
+ rmcpping.8 bmc-autoconfig.8 bmc-config.8 ipmiconsole.8 \
+ ipmi-fru.8 pef-config.8 ipmimonitoring.8 ipmi-chassis.8 \
+ ipmidetect.8 ipmidetectd.8
+INFO+= freeipmi-faq
PORTDOCS= *
+PORTEXAMPLES= *
-FREEIPMI_SHLIBVER= 3
-IPMICONSOLE_SHLIBVER= 0
+CACHE_DIR?= /var/db/${PORTNAME}
+LOG_DIR= /var/log/${PORTNAME}
+RUN_DIR= /var/lib/${PORTNAME}
+FREEIPMI_SHLIBVER= 4
+IPMICONSOLE_SHLIBVER= 1
+IPMIDETECT_SHLIBVER= 0
+IPMIMONITORING_SHLIBVER= 0
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -53,18 +73,17 @@ BROKEN= missing getpw*_r functions in this FreeBSD release
# ports. Note: there is a bug in FreeBSD 5 before 5.5-RELEASE that
# causes SIGBUS to the process sometimes when i386_set_ioperm is used
# (PR 84842).
-.if ${ARCH} == "i386" && (defined(WITH_IOPERM) || \
- ${OSVERSION} < 500000 || ${OSVERSION} >= 505000)
+.if ${ARCH} == "i386" && defined(WITH_IOPERM)
CPPFLAGS+= -DUSE_IOPERM
.endif
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
+CONFIGURE_ARGS+= --enable-debug --enable-trace
STRIP= # empty
.endif
post-install:
- @${CHMOD} 0700 ${PREFIX}/var/log/freeipmi \
- ${PREFIX}/var/lib/freeipmi
+ @${MKDIR} ${LOG_DIR}
+ @${CHMOD} 0700 ${CACHE_DIR} ${LOG_DIR} ${RUN_DIR}
.include <bsd.port.post.mk>