aboutsummaryrefslogtreecommitdiff
path: root/sysutils/freeipmi
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-10-06 01:49:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-10-06 01:49:56 +0000
commit63b89cc822d612629622a6d1cb2d54c987892990 (patch)
treec26794f26f16a2fcc82bb26d0775953863b9b959 /sysutils/freeipmi
parent4ef8581d04881ea1b0dc323ce3714a9bceb21678 (diff)
downloadports-63b89cc822d612629622a6d1cb2d54c987892990.tar.gz
ports-63b89cc822d612629622a6d1cb2d54c987892990.zip
Notes
Diffstat (limited to 'sysutils/freeipmi')
-rw-r--r--sysutils/freeipmi/Makefile16
-rw-r--r--sysutils/freeipmi/distinfo6
-rw-r--r--sysutils/freeipmi/files/patch-libfreeipmi-src-driver-ipmi-kcs-driver.c11
-rw-r--r--sysutils/freeipmi/pkg-plist2
4 files changed, 24 insertions, 11 deletions
diff --git a/sysutils/freeipmi/Makefile b/sysutils/freeipmi/Makefile
index fbead9011593..417e9125d86f 100644
--- a/sysutils/freeipmi/Makefile
+++ b/sysutils/freeipmi/Makefile
@@ -8,11 +8,11 @@
#
# WITH_DEBUG - Enable debugging features.
# WITH_IOPERM - Use i386_set_ioperm(2) instead of io(4) to gain access
-# to I/O ports (i386 only).
+# to I/O ports (i386/amd64 only).
#
PORTNAME= freeipmi
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.10
CATEGORIES= sysutils
MASTER_SITES= GNU/${PORTNAME}/ \
http://ftp.gluster.com/pub/${PORTNAME}/${PORTVERSION}/ \
@@ -24,13 +24,13 @@ COMMENT= Library and tools to support IPMI-capable hardware
LIB_DEPENDS= argp:${PORTSDIR}/devel/argp-standalone \
gcrypt:${PORTSDIR}/security/libgcrypt
-CONFIGURE_ARGS+=--disable-init-scripts \
+CONFIGURE_ARGS= --disable-init-scripts \
--disable-logdir \
--disable-logrotate-config \
--localstatedir=/var \
--sysconfdir=${CONF_DIR} \
--with-ipmi-monitoring-sdr-cache-dir=${CACHE_DIR}/ipmimonitoringsdrcache
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" PTHREAD_LIBS=${PTHREAD_LIBS}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" PTHREAD_LIBS=${PTHREAD_LIBS}
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -41,7 +41,7 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
OPTIONS= DEBUG "Debugging features" off \
- IOPERM "Use i386_set_ioperm (i386 only)" off
+ IOPERM "Use i386_set_ioperm (i386/amd64 only)" off
INFO= freeipmi-faq
MAN3= libfreeipmi.3 libipmiconsole.3 libipmidetect.3 libipmimonitoring.3
@@ -78,10 +78,10 @@ CONFIGURE_ARGS+=--enable-debug --enable-trace
.endif
.if defined(WITH_IOPERM)
-.if ${ARCH} == "i386"
-CPPFLAGS+= -DUSE_IOPERM
+.if ${ARCH} == "amd64" && ${OSVERSION} < 800000
+BROKEN= IOPERM option is not available on FreeBSD/amd64 7.x and below
.else
-BROKEN= IOPERM option is only available on i386 and You are building for ${ARCH}
+CPPFLAGS+= -DUSE_IOPERM
.endif
.endif
diff --git a/sysutils/freeipmi/distinfo b/sysutils/freeipmi/distinfo
index b53829494e15..ce163309acc0 100644
--- a/sysutils/freeipmi/distinfo
+++ b/sysutils/freeipmi/distinfo
@@ -1,3 +1,3 @@
-MD5 (freeipmi-0.8.9.tar.gz) = 5c729b91e229c3ed3cd1d568195a2d26
-SHA256 (freeipmi-0.8.9.tar.gz) = 8c1c18d83b74e2f657b7c6ccbc6be8eb2c0270d7c0424105bee34fdebe794ea0
-SIZE (freeipmi-0.8.9.tar.gz) = 2775329
+MD5 (freeipmi-0.8.10.tar.gz) = 6023e592e083d27cafa3442f2b8e0322
+SHA256 (freeipmi-0.8.10.tar.gz) = 6fea041746728403cb21d8649aa9bd77e6482da50a2c8c5f9cef9b25f0497862
+SIZE (freeipmi-0.8.10.tar.gz) = 2815418
diff --git a/sysutils/freeipmi/files/patch-libfreeipmi-src-driver-ipmi-kcs-driver.c b/sysutils/freeipmi/files/patch-libfreeipmi-src-driver-ipmi-kcs-driver.c
new file mode 100644
index 000000000000..8c90c02aa7e0
--- /dev/null
+++ b/sysutils/freeipmi/files/patch-libfreeipmi-src-driver-ipmi-kcs-driver.c
@@ -0,0 +1,11 @@
+--- libfreeipmi/src/driver/ipmi-kcs-driver.c.orig 2010-09-29 05:11:01.000000000 +0800
++++ libfreeipmi/src/driver/ipmi-kcs-driver.c 2010-10-01 17:51:46.000000000 +0800
+@@ -485,7 +485,7 @@
+ #ifdef __FreeBSD__
+ #ifdef USE_IOPERM
+ /* i386_set_ioperm has known problems on FBSD 5.x (bus errors). */
+- if (i386_set_ioperm (ctx->driver_address, 0x02, 0x01))
++ if (sysarch (I386_SET_IOPERM, (void *) (ctx->driver_address, 0x02, 0x01)))
+ {
+ KCS_ERRNO_TO_KCS_ERRNUM (ctx, errno);
+ return (-1);
diff --git a/sysutils/freeipmi/pkg-plist b/sysutils/freeipmi/pkg-plist
index ecb173dae516..9782e4a63132 100644
--- a/sysutils/freeipmi/pkg-plist
+++ b/sysutils/freeipmi/pkg-plist
@@ -50,6 +50,7 @@ include/freeipmi/interface/rmcp-interface.h
include/freeipmi/locate/ipmi-locate.h
include/freeipmi/record-format/ipmi-cipher-suite-record-format.h
include/freeipmi/record-format/ipmi-fru-information-record-format.h
+include/freeipmi/record-format/ipmi-sdr-oem-record-format.h
include/freeipmi/record-format/ipmi-sdr-record-format.h
include/freeipmi/record-format/ipmi-sel-record-format.h
include/freeipmi/sdr-cache/ipmi-sdr-cache.h
@@ -115,6 +116,7 @@ include/freeipmi/templates/ipmi-messaging-support-cmds-templates.h
include/freeipmi/templates/ipmi-pef-and-alerting-cmds-templates.h
include/freeipmi/templates/ipmi-rmcpplus-interface-templates.h
include/freeipmi/templates/ipmi-rmcpplus-support-and-payload-cmds-templates.h
+include/freeipmi/templates/ipmi-sdr-oem-record-format-templates.h
include/freeipmi/templates/ipmi-sdr-record-format-templates.h
include/freeipmi/templates/ipmi-sdr-repository-cmds-templates.h
include/freeipmi/templates/ipmi-sel-cmds-templates.h