aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-chironfs
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-04-07 12:36:45 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-04-07 12:36:45 +0000
commit212b164b3ff661ceb4773e18a7002f2a8284a339 (patch)
treec401c0e5385bebe0e1e94237540a1c387ab9c3fe /sysutils/fusefs-chironfs
parentd83531ddee46ca9a8689fd66d006c879061cdb79 (diff)
Notes
Diffstat (limited to 'sysutils/fusefs-chironfs')
-rw-r--r--sysutils/fusefs-chironfs/Makefile37
-rw-r--r--sysutils/fusefs-chironfs/distinfo3
-rw-r--r--sysutils/fusefs-chironfs/pkg-descr7
3 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/fusefs-chironfs/Makefile b/sysutils/fusefs-chironfs/Makefile
new file mode 100644
index 000000000000..d515dfff35a8
--- /dev/null
+++ b/sysutils/fusefs-chironfs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fusefs-chironfs
+# Date created: 2008-04-06
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chironfs
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A FUSE based filesystem with replication at the filesystem level
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+
+# chironfs doesn't really depend on iconv, however, there are some undefined
+# references in libfuse, so we have to add USE_ICONV=yes to fix it.
+USE_ICONV=yes
+
+PLIST_FILES= bin/chironfs
+PORTDOCS= *
+MAN8= chironfs.8
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 # Inherited from sysutils/fusefs-kmod
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-chironfs/distinfo b/sysutils/fusefs-chironfs/distinfo
new file mode 100644
index 000000000000..abf02615f9ac
--- /dev/null
+++ b/sysutils/fusefs-chironfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (chironfs-1.0.0.tar.gz) = ce3e8944b3a61c0a6227c12e234dcaa4
+SHA256 (chironfs-1.0.0.tar.gz) = d05dfd7b15ade7f881464a78c176526f086571a7f15948214686349f0e9a86f9
+SIZE (chironfs-1.0.0.tar.gz) = 400809
diff --git a/sysutils/fusefs-chironfs/pkg-descr b/sysutils/fusefs-chironfs/pkg-descr
new file mode 100644
index 000000000000..82ce3ebaf423
--- /dev/null
+++ b/sysutils/fusefs-chironfs/pkg-descr
@@ -0,0 +1,7 @@
+Chiron FS is a FUSE based filesystem which implements replication at the
+FILESYSTEM LEVEL like RAID 1 does at the DEVICE LEVEL. The replicated
+filesystems may be of any kind you want the only requisite is that you
+mount it. No need for special configuration files, the setup is as simple
+as one mount command (or one line in fstab).
+
+WWW: http://code.google.com/p/chironfs/