aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-curlftpfs
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2010-01-08 20:02:31 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2010-01-08 20:02:31 +0000
commitd708c52834cc5a8e5d4b8f2235539770a2e3119e (patch)
tree486dda1a2e984dd289f2c3bf3aaece4a14af1eb0 /sysutils/fusefs-curlftpfs
parent6b221d9c1c94eba8406f16ed01ad0b5c2639c872 (diff)
downloadports-d708c52834cc5a8e5d4b8f2235539770a2e3119e.tar.gz
ports-d708c52834cc5a8e5d4b8f2235539770a2e3119e.zip
Notes
Diffstat (limited to 'sysutils/fusefs-curlftpfs')
-rw-r--r--sysutils/fusefs-curlftpfs/Makefile2
-rw-r--r--sysutils/fusefs-curlftpfs/files/patch-ftpfs.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/sysutils/fusefs-curlftpfs/Makefile b/sysutils/fusefs-curlftpfs/Makefile
index d1e651117409..43c2a9d14922 100644
--- a/sysutils/fusefs-curlftpfs/Makefile
+++ b/sysutils/fusefs-curlftpfs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= curlftpfs
PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= SF
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c b/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c
new file mode 100644
index 000000000000..42f6e1c4ee12
--- /dev/null
+++ b/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c
@@ -0,0 +1,19 @@
+--- ./ftpfs.c.orig 2008-04-30 01:05:47.000000000 +0200
++++ ./ftpfs.c 2010-01-08 19:14:39.000000000 +0100
+@@ -611,10 +611,12 @@
+ curl_easy_cleanup(fh->write_conn);
+ g_free(fh->full_path);
+ g_free(fh->open_path);
+- sem_destroy(&fh->data_avail);
+- sem_destroy(&fh->data_need);
+- sem_destroy(&fh->data_written);
+- sem_destroy(&fh->ready);
++ if (fh->data_avail) {
++ sem_destroy(&fh->data_avail);
++ sem_destroy(&fh->data_need);
++ sem_destroy(&fh->data_written);
++ sem_destroy(&fh->ready);
++ }
+ free(fh);
+ }
+